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Course Overview
Course Description

This course is designed to teach the new animation user how to produce 
animated movies.

The MicroStation V8i for Animation course requires knowledge of MicroStation 
3D. While it is intended for users with beginner through intermediate skills, it 
covers many advanced topics as well. Even an expert animator can learn valuable 
tips and tricks to improve animations. 

Note: This course covers Animation only, not rendering, which is a separate course. 
This course does not cover 3D modeling. We recommend that you use the 3D 
Warehouse for 3D objects. You can access the 3D Warehouse from within 
MicroStation by selecting Utilities > 3D Warehouse.

This course assumes you know nothing about Animation. It starts out slowly, 
covering important basics, and then progresses to more advanced topics. The 
course is presented in order of importance, beginning with three basic 
requirements for Animation; Keyframing, Actors, and Animation Cameras, which 
are different than the regular MicroStation camera.
Oct-13 7 Course Overview
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Target Audience
Target Audience

This course is recommended for the following audience(s):

• Architects

• Engineers

• Designers

• Visualization Specialists

Prerequisites
• Knowledge of MicroStation V8i Interface

• Knowledge of 3D tools, methods, and view controls

• Basic knowledge of Luxology rendering

• Basic understanding of computer generated animation

Course Objectives

After completing this course, you will be able to:

• Create and use actors

• Control actors through hierarchy and parametric animation

• Animate cameras

• Create and record scripts

Modules Included

The following modules are included in this course:

• Course Overview

• Animation Overview

• Keyframing

• Animating Actors
Course Overview 8 Oct-13
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Modules Included
• Actor Hierarchy

• Parametric Animation

• Animating Cameras

• Traffic Simulation

• Animating Lights

• Animating Materials

• Scripts
Oct-13 9 Course Overview
Copyright © 2013 Bentley Systems, Incorporated



Modules Included
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Animation Overview
Module Overview

This module contains an overview discussing what animation is, as well as a brief 
explanation of the various types of video formats and output.

Module Prerequisites
• Understanding of basic MicroStation functionality

• Understanding of MicroStation models

• Fundamental knowledge about 3D tools and view controls

Module Objectives

After completing this module, you will be able to:

• Understand video standards

• Use KeyFrame animation tools

• Create a basic KeyFrame animation
Oct-13 11 Animation Overview
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Animation Overview
Animation Overview

When you think of animation, one of the first things that comes to mind are 
cartoons. By drawing pictures with successive movement of objects, the cartoons 
appear to come to life. Cartoons today are typically created on a computer and 
some of the in-between pictures or frames are computed rather than drawn by 
hand. 

What all forms of cartoon animation have in common is that they create 
perceived motion by showing successive frames at a relatively high speed. 
Computer cartoon animation usually shows 10-20 frames per second. By 
comparison, traditional hand-drawn animation uses anywhere from 8 frames per 
second (for poor quality animation), 12 frames per second (for standard 
animation), or 24 frames per second (for short bursts of smooth, realistic motion).

Human visual accuracy is limited to about 12 images per second. If you see more 
than 12 images per second, the brain thinks it is seeing continuous motion. If you 
see fewer than 12 images per second, the brain knows it is looking at single 
images presented rapidly.

When animating with MicroStation you will find that MicroStation does most of 
the work for you. You must only think about key events, or points in time, and 
then script these events to occur. MicroStation determines the in-between frames 
and interpolates positions based on the parameters you describe.

Animation is a helpful tool that helps you see exactly what is happening in a 
dynamic design. Whether you are doing a walk-thru of a building or plant, or 
showing how to remove a piece of equipment, animation can make the process 
clear. It can be valuable to animate in 2D to show a progression of events.
Animation Overview 12 Oct-13
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Video or Movie Output
Video or Movie Output

MicroStation can handle a smooth 30 frames/sec and at a DVD quality resolution. 
Since most of your animation work will be played back on a PC, the final output 
can be converted to MPEG-1 or MPEG-2 format suitable for playback on a desktop 
or laptop system. MPEG (pronounced M-peg), stands for Moving Picture Experts 
Group, and is the name of the family of standards used for coding audio-visual 
information in a digital compressed format. The major advantage of MPEG 
compared to other formats is that MPEG files are much smaller but have good 
quality. This is due to the sophisticated compression techniques that the MPEG 
format uses.

You will be recording at 30 frames or images per second. When you play your 
animations back using Windows Media Player, they will play at 30 frames per 
second.

You can choose from several digital formats when creating animations to be 
played back on a computer. There is the Microsoft AVI format that can be 
configured to use a variety of compression/decompression routines or codecs. 
You also can choose Windows Media Video movie format, or WMV format.

If you intend to create video for playback on a television, MicroStation’s Animator 
can output to HDTV, NTSC or PAL standard size frames and also supports 
interlaced field rendered frames.

While the MicroStation Movie Player can create movies in various formats from 
your rendered frames we recommend that you consider using a professional Non- 
Linear Editing NLE software program such as Adobe Premiere for editing your 
video. If you want to create professional quality movies that have soundtracks and 
other effects such as fades you will want to invest in a good NLE program.

Video Standards

NTSC

NTSC stands for National Television System Committee, which devised the NTSC 
television broadcast system in 1953. NTSC is also commonly used to refer to one 
type of television signal that can be recorded on various tape formats such as 
VHS, 3/4” U-matic and Betacam. 
Oct-13 13 Animation Overview
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Video Standards
The NTSC standard has a fixed vertical resolution of 525 horizontal lines stacked 
on top of each other, with varying amounts of “lines” making up the horizontal 
resolution, depending on the electronics and formats involved. There are 59.94 
fields displayed per second. A field is a set of even lines or odd lines. The odd and 
even fields display sequentially, interlacing the full frame. One full frame is made 
of two interlaced fields, and displays about every 1/30 of a second. THe remaining 
0.06 fields/sec are used for time correction.

NTSC format is used in North and South America, with the exception of Brazil 
which uses a modified version of PAL.

PAL

PAL stands for Phase Alternation by Line, and was adopted in 1967. It has 525 
horizontal lines making up the vertical resolution. Fifty fields display and interlace 
per second, making a 25 frame per second system. An advantage of this system is 
a more stable and consistent hue (tint). PAL-M is used only in Brazil. It has 525 
lines, at 30 frames per second. 

The PAL format is used in most of Europe, Africa and Asia, including Australia.

HDTV

HDTV - High-definition television is a television broadcasting system with a 
significantly higher resolution than traditional formats (NTSC, SECAM, PAL) allow. 
HDTV is broadcast digitally.

While a number of high-definition television standards have been proposed or 
implemented on a limited basis, the current HDTV standards are defined in ITU-R 
BT.709 as 1080 active interlaced or progressive lines, or 720 progressive lines, 
using a 16:9 aspect ratio. The term “high-definition” can refer to the resolution 
specifications themselves, or more loosely to media capable of similar sharpness, 
such as photographic film.
Animation Overview 14 Oct-13
Copyright © 2013 Bentley Systems, Incorporated



The Animation Task and Tools
The Animation Task and Tools

Following is an overview of the Animation tools and the interface used to create 
animations.

 Exercise: The animation interface

1 Launch MicroStation and 01_KeyFrameanimation.dgn.

2 From the Tasks dialog on the left side of the application window, click 
Animation.

The Animation task gives you access to all the animation tools, as well as 
basic drawing, 3D primitive, and visualization tools.

Important tools are the Animation Producer and Animation Preview tools, 
the Create and Manipulate Actor tools, and the KeyFrames dialog tool.

Note: You can right click on any tool and open the toolbox to which it belongs as an 
individual toolbox.

KeyFrame animation
Oct-13 15 Animation Overview
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The Animation Task and Tools
A KeyFrame is a moment in time where the locations of elements are explicitly 
specified. KeyFrame animation is a sequence of poses where each pose is slightly 
different than the first. This process is like creating a cartoon, where the cartoon 
character appears to be moving across the screen. This type of animation is the 
most basic of all animation methods. 

The following is a workflow for this type of animation.

These images are KeyFrames of a star, showing a starting pose, a middle pose, and 
end pose. 

 Exercise: Creating KeyFrames

1 Continuing in 01_KeyFrameanimation.dgn, from the Animation task, 
select the Animation Producer dialog tool.

Note: You may have to activate the license against your SELECTserver license 
before the dialog opens.

2 Select the star using the Element Selection tool.

3 In the Animation Producer dialog, select Tools > Named KeyFrames.
Animation Overview 16 Oct-13
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The Animation Task and Tools
4 In the Animation KeyFrames dialog, click Create.

5 In the Create KeyFrame dialog, type the name Star 1, add the Description, 
Pose 1 star, and then click OK. 

Note: It is important to create descriptions that will identify the scene or the 
action that takes place in a scene. These let you go back and easily 
review the purpose of a KeyFrame.

6 Click in the view or click Clear in the Element Selection tool settings to 
release the star.

7 Move the star’s left and right points upward using the Modify Element 
tool from the Main toolbox.

8 Select the star using the Element Selection tool.

9 In the Animation KeyFrames dialog, click Create. 

10 Type the name Star 2 and add the Description Pose points up.
Oct-13 17 Animation Overview
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The Animation Task and Tools
11 Using the same process, create pose 3 with the points in a downward 
position.

Scripting the KeyFrames

After you have created your KeyFrames, you must create a file that provides 
directions about what to do, and in what order, this is called a script. MicroStation 
will automatically create the transition images from one KeyFrame to another, 
involving movement, rotation, or element changes. This process is called 
tweening.

In the following exercise you will create a script file for the star.

 Exercise: Scripting the KeyFrames for the star

1 Continuing in KeyFrameanimation.dgn, in the Animation KeyFrames 
dialog, with the Start KeyFrame highlighted, click Script.

2 In the Script KeyFrame dialog, set the following, and then click OK:

Start Time: 0

Interpolation: Linear
Animation Overview 18 Oct-13
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The Animation Task and Tools
Velocity: Constant

Since Start is the first KeyFrame, the beginning of the animation, the start 
time is 0. In the following steps you will set the start time for the 
remaining KeyFrames.

3 Set the Script KeyFrame parameters for Star 2 as follows:

Start Time: 10

Interpolation: Linear

Velocity: Constant

4 Set the Script KeyFrame parameters for the Star 3 KeyFrame as follows:

Start Time: 20

Interpolation: Linear

Velocity: Constant

In the Animation Producer dialog, markers are placed in the timeline grid 
at the 0, 10, and 20 seconds. 

Hint: If you expand the Storyboard Panel in the Animation Producer dialog, all 
KeyFrames are listed.

5 In the Animation Producer dialog, select Settings > General make sure the 
following parameters are set:

In the Range section - End: 20

In the Preview section - Loop: Enabled

6 Close the dialog and also the Animation KeyFrames dialog.

7 From the Animation tasks, select the Animation Preview tool and dock the 
dialog at the bottom of the application window.
Oct-13 19 Animation Overview
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The Animation Task and Tools
8 Click Play in the Animator Preview dialog. 

The star appears as if it is trying to fly.

9 Click Pause Animation when you are done.

10 Create KeyFrames for the rocket and car. 

Remember, you can move, rotate, and modify an element for each 
KeyFrame.

11 When you are done, select File > Close from the main menu bar.
Animation Overview 20 Oct-13
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The Animation Preview and General Settings Dialogs
The Animation Preview and General Settings Dialogs

This dialog is used to play animations so you can see how they perform. There are 
controls on the right side of the dialog like those of typical video applications.

Above these, one field shows the elapsed time. Options to the right of this field 
let you select the view window in which you want to see the preview. There is also 
a tool to open the Animation Settings dialog.

The way the time is shown at the bottom of the Animator Preview dialog depends 
on the first Time Display setting in the Animation Settings dialog. You can choose 
to see hours, minutes and seconds along with frames, or just frames.

You can also set a data format. If your Time Display is set to a date style format, 
clicking the icon to the right of the field opens a Select Start Time dialog, which 
lets you select the month, year, and day.
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The Animation Preview and General Settings Dialogs
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Animating Actors
Module Overview

This module shows you how to create, manipulate, and animate elements that 
are automatically placed in a Named Group when you create an Actor. You will 
also learn how to record scripts and save animations to Adobe PDF files.

Module Prerequisites
• Complete the Animation Overview module

• Fundamental knowledge of 3D tools and view controls

• Fundamental knowledge about rendering

• Basic knowledge about AccuDraw

Module Objectives

After completing this module, you will be able to:

• Create animation actors

• Preview scripts

• Create 3D content in Adobe PDF

• Record animation scripts

• Use the Movie Player
Oct-13 23 Animating Actors
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Creating and Manipulating Actors
Creating and Manipulating Actors

Animation Actors

In an animation sequence, an Actor is a Named Group that is scripted to move, 
rotate, or scale in a controlled manner. The tools for creating and manipulating 
Actors are located in the Actors toolbox, which is opened from the Animation 
task.

Following is the workflow for creating an animation sequence using Actors:

 Exercise: Create an Actor and test its movement

1 Open 02_animateactors.dgn.

2 Use the Element Selection tool to select all geometry on the level Shock 
upper assy. 
Animating Actors 24 Oct-13
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Creating and Manipulating Actors
You must click the Show Extended Settings arrow in the Element Selection 
tool settings. Then just click the level name on the Level tab to select the 
elements.

3 From the Animation task, select the Create Actor tool, with the following 
tool settings:

Name: upper shock

Move Along: Z Enabled (X and Y are disabled)

4 Following the status bar prompt, snap origin to the center of the assembly 
in View 1, the Top view.

You can now test the Actor’s motion.

5 Select the Manipulate Actor tool with the following tool settings:

Move Actor: Enabled

Actor List: upper shock

The Actor highlights.

6 In View 2, move the pointer up and down.
Oct-13 25 Animating Actors
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Creating and Manipulating Actors
It will move along the Z-axis.

7 Reset when you have confirmed movement along the Z-axis.

Important: Do not accept with a data point or the element’s position will 
change. Reset after testing an Actor’s movement.

 Exercise: Create another Actor and test movement

1 Continuing in 02_animateactors.dgn,use Level Display to make the Spring 
level the active level and then turn off all other levels in View 4

2 Use Element Selection to select all the geometry on the level Spring.

3 From the Animation task, select the Create Actor tool with the following 
tool settings:

Name: spring (change the previous name)

Scale Along: Z enabled (X & Y disabled)

4 Snap to the green weighted point in View 4 and enter a data point to 
create the spring actor.

5 Select the Manipulate Actor tool with the following tool settings:

Scale Actor: Enabled
Animating Actors 26 Oct-13
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Creating and Manipulating Actors
Actor List: spring

Method: By Points

6 Drag the pointer along the Z-axis to test the scaled movement. The spring 
should appear to expand and compress about the origin

7 Reset after confirming scaling about the Z-axis.

As mentioned previously, Actors are grouped together in Named Groups. The 
following exercise shows you how to isolate the elements that comprise and actor 
using this fact.

 Exercise: Actors are Named Groups

1 Select Utilities > Named Groups from the main menu bar.

2 In the Named groups dialog, select one of the Actors.

3 Click the Select Elements in Named Group tool.

The elements that comprise the actor are selected.

4 Click on the Set DisplaySet from Selected Named Groups icon to isolate 
this geometry.
Oct-13 27 Animating Actors
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Creating and Manipulating Actors
Note: DisplaySet visibility is a View Attribute. You may easily create or clear a 
DIsplaySet by using Shift Right Click to bring up a context menu. You can also 
remove or add additional elements to the DisplaySet.

5 Enter a Shift Right Click and choose DisplaySet Clear.

Now you’ll create KeyFrames to give movement to the assembly.

 Exercise: Creating KeyFrames

1 Continuing in 02_animateactors.dgn, from the Animation tasks, click the 
KeyFrames tool.

2 Use the Element Selection tool and select the levels Shock upper assy and 
Spring.

3 In the Animation KeyFrames dialog, click Create, type the following, and 
then click OK:

Name: Up

Description: Shock in up position

4 Use the Element Selection tool to select only the Shock upper assy level.

5 Select the Manipulate Actor tool, with the following tool settings:

Move Actor: Enabled 

Actor List: upper shock

6 Move the upper assy 2.5 units along the negative Z-axis.

7 Enter a data point in View 3.

8 Select the Manipulate Actor tool, with the following tool settings:

Scale Actor: Enabled

Actor List: spring

Method: Active Scale
Animating Actors 28 Oct-13
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Creating and Manipulating Actors
Z Scale: 0.6

9 Enter a data point in View 3.

10 Use the Element Selection tool and select the Spring and Shock upper assy 
levels.

11 In the Animation KeyFrames dialog, click Create and type the following:

Name: Down

Description: Spring compressed

To make sure an actor always returns to a certain position, you can set a 
Freeze at that position.

12 Clear the selection set.

13 In the Animation KeyFrames dialog, select the Up KeyFrame and click 
Freeze to return the geometry to the uncompressed position at the end of 
the animation.

 Exercise: Scripting the KeyFrames using the Animation Producer Dialog

1 Continuing in 02_animateactors.dgn, in the Animation KeyFrames dialog, 
with the Up KeyFrame selected, click Script.

2 Set the following in the Script KeyFrame dialog, and then click OK:

Start Time: 0

Note: Since this is the beginning of an animation at frame 0, the Interpolation 
setting has no effect.

3 Script the Down KeyFrame as follows:

Start Time: 29

Velocity: Decelerate

4 Script the Up KeyFrame as follows:

Start Time: 59

Velocity: Decelerate

5 Select Settings > General in the Animation Producer dialog, and set the 
following:

Range section - End: 59

Preview section - Alternate Views: Enable the View 2 toggle and the Loop 
check box

6 Close the dialog.
Oct-13 29 Animating Actors
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Creating and Manipulating Actors
7 Preview the animation by clicking Start in the Animator Preview dialog.

Recording Animations

Select File > Record Script in the Animation Producer, or click the Record tool in 
the Animation task, to open the Record Script dialog. The dialog is used to set the 
file format and record the active script.

The workflow and important settings are discussed here.

Following is a typical workflow for recording an animation sequence.
Animating Actors 30 Oct-13
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Creating and Manipulating Actors
The dialog

Output File 

When opened, the active file is listed. Click the magnifying glass to select 
another output folder. The default folder is the \out folder in the project in 
which you are currently working.

Aspect 

Is set to 320X200 pixels by default, but common and custom settings are 
available from the option list.
Oct-13 31 Animating Actors
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Creating and Manipulating Actors
Note: When recording for playback on NTSC and PAL television systems, 
interlaced video is used. This means that each frame actually consists of 
two fields. Each field contains half of the frame scan lines, and only a 
single field is refreshed in each scan. An NTSC screen that displays 30 
frames per second will therefore display 60 fields per second.

Warning: Digital TVs and all computers that display all the scan lines in a frame 
simultaneously are very common today. This is referred to as non-
interlaced or Progressive Scan video. For video playback on 
computers you will alway see all the scan lines so progressive scan 
and not interlaced video is your only option. Unless you really plan 
to create a video for and old analog TV you should not use Field 
Rendering. As you can clearly see in the following image, you see 
both fields at once and where fast motion occurs you will see an 
obvious separation between the two fields.

Field Rendered Example frame

Resolution X,Y 

Custom resolution values can be entered but remember the larger the value 
the more memory and time it takes to render the animation sequence.

View 

Sets the View number for the view you want to record.
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Creating and Manipulating Actors
Gamma

Gamma correction of images is required to compensate for properties of 
human vision, and to maximize the displayed image relative to how humans 
perceive light and color. A setting of 1.0, means that no gamma correction is 
used. The settings range for the Animator output is from 0.01 - 3.0 a typical 
value for Luxology renderings would be 1.5 - 2.2.

Format

The preferable method for creating animation movies using MicroStation V8i 
(SELECTseries 3) is to save individual sequential frames. You will use the TIF 
(Tag Image File Format) in this Animation course. These files can be loaded 
into the Movie Player inside MicroStation V8i by selecting Utilities > Image > 
Movies. 
Creating individual frames is preferred because it provides greater flexibility. If 
you have an interruption in the rendering process, you can re-render the 
remaining frames using the same file name and sequence number. The 
remaining frames with incremental sequence numbers will be created. You do 
not have to re-render the entire project.

Compression

A lossy compression such as JPEG should never be used for rendered 
animation frames using Luxology. In the first place we render to a floating 
point image Bentley Image or BIMG file and these contain more information 
than can be displayed so they must first be Tone Mapped to be displayed in 
8bit RGB True Color and saved as TIFF or JPEG. More about BIMG files later 
but you are not doing yourself a favor saving frames as JPEG you might be 
saving some disk space but if you care about quality just say no to JPEG.

You might think that JPEGs are great and they are for saving static images but 
the truth is they introduce some artifacts or noise depending on the amount 
of lossy compression used. When you make your movie and create a media 
file such as Windows Media Video (WMV) or and AVI this introduces more 
artifacts. If you are old enough to remember VHS tape think what happened 
when you copied a movie and then copied the copy. The first copy was not as 
good as the original and the copy of the copy was even worse.

JPEG format:

• Minimum Loss

• Low Loss

• Medium Loss

• High Loss
Oct-13 33 Animating Actors
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Creating and Manipulating Actors
TIFF format

• PackBits Compression - (Popular Macintosh format also used by USGS 
for the DRGs)

• JPEG Compression - (A lossy compression method where some original 
data is lost)

• Deflate Compression - (Extended), (lossless compression that came 
from PKZIP)

• None (no compression)

Windows AVI

• DV Video Encoder - (typically used for Video Camcorder’s.)

• MJPEG Compressor - (Motion JPEG (M-JPEG) a class of video formats 
where each video frame or interlaced field of a digital video sequence 
is separately compressed as a JPEG image)

• Cinepak Codec by Radius - (Originally used with QuickTime but also 
used Microsoft Video for windows and MPEG-4)

• Intel IYUV codec - (a bit slow, older format but works with many 
applications)

• Microsoft RLE - (Run Length Encoding simple compression method)

• Microsoft Video 1 - (MS-CRAM early video compression codec, 
Microsoft Video for Windows 1.0)

• TechSmith Screen Capture Codec - (Used with Camtasia but not always 
compatible with other applications)

Windows WMV

• Windows Media Video 9 Screen - (high compression used for capturing 
computer display Media player 7 or later))

• Windows Media Video V7 - (Windows XP 7.0)

• Windows Media Video 9 Image - (Media player 7 or later)

• Windows Media Video 9.1 Image - (Media player 7 or later)

• Windows Media Video V8 - (Media player 8.1)

• Windows Media Video 9 - (Media Player 6.4 or higher, Mac OS, media 
player 9.1 Pocket PC and Smartphone)

• Windows Media Video 9 Advanced Profile (Media player 7 or later)

All others Formats use a Default compression for the specific format.
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Creating and Manipulating Actors
Mode

Determines the number of colors in the output file.

Render Mode

All Render Modes have a Light Setup and options for setting Antialias but 
only Luxology provides Render, Light and Environment Setup options. In 
Luxology the Antialias value is set in the Render Settings dialog.

Record Range

If on, you can select the start and End time for your recording. For example 1-
30 records frames 1 through 30, 1,25 records frames 1 and 25 and 1,25-30 
records 1 and frames 25 through 30.

Field Rendering

Enable only for interlaced video for NTSC or PAL video formats. Do not use this 
option if you intend to make videos for playback on your computer.

Motion Blur

If on, motion blur is rendered by Luxology. Motion blur is the effect of 
“blurring” objects as they move on the screen, giving them a smooth and 
more realistic appearance of motion. It is recommended that you use motion 
blur this will prevent stuttering especially where the motion is fast. Motion 
Blur requires that Anti-aliasing be enabled in the render setup where higher 
quality Antialias settings produce smoother blurring at the expense of render 
time.

Motion Blur enabled
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Stereo

If on, creates a 3D animation with a stereo effect that is visible when viewed 
with 3D (Red/Blue) glasses. Can also be set to render side by side stereo pairs 
for display with active (shutter glasses) or passive (polarized glasses).

Record Selection

If on, lets you define a range of frames/times to record

Use Distributed Rendering

This is enabled if a valid shared directory is identified. If enabled it allows 
Distributed Rendering (DR) when rendering the animation frames to disk. 
When DR is used to render animation frames each machine renders a 
complete frame whereas participating machines render buckets or portions of 
an image when DR is used for rendering a still image.

Include This Session

If on, the current session of MicroStation will contribute to the rendering. If 
off Luxology renders will always include the session regardless but for any 
other display style the current session will not be used to compute frames.

Hint: Unchecked this when you wish to use the current MicroStation session for 
other work and your animation frames are not using Luxology for rendered 
output.

 Exercise: Record a script for the shock animation using Luxology rendering

1 Continuing in 02_animateactors.dgn, click in View 2 to make it the active 
view.

2 Click Record in the Animation tasks.

3 In the Record Script dialog, set the following:

Output File: Use the default or select a location you will remember

Aspect: 640 X 480

Format: Tag Image File Format 

Compression: None

Mode: 24 Bit Color

Render Mode: Luxology

Render Setup: Exterior Good

Light Setup: 3:25PM
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Environment Setup: Sky Sphere

4 Click OK to begin recording.

Note: If you need to cancel recording, right click to enter a reset or press Ctrl + 
C on the keyboard.

5 When the final frame has been recorded, select Utilities > Image > Movies 
from the main menu bar.

6 In the Movies dialog, select File > Load, and navigate to your output file.

7 Select first frame 02_animateactors000.tif and play the movie.
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8 If the movie plays as expected, Pause it, select File > Save As and save it as 
Windows Media (WMV) (*.wmv) change the output name to shock.wmv.

9 Click on the wrench icon to adjust the WMV Bitrate, change it to 5000 and 
click OK. This will improve the quality but also increase the size of the 
movie.

10 Click OK on Save Movie as dialog to make the Window Media Video file.
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11 If available, launch Windows Media Player and open 
02_animateactor.wmv.
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Actor Hierarchy
Module Overview

This module explains how to edit scripts and create a hierarchy of Actor 
assemblies. The Actor assemblies are simply attached to each other in logical 
order. You will also learn how to create more advanced key framed animation.

Module Prerequisites
• Know how to create Actors

• Knowledge about 3D view controls and AccuDraw

Module Objectives

After completing this module, you will be able to:

• Attach actors to create assemblies

• Create a KeyFrame hierarchy

• Script animation using KeyFrames

• Preview animations

• Target Actors
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Actor Hierarchies

Actor hierarchies let you create more complex animation scripts by assembling 
Actors into hierarchical relationships. The ability to attach one actor to another is 
referred to as creating a parent-child relationship.

Create Desk Lamp Actors

In the following exercises you will create actors that make up a desk lamp. You will 
assemble them into a logical hierarchy, forming a parent child relationship. This 
makes it easier to create KeyFrames to animate the lamp.

 Exercise: Create and test the Shade Actor

1 Open 03_dlamp.dgn.

2 Maximize View 3 and Zoom In on the desk lamp.

The Center snap will make it easier to snap to the geometry and place 
origins.

3 From the main menu bar, select Settings > Snaps > Button Bar and dock 
the Button bar at the bottom of the application window.

4 Double click the Center snap to make it the active snap mode.

5 Use the Element Selection tool to select all the geometry on the 
Lampshade level including the construction elements.

6 Select the Create Actor tool, with the following tool settings:

Name: Shade

Rotate About: X and Y (Disable all other motion)
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7 Move the pointer over the sphere where the shade meets the red 
weighted line AccuSnap will snap to the center of the spherical socket.

8 Enter a data point to create the Actor.

9 Select Manipulate Actor with the following tool settings:

Rotate Actor (icon): Enabled

Actor List: Shade

Method: By Points

10 Enter a data point and move the pointer to test the actor’s motion, and 
then reset without entering another data point. Because the actor can 
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rotate about either the X or Y axis you can switch between the two axises 
by simply enabling the rotation you want in the Manipulate Actor Tool 
Settings.

Important: Remember to reset. Do not enter a data point when testing an Actor so 
you do not change its position.

You test Actors to make sure they are behaving as expected. If they are not, you 
can use the Modify Actor tool to change them. If an origin is not located correctly, 
you can move it with MicroStation’s Move tool to the correct location. 

 Exercise: Create more Actors for the lamp

1 Continuing in 03_dlamp.dgn, use Element Selection to select all geometry 
on the Upper arm level.

2 Select the Create Actor tool, with the following tool settings:

Name: Upper_arm

Rotate About: Y (Disable all other motion)

3 Identify the origin by snapping to the opposite end of the cylinder in View 
4, and then entering a data point.

4 Select Manipulate Actor, with the following tool settings:

Rotate Actor: Enabled

Actor List: Upper_arm

Method: By Points

5 Enter a data point and move the pointer to test the actor’s motion, and 
then reset without entering another data point.
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6 Use Element Selection to select all geometry on the level Lower arm level.

7 Select the Create Actor tool, with the following tool settings:

Name: Lower_arm

Rotate About: Y (Disable all other motion)

8 Move the pointer over the lower part of the arm, snap to the center, and 
enter a data point.

9 Use the Element Selection tool and select all geometry on the Base level.

10 Select Create Actor, with the following tool settings:

Name: Base

Rotate About: Z (Disable all other motion)

11 Enter a data point at the center of the base.

12 Test both Actors using the Manipulate Actor tool.
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All the Actors have been created for this animation. In the next section you will 
learn how to create an actor hierarchy for the desk lamp.

Assemble the Desk Lamp

Now that you have created Actors from the individual components of the desk 
lamp you must attach them together to create the hierarchy.

The Shade will become a child of the Upper_arm, the Upper_arm a child of the 
Lower_arm, and the Lower_arm a child to the Base. Whenever a parent is moved, 
the children under it will also move.

 Exercise: Creating a hierarchy using Animation Producer

1 Continuing in 03_dlamp.dgn, select the Animation Producer dialog tool.

2 In the Animation Producer’s Animation pane, click on the + sign next to 
Actors.

3 Click on the Shade actor and drag it to the Upper_arm Actor.

The Actors are nested.

4 Drag the Upper_arm Actor to the Lower_arm Actor.

5 Drag the Lower_arm Actor to the Base actor.

6 Select Manipulate Actor with the following tool settings:
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Rotate Actor: Enabled

Actor List: Upper_arm

Method: By Points 

7 Enter a data point over the Upper_arm and move the pointer to test the 
rotation. Notice how the shade now moves with the upper arm actor 
Reset.

8 Test the Lower_arm and the Base if you like, resetting when done.

Create KeyFrames

Now that you have created the actors and attached them to form a hierarchy, an 
assembly, you must position the lamp into several KeyFrame positions. Then you 
create a script. The goal is to have the lamp appear lifelike. The workflow follows.

You will create intermediate KeyFrames to prevent the lamp shade from hitting 
the table or the object sitting on the table. 

 Exercise: Create KeyFrames for the desk lamp

1 Continuing in 03_dlamp.dgn, select the KeyFrames dialog tool.

2 In the Animation KeyFrames dialog, click Create and click the desk lamp at 
the Base in View 2(this selects all the actors in the hierarchy) and accept 
with a data point.

3 In the Create KeyFrame dialog, set the following, and then click OK:

Name: Start
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Description: Initial position

The next KeyFrame will swing the lamp to the side.

4 Select the Manipulate Actor tool, with the following tool settings:

Rotate Actor: Enabled

Actor List: Base

Method: Active Angle set to 90 degrees

5 Enter a data point. 

The desk lamp rotates 90 degrees.

6 In the Animation KeyFrames dialog, click Create, enter a data point on the 
lamp base, and another to accept.

7 In the Create KeyFrame dialog set the following, and then click OK:

Name: p1

Description: Rotate base 90 degrees

For the next KeyFrame you will move the lower arm 20 degrees.

8 Select Manipulate Actor with the following tool settings:
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Actor List: Lower_arm 

Method: Active Angle set to 20 degrees

9 Enter a data point in the view.

10 In the Animation KeyFrames dialog, click Create, enter a data point on the 
lower arm, and another to accept.

11 Set the following in the Animation KeyFrames dialog, and then click OK:

Name: p2

Description: Rotate lower arm 20 degrees

The next KeyFrame requires you to make multiple moves within the same 
KeyFrame. You will rotate the Shade -45 degrees, the Base -20 degrees, and the 
Lower_arm -20 degrees.

 Exercise: Create more KeyFrames to create further motion

1 Continuing in 03_dlamp.dgn, select Manipulate Actor, with the following 
tool settings:

Actor List: Shade 

Method: Active Angle set to -45 degrees

2 Set Rotate to Y.

3 Enter a data point in the view.
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4 Change the following tool settings:

Actor List: Base

Method: Active Angle set to -20 degrees

5 Enter a data point in the view.

6 Change the following tool settings:

Actor List: Lower_arm

Method: Active Angle set to -20 degrees

7 Enter a data point in the view.

8 Create a KeyFrame of the desk lamp in this position using the parameters:

Name: p3

Description: Rotate all

9 Repeat the previous steps, using the following parameters:

Rotate the Upper_arm -35 degrees

Rotate the Lower_arm 20 degrees

Rotate the Shade By Points until it is pointing at the element on the desk. 
If want to use Active Angle you can rotate in Y 30 degrees and in X - 30 
degrees to get the shade pointed.

10 Create a KeyFrame of desk lamp in this position with 

Name: p4
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Description: Rotate toward element

11 Now, in the Animation KeyFrame dialog, select the Start KeyFrame and 
click Freeze. This moves the geometry back to the start position.

 Exercise: Create the desk lamp script

1 Continuing in 03_dlamp.dgn, click the Animation Producer tool.

2 In the Animation Producer dialog, select Settings > General and set the 
following:

Start: 00

End: 299

Note: Because the start time begins at frame zero you will have a total of 300 frames. 
The animation that you are creating is going to play at 30 frames per second 
with and end time set to 299 you are creating an animation that will be exactly 
10 seconds in length. 

3 In the Preview section check the option to Disable Intermediate Updates.
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Note: If want to see the frame number (Time) display in the view you can 
enable the Display Time In View option in the Animation Settings dialog.

4 Close the dialog.

5 In the Animation Producer dialog’s Animation pane, expand the list of 
KeyFrames by clicking on the +.

6 Right click the Start KeyFrame, select Script from the pop-up menu, set the 
following, and then click OK:

Start Time: 00

Interpolation: Linear

Velocity: Constant

7 Now script the rest of the KeyFrames as follows:

p1: Start Time set to 60

p2: Start Time set to 120

p3: Start Time set to 180
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p4: Start Time set to 299

 Exercise: Scaling a Script

1 Continuing in 03_dlamp.dgn, bring View 2 to the top.

2 Attach the Saved View Camera View to view 2.

3 Click the Animation Preview tool.

4 Click and drag the progress bar through time, watching the preview in 
View 2 and in the Animation Producer dialog. 

The blue time bar indicator moves along the Animation Producer’s 
timeline grid.

5 In the Animator Preview dialog, type 90 in the field above the Play button 
and press Enter.
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The Animation Producer’s time bar moves to frame 90 and the desk lamp 
is positioned at frame 90 in view 2.

6 From the Animation Producer dialog, select File > Scale Script.

7 Type 1.5 as the Scale Factor and click OK to scale the script.

There is no need to save a script, as it is continuously saved in the design file. If 
you want to create another script, you can create a new script or copy this script 
and edit it. If you want to edit the time that a KeyFrame occurs you can double 
click on the Type KeyFrame in the Animation Produce dialog to open the Edit 
KeyFrame dialog.
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You may also click on the green vertical bar in the Timeline window and drag it to 
move the time. If you hold the Ctrl key and drag you will make a copy of a 
KeyFrame, this is useful if you want to add a pause.

Clearing a script (File > Clear Script) will remove all actors and KeyFrames. If you 
want to keep actors and KeyFrames, creating a new script based on them, select 
File > Copy Script in the Animation Producer. If you want only actors, but no 
KeyFrames, create a New Script which retains actors but not KeyFrames.

Targeting Actors

In the next exercise you will make a minor change to the script for the desk lamp. 
By adding a target object and scripting the Shade actor to follow or remain 
focused on this target, you can have the shade always facing the object on the 
table.

 Exercise: Actors targeting Actors

1 Continuing in 03_dlamp.dgn,use the Element Selection tool to select the 
elements on the level structure.

You will make an actor out of this geometry.

2 Select Create Actor tool, with the following tool settings:

Name: Structure

Enable: Does not matter what is enabled here because you will not be 
manipulating the actor.

3 Place the origin at the top center of the structure. You may want to change 
to the Keypoint snap for this.

The origin of this Actor will be the target for the Shade Actor so it will 
swivel to remain focused on this point during the animation. You just need 
to add a line to the script for this to take place. First, you will copy the 
original script so that you have both versions.

4 In the Animation Producer dialog, select File > Copy Script.

5 In the Copy Script dialog, set the following, and then click OK:

Name: Focus lamp

Description: Structure track

6 From the Animation Task, Cameras toolbox, select the Script Target tool 
with the following tool settings:
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Start Time: 0

Interpolation: Linear

Velocity: Constant

Target Activated: Enabled

Object: Shade

Target: Structure

7 Enter a data point in any view to add this item to the script.

8 In the Animator Preview dialog, click the Play button to preview.

The desk lamp’s shade is in motion focusing on the structure Actor’s 
origin.

9 Select File > Close when you are done.
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Parametric Animation
Module Overview

This module will teach you how to animate actors using parameters that you 
define. It also shows how to use built-in mathematical functions to create more 
complex animations.

Module Prerequisites
• Know how to script Actors

• Understand what variables and functions are

Module Objectives

After completing this module, you will be able to:

• Use equations to control motion of Actors

• Apply parametric controls in Animation Scripts
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Parametric Motion Control

This type of animation method is useful when basic KeyFrame animation is very 
difficult or when the equation for a motion is already known. Motion control 
parameters are created in the Animation Parameters dialog.

Animation Parameters dialog

Parameters and equations are defined in the Animation Parameters dialog which 
you can open by selecting Tools > Parameters in the Animation Producer dialog.

MicroStation includes a number of built-in variables and functions for defining 
actor motion equations or custom parameters. When defining an equation, you 
can include custom parameters that you have previously defined, or you can key-
in the entire equation. The built-in variables and functions are case sensitive and 
must be typed exactly as shown. Case sensitivity also applies for any custom 
parameters you create.

Some parametric motion equations can often be used by a number of designs. 
You can save time by creating custom parameters that define these equations, 
and then using them when scripting your actors.

If parameters are used often, they should be saved in a separate script file that 
contains only those custom parameters. In the future, this script file can be 
included in a new script.

Built-in variables
These are available for developing actor motion equations, or developing 
custom parameters with the Script Actor tool.

Variable Description
frame Frame number

pi The mathematical value, Pi, which 
is the ratio of the circumference to 
its diameter

tSeconds Elapsed time from beginning of 
sequence in seconds

beginFrame Beginning frame of current 
sequence
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Built-in functions

These are available for developing actor motion equations or custom parameters 
with the Script Actor tool. These functions are identical to those in the standard C 
math library, except that all angular values are expected, and returned in degrees 
rather than radians.

endFrame End frame of current sequence

maxFrame maximum frame number 

Function Description
radiansFromDegrees(d) Radians from degrees

degreesFromRadians(r) Degrees from radians

secondsFromFrame(f ) seconds from frame number

cos(angle) Trigonometric cosine of angle

acos(value) Arc cosine of value

sin(angle) Sine of angle

asin(value) Arc sine of value

atan(value) Arc tangent of value

atan2(valueY, valueX) Arc tangent of valueY/valueX

tan(angle) Tangent of angle

cosh(value) Hyperbolic cosine of value

sinh(value) Hyperbolic sine of value

tanh(value) Hyperbolic tangent of value

exp(value) Exponential of x

log(value) Natural logarithm of value

log10(value) Base 10 logarithm of value

pow(x,y) x to y power

sqrt (value) Square root of value

fabs (value) Absolute value of

ceil(value) Smallest integer not less than 
value

floor(value) Largest integer not greater than 
value

fmod (value) Modulus of value

rand () Pseudo random number

srand(x) Set random seed

Variable Description
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Scripting an actor with a parametric equation

In the next exercise series, you will use two of the built-in variables, maxFrame 
and frame, which define the maximum frame number and the current frame 
number, respectively. You will write an equation that instructs the actor to rotate 
one revolution during the course of the animation sequence.

Note that cranking the winch handle one revolution would produce 2/3 revolution 
in the middle gear and 1/3 revolution in the winch’s drum, so you would need to 
crank the handle 3 revolutions to make one complete revolution of the winch 
drum.

 Exercise: Create custom motion control parameters

1 Open 04_winch.dgn.

2 Click the Animation Producer dialog tool.

3 From the Animation Producer dialog, select Settings > General and make 
sure the following are set:

Range section - End: 179

Preview section - Alternate Views: 2

4 Select Tools > Parameters.

5 In the Animation Parameters dialog, click Create, set the following, and 
then click OK:

Name: drum

Value: 360/maxFrame*frame

Description: revolution of drum

6 Create another parameter as follows, and then click OK:

Name: gear

Value: -drum*24/12

Description: reverse direction of drum at 24/12 speed
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This means that if the drum goes around once, this gear will make two 
revolutions in the same amount of time.

7 Create another parameter as follows, and then click OK:

Name: crank

Value: drum*24/8

Description: 24/8 drum speed

Look at the custom parameters you have created. All the motion is now 
tied to the winch drum motion. 

The middle gear rotates in the opposite direction of the crank and at a 
speed of 24/12, or 2x the drum speed. In other words, if you rotate the 
drum one revolution, the middle gear makes 2 revolutions in the opposite 
direction from the drum. The crank has 8 teeth and it is also tied to the 
drum motion. If you turn the drum one revolution, the crank turns in same 
direction as the drum and at 24/8 drum speed, or 3 revolutions.

You certainly could simplify the parameters. Instead of using 24/12 and 24/8, you 
could use 2 and 3, respectively. The numbers were chosen so you could see the 
relationship of the gears based on their tooth count.
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 Exercise: Create animation script using custom parameters

1 Continuing in 04_winch.dgn, from the Animation Actors toolbox, select 
the Script Actor tool.

2 Select the drum actor from the Actor List, set the following in the Script 
Actor dialog, and then click OK:

End: 179

X Rotation: drum

This is the value you set in the Animation Parameters dialog. In this 
example (360/maxFrame*frame) use 179, the total frames in this 
animation, and you will see that the drum rotates 2 degrees for each 
frame.

Note: The custom parameters you created are case sensitive, so if you used all 
capitals to create a parameter you must use all capitals to apply it in the 
Script Actor dialog.

3 Select the gear actor from the Actor List, set the following, and then click 
OK:

End: 179

X Rotation: gear

4 Select the crank actor from the Actor List, set the following, and then click 
OK:

End: 179

X Rotation: crank

5 Click Play in the Animator Preview dialog to preview the current script.

 Exercise: Edit custom motion control parameters

1 Continuing in 04_winch.dgn, in the Animation Producer dialog choose 
Tools > Parameters. The Animation Parameters dialog appears.

2 In the Animation Parameters dialog, double click the drum parameter to 
edit it, or select drum from the list and click Edit.

3 Change the Value to -3*360/maxFrame*frame and click OK.

This increases drum revolutions from 1 to 3 and also reverses the motion. 
Editing this one value causes the entire mechanism to reverse and speed 
up. The winch drum now makes three complete revolutions, but in the 
opposite direction from the previous animation.

4 Click Play in the Animator Preview dialog to preview the current script.
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As you can see, the animation plays in reverse and at 3 times the previous 
speed.

 Exercise Challenge: Create your own script with new parameters

1 Use new parameters that will link everything back to the motion of the 
crank, rather than the drum.

Hint: Hint in this scenario one turn of the crank would produce 1/3 of a 
revolution in the drum actor.

Important: Clearing the script will remove all actors and KeyFrames from the 
current script. If you want to keep the actors and KeyFrames and create new 
script based on these you should choose File > Copy Script from the Animation 
Producer. If you only want actors and no KeyFrames or parameters, you can 
choose to create new script, this retains actors, but not KeyFrames or 
parameters.

2 Select File > Close when you are done.

Animating a Clock with Parameters

In the next exercise series you will animate a clock and tie the motion together 
using a common parameter. To save time, the animation actors have already been 
created for this exercise.

 Exercise: Create clock animation parameters

1 Open 05_clock.dgn.

2 In the Animation Producer, select Tools > Parameters.
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3 Click Create, set the following, and then click OK:

Name: hour

Value: 360/maxFrame*frame

Description: 12 hours

4 Create another parameter as follows, and then click OK:

Name: minute

Value: hour*12

Description: 12 revolutions

5 Create another parameter as follows, and then click OK:

Name: rocking

Value: 15*sin(frame*30)

Description: pendulum rocking motion

Click OK to create the parameter.

 Exercise: Create a clock animation script

1 Continuing in 05_clock.dgn, from the Animation Actors toolbox, click the 
Script Actor tool.

2 Select the hour-hand actor from the Actor List, set the following, and then 
click OK:

End Time: 359

Y Rotation: hour 

3 Select the minute-hand actor from the Actor List, set the following, and 
then click OK:

End Time: 359

Y Rotation: minute 

4 Select the pendulum actor from the Actor List, set the following, and then 
click OK:
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End Time: 359

Y Rotation: rocking

5 Click Play in the Animator Preview dialog to preview the current script.

The animation preview is fast. To slow it down you can scale the script up by a 
factor. You can also edit the rocking parameter, creating a speed variable that lets 
you easily control the speed of the pendulum.

 Exercise: Editing the script and parameters 

1 Continuing in 05_clock.dgn, from the Animation Producer select File > 
Scale Script.

2 In the Scale Script dialog, set the following, and then click OK:

Scale Factor: Enabled

Scale: 10

The script is now 3590 frames long. The Scale Script dialog lets you scale 
by a factor and you can also change the duration in time or frames.

3 Click Play in the Animator Preview dialog to preview the current script.

The clock’s motion is slowed, but the pendulum’s motion is still a little too 
fast. You can edit the parameters you created earlier to slow it down.

You will create a new parameter that will allow you to easily adjust the 
speed of the rocking pendulum.

4 In the Animation Parameters dialog, click Create, set the following, and 
then click OK:

Name: ps

Value: 3

Description: pendulum speed

In the next step, you will edit the rocking motion equation to use the new 
parameter.

5 In the Animation Parameters dialog, double click rocking, set the following 
and then click OK:

Value: 15*sin(frame*ps) 

This replaces 30 with the new parameter.
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The portion of the parameter that effects the speed the pendulum swings 
now uses a variable, (ps) that you can edit to change the speed.

6 Click Play in the Animator Preview dialog to preview the current script.

7 Select File > Close when you are done.
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Module Overview

This module describes how to place animation cameras and how to attach a 
camera to path.

Module Prerequisites
• Understanding of 3D view controls

• Understanding of basic MicroStation procedures

• Knowledge about AccuDraw

Module Objectives

After completing this module, you will be able to:

• Place animation camera

• Attach cameras to paths

• Script cameras and targets

• Script animation targets using KeyFrames

• Preview animation

• Use a Velocity Graph

• Activate and deactivate targets
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Introduction to Animation Cameras

Animation cameras are specialized actors. Their motion can be controlled using 
KeyFrames, paths, or scripts the same as regular actors. They can also be 
manipulated with the Manipulate Actor tool or positioned with any of the 
standard manipulation tools. Camera Targets can be another actor, where the 
actor’s origin is the actual focal point for the target or you can use the create 
target tool to place predefined one.

You can have multiple targets and cameras in a design file but there can only be 
one camera on at any given time. You can however have MicroStation interpolate 
between two cameras, or targets to gradually transition from what one camera 
sees to what the other one sees even if they both are in motion.

You can use one or more animation cameras in an animation sequence by 
scripting each one to become active from a particular frame number. The 
animation view is taken from the designated camera, from the specified frame. 
Additionally, you can specify targets at which an animation camera is aimed.

MicroStation has pre-defined target and camera actors that can be placed and 
then renamed. 

Animation Camera tools

These tools are located in the Animation tasks. Tools are as follows.

• Create Animation Camera

• Modify Animation Camera

• Script Camera - use this tool to specify the frame number at which to 
begin using an animation camera

• Camera View - use this tool to show the view from an animation 
camera in a view window

• Create Target

• Script Target - use this tool to Specify the frame interval during which 
to use an animation camera target
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The Storyboard

Before the creation of any animation you should first consider the objectives of 
the animation. These objectives may be your own or are provided by others.

In the next exercise you are presented with an urban renewal project of the city of 
Long Beach and you will want to highlight some of the cities major landmarks. 
Here is a layout of most of the items to be highlighted in the animation. The 
camera path will show these individual landmarks in the animation.

Defining a Camera Path 

In the following exercise series, you will place an animation camera and then use 
the Define Actor Path tool to attach the camera to a B-spline path.

 Exercise: Create a camera animation

1 Open 06_Longbeach.dgn.

2 Open View 5.

In this view, Camera path is the active level and the other levels are not 
displayed to make placement easier

3 From the Animation tasks select the Create Animation Camera tool with 
the following tool settings.

Standard Lens: Wide 

Cell Scale: 1000 
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4 Snap to the B-spline curve at the pole on the right end, as shown, enter a 
data point, move the pointer to the second pole and enter another data 
point.

5 Set the following in the Create Camera dialog, and then click O:

Name: Main Camera

Description: Flying camera

Hint: The Description is optional, but can be very helpful when you have 
multiple cameras in a design.

6 From the Animation tasks, select Define Actor Path, with the following 
tool setting:

Actor List: Main Camera

The status bar prompts you to identify a path. 

7 Enter a data point anywhere on the B-spline path.

You are then prompted to Identify a direction.

8 Enter a data point in front of the animation camera to define the direction.

9 In the Define Actor Path dialog, set the following, and then click OK:

End Time: 599

Velocity: Constant

10 Click the Animation Preview tool and click Play to see the Main Camera 
Actor move along the defined path.

11 When done, use the slider to move the camera back to the start position.
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 Exercise: Turn the camera on at frame zero

1 From the Animation tasks, select Script Camera, with the following tool 
setting:

Actor List: Main Camera

2 As prompted, enter a data point on the camera and another to accept.

3 Set the following in the Script Camera dialog, and then click OK:

Start Time: 0

The Main Camera turns on at frame zero. The animation script is 
complete. The camera will fly down the path looking along it. To see the 
script so far, you need to open the Animation Producer.

4 From the Animation Settings toolbox, click the Animation Producer dialog 
tool.

5 In the Animation Producer dialog, click Longbeach in the Animation pane.

You can see two items have been added to the script, a Path and a 
Camera. 

6 In the Animation Producer select Settings > General and observe the 
following, and close the dialog:

Preview section - Maintain Frame Rate: Disabled

If Maintain Frame Rate is enabled in the Animation Settings dialog, 
MicroStation will try to maintain the 30 frames / sec preview. In order to 
do this, geometry may be dropped from frame to frame in the preview. If 
you prefer to see all the geometry you can disable this option, the default 
is for this option to be disabled.

Previewing the animation script
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Now you have the script ready to preview. Depending on the performance of your 
system and graphics card, you may need to make adjustments to improve the 
preview performance.

 Exercise: Preview the animation 

1 Continuing in 06_Longbeach.dgn, open View 8.

View 8 has been saved with the level containing the trees turned off. This 
provides a smoother preview as there is less geometry to update. Another 
way to make the preview play more smoothly is to reduce the size of the 
view window used for previewing the animation.

2 From the Visualization Task Pane select the View Size tool and enter a data 
point in View 8 to start the tool.

3 In the View Size tool dialog, click on the Aspect bar to see a drop down list 
of presets and choose 640x480.

4 Close the dialog.

5 In the Animator Preview dialog, set the view number, above the Play/
Pause controls to 8, and then click Play.

Hint: You can interrupt the preview by entering a reset.

You can see that the animation needs some improvement. Since the 
camera only looks along the path, you are not focused on more important 
things in the model. To create a visually compelling story, you must make a 
few changes.

6 Close View 8 and the Animation Producer.

Adding Targets

In the next exercise you will make one minor change and preview the animation 
again. You will add a target to draw the focus of the animation camera to the 
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center of the city. Later, you will put this target in motion for a smooth animation 
that highlights the landmarks and showcases the design.

You will see how to use Named Groups and Display Sets to place a target, rather 
than toggling levels.

 Exercise: Adding and scripting an animation target 

1 Continuing in 06_Longbeach.dgn, make Fountain the active level.

This step is important so that the target is on the same level as the 
geometry to which it is associated.

2 Select Utilities > Named Groups to open the Named Groups dialog.

3 Select fountain, and then click the Select Elements in Named Group icon.

4 Now click the Put Elements into DisplaySet icon.

5 To make it easier to place the target, Fit Views 1 and 3.

6 Reset, and then enter a data point to de-select the elements.
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The fountain elements are isolated so you can easily place the target.

7 From the Animation task, select Create Target with the following tool 
settings:

Cell Scale: 1000

A target graphic is attached to the pointer.

8 Snap to the center of the fountain in View 1 and enter a data point to 
place the target.

9 In the Create Target dialog, set the following, and then click OK:

Name: Target1

Description: Main target 

If you are wondering why the description was not fountain target instead 
of main, it is because you will be using KeyFraming to provide motion to 
this target where it will be used to look at several sites along the camera’s 
route or path. 

10 Right click, select DisplaySet Clear from the pop-up menu to clear the 
current DisplaySet.

11 From the Animation Cameras toolbox, select Script Target with the 
following tool settings:

Start Time: 0

Object: Main Camera

Target: Target1

12 Enter a data point in any view to add this item to the script.

Since the Time is 0 the Main Camera actor will be focused on the Target1 
actor from the beginning.

13 Open View 8 if closed.

14 In the Animator Preview dialog, set the view number, above the Play/
Pause controls to 8, and then click Play.

As you can see, the animation is different than the first, as the camera 
remains focused on the fountain landmark throughout the entire 
animation.

Activating and de-activating targets 
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This is done using the target activated toggle for each actor in the Animation 
Producer dialog. By default it is enabled, which means the camera will look at the 
target. Disabled, the camera will look in its original direction during the time 
interval it will interpolate between the two.

In the script shown here the camera will be looking along the path from frame 0 
to 60. For frames 61-120, the camera will be interpolating to look at the target. 
For frames 121 to 180, the camera will be looking at the target. From frames 181 
to 240, the camera will be interpolating back to look along the path. At frame 240 
the camera will be looking in the path direction.

Note: Target frame and value can be edited in the Animation Producer by clicking 
directly on item in scripted list above or frames can be modified by clicking on 
frame tick mark in Animation Producer timeline and dragging to new frame.

 Edit the Script to activate and deactivate the target

1 Open the Animation Producer and expand the Storyboard Panel.
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2 Choose File Copy Script and set the Following in the Copy Script dialog:

Name: AD

Description: Activate Deactivate Targets

3 Hold Ctrl key and click on the Target1 purple vertical bar in the Timeline 
and drag it to the right to make a copy.

The Time does not matter you will edit these in later step.

4 Repeat this operation until you have a total of 5 Target1 items in the 
Timeline.

5 Change the Time and whether or not the target is active or inactive to 
match the following by clicking on the items.

6 Open View 8 if closed and Preview the Script in View 8.

As you can see the camera starts out looking ahead then transitions to focus on 
target then it stays focused on the target then it transitions back to looking ahead. 
This one method to go from looking ahead along the path and then focusing on a 
target and then back to looking ahead.

KeyFraming a target 

In the next exercise series, you will learn how to animate a target. By setting a 
target in motion, you can change the visual focus to several landmarks along the 
way and convey the overall project scope with the animation. Using KeyFraming, 
you will find the target is much easier to control than having the target follow a 
defined path as with the camera. A KeyFrame is a moment in time that precisely 
defines the locations and orientations of particular elements, in this case the 
target.

Having the camera’s target in motion during the animation can be accomplished 
by moving the target on which the camera is focused. In this case, the Target1 
Actor will be moved to each landmark location you want to see along the way. 
Then, by creating KeyFrames of the target at these focal points, you can easily set 
the camera target in motion with a simple animation script.
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You could also accomplish this using fixed targets activating and de-activating 
them along the way, causing the camera to pan from a target to the path, and 
then back to a target as the camera moves along the path.

The following items are to be seen in this animation: 

• The high-rise building

• The fountain in central city park

• The lighthouse

• The waterfront from lighthouse to fountain

 Exercise: Create a KeyFrame of the fountain target

1 Continuing in 06_Longbeach.dgn, use Element Selection to select the 
Target actor you place earlier at the fountain.

2 From the Animation Producer choose File Open Script, choose Longbeach 
and then click OK.

3 From the Animation Task, select the KeyFrames dialog tool, and then click 
the Create button. 

4 Set the following in the Create KeyFrame dialog, and then click OK:

Name: Fountain

Description: focus on fountain

5 In the Named Groups dialog, select both the highrise and Target1 Named 
Groups.

6 Click the Select Elements in Named Group icon.

7 Click the Put Elements into the DisplaySet icon.
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8 Fit View 2.

9 Reset, and then enter a data point de-select the elements.

Enabling the graphic group lock ensures that you move both the target 
Actor’s origin and coordinate system, which could be moved separately if 
the lock is not on. This is true for any Actor, not just a target Actor.

10 Select Settings > Locks from the main menu bar to make sure the Graphic 
Group lock is enabled.

11 Make the Center snap the active snap.

12 Select the Move from the Main toolbox, snap to the center of Target1, and 
enter a data point. 
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13 Using AccuDraw, move the target to the top of the highrise, and then 
position it as shown.

14 Make sure the target is selected.

15 Click on the Create KeyFrame tool and then click on the Create button.

16 Set the following in the Create KeyFrame dialog, and then click OK:

Name: Highrise 

Description: focus on highrise

17 Shift + Right click and select DisplaySet Clear from the pop-up menu.

Now you have two KeyFrames listed in the Animation Producer dialog. 
Next you will create a KeyFrame of Target1 at the lighthouse.

 Exercise: Create a KeyFrames of the lighthouse target

1 Continuing in 06_Longbeach.dgn,choose Utilities > Named Groups.

2 In the Named Groups dialog, select both the lighthouse and Target1 
Named Groups.

3 Click the Select Elements in Named Group icon and then the 

4 Click the Put Elements into the DisplaySet icon.
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5 Fit View 3.

6 Reset, and then enter a data point deselect the elements.

7 Move Target1 by center snapping on the target then Keypoint snap to the 
top of the lighthouse to move. 

Target on top of lighthouse as seen in View 2

8 With the Target 1 actor selected, create a KeyFrame as follows:

Name: Lighthouse 

Description: focus on lighthouse

9 Right click and select DisplaySet Clear from the pop-up menu.

Creating a Storyboard

Early in any animation project you should map out what you want to show using a 
storyboard. A storyboard is a visual script or outline form of an animation. It can 
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be a series of visual images that simply illustrate the animation’s key scenes and 
events. You can even plan the animation by describing key sequences, or events, 
as they would occur.

The plan is for the camera to move along the path as follows:

• Start the animation by focusing on the highrise building at frame 0

• At frame 100, the camera moves to focus on fountain

• As the camera moves around the highrise, the target can be moved out to the 
lighthouse and remain there until the camera approaches, at around frame 
450. 

• The target can then be moved back to the fountain, so that at the end of the 
animation the focus will be back on the fountain

 Exercise: Scripting the KeyFrame motion of the target for the camera path

1 Continuing in 06_Longbeach.dgn, in the Animation Producer dialog List, 
right click the Highrise KeyFrame, select Script and make sure the Start 
Time is set to 0, click OK to add to script.

The Highrise KeyFrame item is now listed in the Storyboard Panel. The 
Camera now focuses on the high-rise at frame zero.

2 Right click on the Highrise KeyFrame in the timeline grid and select Copy 
from the pop-up menu.
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3 Drag the blue time bar from the left side of the grid to 100 in the timeline 
grid.

You can also type 100 in the field to the right of the clock at the right of 
the panel.

4 Right click on the timeline in the same row as the Highrise KeyFrame and 
select Paste.

Now you will script the Fountain KeyFrame.

5 Right click on the Fountain KeyFrame, select Script, set the following, and 
then click OK:

Start Time: 150

6 Ctrl click on the Fountain KeyFrame you just added and drag it to the right 
between 200 and 300.

The KeyFrame you copied by holding the Ctrl key and dragging should be 
around frame 250 + or - a frame or 2 is fine. You can simply drag it without 
holding the Ctrl Key to move it.

Now you will script the Lighthouse KeyFrame.

7 Right click on the Lighthouse KeyFrame select Script, set the following, and 
then click OK:

Start Time: 400

8 Right click on the Lighthouse KeyFrame select Script, set the following, and 
then click OK:

Start Time: 440
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Last, you will script the last KeyFrame for the Fountain.

9 Right click on the Fountain KeyFrame again, select Script, set the 
following, and then click OK:

Start Time: 500

Following is a summary of the timeline and the Storyboard Panel.

The target is moved rapidly from the lighthouse back to the fountain to prevent 
the camera from turning around and appearing to back away from the lighthouse 
target. This would happen if the focus remained on the lighthouse past frame 450.

 Exercise: Previewing the script

1 Continuing in 06_Longbeach.dgn, open View 8.

2 In the Animation Producer dialog, select Settings > General, set the 
following, and then close the dialog:

Time Display (input box): 1

Animated Elements: Enabled

Static Elements: Enabled

Clear View Between Frames: Enabled
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Disable Intermediate Updates: Enabled

3 In the Animator Preview dialog, set the view to 8 and click Play to preview 
the modified script.

The animation looks much better, but the timing seems a little off at the 
lighthouse. The focus stayed on the lighthouse and the camera turned 
around and looked back as it was passing the lighthouse. A simple edit of 
the script can correct this.

4 In the Animation Producer’s Storyboard Panel, right click in the Lighthouse 
KeyFrame’s Time column at 440, change to 445, and press Tab or Enter.

This will hold the focus on the light house a little longer and prevent the 
camera from turning around as it passes.

5 In the Animator Preview dialog, set the view to 8 and click Play to preview 
the modified script.

Actors on Paths

In the previous exercises you created and moved a camera along a defined path. 
Any Actor can move along a path. The path can be a closed element. such as a 
block or circle, or an open element, such as a line, line string, curve, arc, or B-
spline curve. 

The Define Actor Path tool from the Animation Tasks is the tool used to place an 
Actor on a path. Actors can be located in the active model, or in referenced DGN 
or DWG files. The Actor can be identified as follows:

• Graphically, by clicking on the Actor 

• Select its name from the Actor List options
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In the next exercise series, you will attach actors to paths and create custom 
acceleration curves to speed up, slow down, stop, or even reverse direction as the 
actor travels along a path.

 Exercise: Actors on paths

1 Open 07_car_race.dgn.

2 From the Animation Actors toolbox, select the Define Actor Path tool with 
the following tool setting:

Actor List: CAR1-1

3 Enter a data point on the cyan B-spline path in View 1. 

A direction arrow inside the car shows the direction the actor will take 
along the path. You are prompted to identify the direction.

4 With the direction arrow pointing to the left, enter a second data point to 
accept.

5 In the Define Actor Path dialog, set the following, and then click OK:

Start Time: 00

End Time: 600

Velocity: Constant

6 Bring View 2 to the top.
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7 Open the Animator Preview dialog, set the view to 2, and preview the 
animation.

8 Minimize View 2.

The CAR2 actor is attached to a actor named DUMMY, which is a circle 
underneath the car.

This DUMMY actor is a construction element that can be Switched off, or not seen 
in a view where the View Attribute for Constructions is off. In the hierarchy, the 
DUMMY actor is the top level actor, so by attaching it to the path, it drags CAR2 
actor around the track. The assembled hierarchy with the DUMMY actor at the 
top lets previously created KeyFrames of the CAR2 actor be introduced at any 
point, or time, along the path. 

 Exercise: Attach the DUMMY Actor to the path 

1 Continuing in 07_car_race.dgn, select Define Actor Path with the following 
tool setting:

Actor List: DUMMY

2 Enter a data point on the cyan colored B-spline path and set the direction 
to the left.

Even though the DUMMY actor is not located over the path, it still follows 
it as if a parallel path had been created.
Animating Cameras 86 Oct-13
Copyright © 2013 Bentley Systems, Incorporated



Actors on Paths
3 In the Define Actor Path dialog, set the following, and then click OK:

End Time: 600

Velocity: Constant

Both cars will now travel around the race track at the same constant 
velocity.

4 In the Animator Preview dialog, preview the animation in View 2, 
minimizing when done.
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Velocity Graphs

A velocity graph lets different Actors move at different rates of speed. In the 
Animation Producer dialog, select View > Velocity Graph to display this tool. 

 Exercise: Using the Velocity Graph

1 Continuing in 07_car_race.dgn, in the Animation Producer dialog, select 
View > Velocity Graph.

The numbers at the top are frame numbers, while the numbers along the 
side indicate the distance as a percentage.

2 In the Animation Producer’s Animation pane, expand the list of actors and 
click on the DUMMY actor.

You see a straight line that starts at zero on the lower left and extends to 
the upper right corner at frame 600. This is constant velocity. 

3 In the Animation Producer dialog’s upper right corner, click the arrow next 
to Percentage and choose Value. 
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The Velocity Graph changes so the distance is displayed in units, rather 
than a percentage of distance.

4 In the Animation Producer, click the Add Point icon, and then click on the 
center of the line.

Additional points appear on the line. You can move these points to form a 
smooth curve.

5 In the Animation Producer, click the Move Points icon.
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6 Click and drag the second point on the line to form a smooth curve, 
leaving the center point at the original location.

As you click on the points in the velocity graph, the distance is displayed in 
the upper right, and time is displayed in the lower right.

The curve you see represents rapid acceleration in the beginning, slowing 
in the middle, followed by more rapid acceleration, and then a slight 
slowing at the end. 

7 In the Animator Preview dialog, preview the animation in View 2. 

The CAR1 moves at a constant velocity but the other car speeds up, slows 
down, and then speeds up again.

Preview at frame 150

8 Return the animation to frame 0 and minimize View 2.

The steeper the rise in relation to the passage of time, the faster the Actor is 
moving. If the curve has a flat spot, the Actor would be stopped since time would 
be passing, but the distance would not be changing.
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What would happen to the actor if the curve were to slope downward?
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More Scripting for a Realistic Animation

In the next exercise you will place an animation camera into CAR1’s driver seat.

 Exercise: Place a camera in CAR1

1 Continuing in 07_car_race.dgn, Zoom In on the cars in View 8.

This view is an Isometric view and Construction elements are enabled in 
the view. This lets you see the camera actor which is a construction 
element. Note that the Graphic Group lock is on in this file.

2 From the Animation Cameras toolbox, click Create Animation Camera with 
the following tool setting:

Cell Scale: 30

3 Snap the camera to the midpoint of the driver’s door and, with focus in 
the AccuDraw window, type the letter <O> to establish a temporary origin.

This also sets the view depth.

4 Now type <T> to place AccuDraw in a top orientation.

5 Move the camera to the +Y for 1.0 units, type <O>, type <F> for a front 
orientation and move .5 units in +Y direction to set the height of the 
camera.

6 Enter a data point.
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7 Set the target point at 35 units in the -X direction (-35), and enter a data 
point.

8 In the Create Camera dialog, set the following, and then click OK:

Name: carcam

Description: CAR1

9 Select the Script Camera tool with the following tool settings:

Actor List: carcam

10 In the Script Camera dialog, set the Start Time to 0 and click OK. 

The camera is on starting at Frame 0.

11 In the Animator Preview dialog, preview the animation in View 8. 

The cars drive away, leaving the viewer standing on the race track.

12 Return the animation to frame 0.
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The animation camera placed with the Create Animation Camera tool is a built-in 
Actor which is not attached to the car yet. Use the Attach Actor tool to attach it so 
it moves around the race track with the car.

 Exercise: Attach the camera actor to CAR1 

1 Continuing in 07_car_race.dgn, from the Animation tasks, select the 
Attach Actor tool with the following tool settings:

Actor list: carcam

2 In View 1 enter a data point on CAR1 to attach the camera, and then 
another data point to accept.

Hint: To attach an actor to another actor you can simply drag the actor that you want 
to attach on to the actor that you want to attach it to in the Animation 
Producer dialog.

3 In the Animator Preview dialog, preview the animation in View 2. 

You are looking out the window of CAR1 as it moves around the track and 
you pass CAR2, the DUMMY Actor, around the halfway point.

You can also compare the velocities of the two race cars by sending the other car’s 
path to the velocity graph and getting a better idea graphically where CAR1 passes 
the DUMMY.
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Also, if you were in a real race, CAR1’s driver might look at CAR2 as they pass by. 
To accomplish this, you only need a minor addition to the existing script. The 
animation tools let you enable and disable targets to provide a smooth transition 
from looking at a target, to looking straight ahead, or looking back to target.

 Exercise: Compare velocities and script target

1 With the Animation Producer dialog in Velocity Graph mode, press and 
hold the Ctrl key, and then click on DUMMY and CAR1 in the Animation 
pane.

CAR1’s velocity is a straight line, indicating constant velocity. The curved 
line is CAR2 (the DUMMY Actor). The curve crosses the line near the 
midpoint, around frame 300 of the 600 frame animation. This is where 
CAR1 overtakes CAR2. 

2 In the Animation Producer dialog click the Select Curve icon, and then click 
on the DUMMY actor’s velocity curve.

This makes the DUMMY curve the active curve so you can make 
modifications.

3 Click the Move Point icon and move the end point back a few frames so 
that the DUMMY actor wins the race. 

4 Also, move the points to bring the curves a little close together.

This will make it a much closer race.
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5 Using the Animator Preview dialog’s slider, move the progress bar until 
CAR1 is along side CAR2, at about frame 239.

Frame 239

6 From the Animation Cameras toolbox, select Script Target with the 
following tool settings:

Start Time: 239 (or the value where your slider is located)

Object: carcam

Target: CARTGT

The CARTGT actor is located in the DUMMY actor’s hierarchy, where the 
drivers head would be as the target for the carcam camera.

7 Enter a data point in any view to add this item to the script.

8 In the Animator Preview dialog, preview the animation in View 2. 
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You turn to look at CAR2 car when you pass it and remain focused on the 
CARTGT actor until the end of the movie.

Luxology rendering of frame 344

The DUMMY actor provides an additional level of hierarchy. The top level DUMMY 
actor will drag the lower level hierarchy actor CAR2 around the track. This lets you 
script KeyFrames of CAR2 in a down position then in a rolled up position so you 
can roll the car up onto two wheels at any point.

CAR2’s origin, or coordinate system, is located on the right side where the tires 
make contact with the road.
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In the following exercise, the KeyFrames for CAR2 are named DOWN and ROLL. 
ROLL rolls the car up on two wheels and it moves back down when the DOWN 
KeyFrame is used.

 Exercise: Script CAR2 to roll up on two wheels

1 Continuing in 07_car_race.dgn, in the Animator Preview dialog, move the 
progress bar to the right until CAR2 is in front and going into the curve.

Around frame 93 Display Style Illustration: Gradient Sky

2 Depending on your acceleration curve this could be different than shown. 
Don’t worry about the time being exact, just move the progress bar until 
the DUMMY car is close to the position shown. 

3 In the Animation Producer dialog, select View> Timeline to switch back to 
timeline view. 

4 In the Animation pane, expand the KeyFrames by clicking the + sign.

5 Right click the DOWN KeyFrame and select Script.
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6 In the Script KeyFrame dialog, set the following, and then click OK:

Start Time: 93 (or the value where your slider is located)

7 Move the Animator Preview progress bar until the Dummy is to the right 
of the CAR1.

8 Right click the ROLL KeyFrame and select Script.

9 In the Script KeyFrame dialog, set the following, and then click OK:
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Start Time: (the value where your slider is located around 278)

Position of slider at ~ 278 after ROLL KeyFrame added

10 Move the progress bar to the right so that a little more time passes and 
CAR2 is farther down the road. 

This will be the point at which it comes back down and all four tires are 
back on the road.

11 Right click the DOWN KeyFrame and select Script.

12 In the Script KeyFrame dialog, set the following, and then click OK:

Start Time: 300

Now the Actor gradually comes back down during this time.

Hint: From the Animation Producer’s timeline view you can click and drag a 
KeyFrame to move it in time and change where the KeyFrame occurs. 
This makes changing a script very easy.

13 In the Animator Preview dialog, preview the animation. 

Hint: If the preview is too fast, you can scale the script up by a factor of 2 or 3 to 
increase the number of frames and slow down the action.
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Traffic Simulation
Module Overview

This module describes how to script a traffic simulation using the new Traffic 
Simulation tools that were first delivered with MicroStation V8i SELECTseries 3.

Module Prerequisites
• Understanding of 3D view controls

• Understanding of basic MicroStation procedures

Module Objectives

After completing this module, you will be able to:

• Create a vehicle library

• Script lane traffic

• Link entrance and exit lanes

• Link inside lanes to main lanes

• Preview animation

• Add vehicle to lane

• Add camera attached to vehicle
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Traffic Simulation 

MicroStation SELECTseries 3 includes a new set of tools to simulate traffic on 
highways as part of the Animator. These tools enable the creation of a road 
network for placing and animating vehicles. The following is an overview of how 
to use these tools to easily create an animation with moving traffic.

Setting up Lanes

In order to animate the vehicles along the road or highway a series of paths need 
to be defined for the vehicles to follow. These paths are used by the animator for 
calculating the points on the road surface that the vehicles move along. Therefore 
they don't need to be accurately placed on the road surface. In most cases 
anywhere above the road surface is suitable. You can even reference in a 2D 
layout file with the path information and then use this as a basis for the lane 
paths. In the case where a single lane goes under a bridge and then curves around 
and crosses itself as for example a clover leaf highway exit the lane, then a path 
will need to be defined in 3D such that it is above the correct part road surface as 
the road curves around over itself.

There are 2 tools for adding lane information to the traffic simulator. These are: 

IScript Single Lane Traffic 

IScript Multi-Lane Traffic

The place single lane of traffic tool is used when there is a single lane center line 
element defined per roadway lane. This tool will place and animate a single lane 
of vehicles along this path. 

The place multiple lanes of traffic tool will allow multiple lanes of traffic to be 
defined using a single path or alignment.

In the image below the yellow lines can be used for defining single lanes of traffic 
along the roadway and the red line can be used for defining multiple lanes of 
traffic. Once the lanes have been setup they can then be linked together so that 
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vehicles can join and leave from one lane to another and they can also overtake 
based on their differing velocities.

Entrance and exit ramps 

When defining lanes for exiting and entering a highway the lane paths should not 
be joined together. The centerline of the lane should be maintained along the 
center line of the lane. The entrance and exit lane paths should then run parallel 
to the main lane for some distance. The traffic simulation system will 
automatically perform the merging of the vehicles from exit or entrance lanes on 
to or off the main highway. This is based on the vehicles in the lane being merged 
by taking into account both their speed and the speed of the vehicles entering or 
exiting. 
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Creating Vehicle Set

In order to add vehicles you will need to add the vehicles that you intend to use to 
a library. In MicroStation V8i SELECTseries 3 by default the installer will download 
and install some very useful visualization content. This includes a library of cars 
and trucks from Marlin Studios, a sample of Trees from Xfrog and a sample of 
more detailed vehicle models from Dosch Design. These files are delivered by 
default to C:\ProgramData\Bentley\SharedContent, here you should find the 
following folders:

Dosch_Design

Marlin_Studios

Xfrog_Samples

 Exercise: Create Vehicle Set

1 Open the File Interchange.dgn

2 Select the Script Single Lane Traffic tool (E+1) 

3 Click on the Browse icon to open the Vehicle Library dialog.

4 Enter Cars for the Library name.
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5 Click on the Add vehicles from (cel, dgn, dgnlib) icon. The Add Vehicles 
dialog appears.

6 Click on the Browse icon in the Add Vehicles dialog. The Select Vehicle 
Library appears.

7 Browse to C:\ProgramData\Bentley\SharedContent\Marlin_Studios and 
Double click on Marlin_Studios_Motion_Vehicles.cel to choose this file. 
The Add Vehicles dialog appears.
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You will need SELECTseries 3 version 08.11.09.459 or later installed to have 
this library, if you don’t have this version installed you can just choose the 
Marlin_Studios.cel library instead.

Note: The motion libraries have people in the cars and trucks and the textures for the 
wheels all have radial blurs so that they will appear to be spinning. The non 
motion libraries have static wheels and no people, these are intended to be 
used in parking lots.

8 Click and drag select all of the cars in the Add Vehicles dialog but do not 
select the trucks and click OK.

You have used the default settings for adding the vehicles the following is 
and explanation of the settings:

Rotation - This is the angle to rotate the contents of the model such that 
the vehicle is facing in the positive x direction. Typically if the model 
should be located such that the origin is at the center of the vehicle on the 
same plane as the bottom of the wheels.

Vehicle takes exit lanes: When checked the vehicles will randomly take exit 
lanes for large semi tractor trailer rigs you should turn this off because the 
vehicles do not articulate and could look bad especially on tight turns.

Acceleration: Vehicle acceleration in m/s2 a typical value for a car is 0.3 
and 0.25 for a truck.

Deceleration: Vehicle deceleration in m/s2 a typical value for a car is 3.0 
and 2.0 for a truck.

Minimum Vehicle Spacing - This is the minimum allowed spacing between 
vehicles. When a vehicle slows down because it cannot join an entrance 
lane then the vehicle behind it will also slow down. If the vehicle comes to 
a stop then this value represents the distance maintained between them.

Time Headway - This is the safety time in seconds between vehicles in a 
traffic system. Typically this varies between 0.8 and 2.0, more careful 
drivers will have a larger time headway. This also means the traffic system 
can support less volume.

9 Click on the Save icon to save this library.

10 From the Vehicle Library dialog click on the Create New icon and change 
the Untitled-1 name to Trucks.

11 Click on the Add vehicles from (cel, dgn, dgnlib) icon. The Add Vehicles 
dialog appears.
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12 Click on the Browse icon in the Add Vehicles dialog. The Select Vehicle 
Library appears.

13 Browse to C:\ProgramData\Bentley\SharedContent\Marlin_Studios and 
Double click on Marlin_Studios_Motion_Vehicles.cel to choose this file. 
The Add Vehicles dialog appears.

14 Click and drag select all of the Peterbuilt truck models in the Add Vehicles 
dialog but do not select the cars and set the following:

Vehicle takes exit lane: Disable

Acceleration: 0.250

Minimum vehicle spacing: 6.0

Deceleration: 2.000

15 Click OK to add the trucks to the library.

16 Click on the Save icon to save this library.

Script Single Lane Traffic 

The operation of this tool is to place a set of vehicles along the lane defined by the 
parameters and add a script entry to the animator for animating the vehicles. The 
tool uses data point entry to select the lane, define the direction of vehicle travel 
and preview the vehicles on the road. This allows you to see the vehicle spacing 
which can be adjusted prior to accepting the settings.

 Exercise: Script Single lane Traffic
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1 Continuing with Interchange.dgn, make road surface the active level and 
in View 1 turn off all other levels except for the Bridge, Lanes and Vehicles 
levels. You may also just attach the saved view Script Lanes to View 1.

Note: When you use the Script Lane tools a depth mesh is created in memory so that 
the positions and orientation of all the vehicles can be computed. You should 
limit the geometry visible in the view where you place them to just those 
elements that will receive the vehicles. This can be achieved by using levels or 
DisplaySets. Failing to do this could result in MicroStation running out of 
memory and possibly crashing. In addition if you limit what is visible to that 
geometry receiving vehicles the tool will work much faster. The Populate 
Contents tools works the same way so for adding trees and other content to 
your scene you should limit the visible geometry to just the elements that are 
receiving the content.

2 Select the Script Single Lane Traffic tool (E+1) 

3 Set the Settings as you see below:

You are setting the speed for the lane and the vehicle separation. The 
smaller the separation the more vehicles you will have on the lane.

Lane Offset - If the path for the vehicles to travel down is not in the center of the 
lane then this value allows you to set the distance from the lane path element to 
the center of the lane. The option button allows the choice of the units to use.

Average Speed - This the average speed of the vehicles in this lane as expressed in 
the units defined in the option button next to it.

Vehicle Separation - This is the distance between adjacent vehicles in the same 
lane.

Path Sampling - This is the sampling distance along the lane path element that the 
road surface information is calculated at. A value of 2 meters is usually sufficient 
for smooth highways. If the road surface contains speed bumps then a lower 
value should be used.
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Start time - This is the animation script entry start time, expressed in the current 
animation scripts time code. 

End Time - This is the animation script entry end time, expressed in the current 
animation scripts time code.

4 In View 1 (Top View) select the right Lane as seen in the figure below, 
position your cursor to give it a traffic flow toward the top the direction 
arrow should be red and accept. Make sure you don't select the exit lane 
you don’t want to be exiting at 65 miles per hour.

You can see the vehicles show up in the right lane at the spacing that you 
have set in the dialog box.If you wanted to change the separation you 
could do this after the vehicles appear and prior to accepting by just 
changing the value

5 Select that same tool except change the settings to:

Average Speed: 50
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Vehicle Separation: 180

6 Select the exit lane as shown (lower right) and give it a traffic flow toward 
top of screen red indicator arrow and accept.

7 Use the map show above to script the other lanes with the speed and 
separations shown.

In the interchange map (provided you are scripting for right hand drive) all 
of the lanes on the right will require that the direction indicator be red and 
the onces on the left will be toward bottom of the screen and appear in 
green.

For left hand drive vehicles just reverse the direction when scripting the 
lane.

TIP: If you by mistake and have a lane with traffic flowing in the opposite 
direction than what you intended, you can use the Delete Lane tool to 
delete the lane and then script it again with the vehicles going in the 
direction that you need.
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8 Use the Preview tool to preview the animation in View 1, you can zoom in 
out or pan view the view while the animation is playing.

Linking Lanes

Notice how the cars appear out of nowhere at the beginning of the exit and 
entrance lanes. This is because the traffic repeats and the cars are recycled and 
used again. What you really want to happen is for the cars to move from the main 
lane to the exit and entrance lanes. For this to work you will need to link the exit 
lanes and entrance lanes to the main lane.Linking Lanes. 

Once a set of lanes has been created it is possible to create a road network by 
linking lanes together and defining the types of lanes in the file. There are 4 main 
types of lanes.

Exit Lanes - These are lanes which vehicles can change to in order to leave a main 
carriageway. This tool links two lanes together. Following the prompts you will 
first be asked to select the lane which is the lane entering the carriage way. Then 
you will be prompted to identify the main carriageway. Once accepted the cars 
will move from one lane to the other.

Entrance Lanes - These are lanes which vehicles can change from to join a main 
carriageway. This tool links an exit lane to a main carriage way lane. Following the 
prompts you will first be asked to select the lane which is the lane exiting the 
carriage way. Then you will be prompted to identify the main carriageway. 

Outside Lane - This is a lane which is closer to the central reservation of a road 
than the lane you are currently in. This lane links two single lanes together such 
that the first is the outside lane and the second is the inside lane. (Note: if you use 
the place multi lane traffic tool then inside and outside lanes are automatically 
calculated)

Inside Lane - This is a lane which is further away from the central reservation of a 
road than the lane you are currently in. This lane links two single lanes together 
such that the first selected is the inside lane and the second is the outside lane. 
(Note: if you use the place multi lane traffic tool then inside and outside lanes are 
automatically calculated)
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Show Lane Links - When selecting a lane this tool will draw the links this lane has 
to other lanes in the views. Using the icon on the tool will zoom the active view to 
the area where the linking occurs. 

Delete Lane Link - This tool will delete individual links from lanes. Firstly identify 
the lane to delete the link. Now identify the transient which represents the link to 
be deleted. You can use the zoom icon on the tool settings to animate the active 
view between the links for a given lane.

 Exercise: Linking Lanes

1 Continuing with Interchange.dgn, click on the Link Exit Lane tool, it will 
prompt you to select the exit lane first and then the main lane. Click on 
the exit lane then click the main on the main lane then accept with a data 
point to complete the lane linking.

2 Repeat the steps for the other exit lane.

3 Using same procedure use the Link Entrance Lane tool to link the two 
entrance lanes to the main lane.

4 Use the Link Inside Lane tool to link the inside lanes to the outside lanes. 
Enter a data point on the inside lane and then a data point on the outside 
lane and one more data point to accept.

You will need to use the tool twice once for North bound traffic and once 
for South bound traffic. Once you have done this the vehicles will 
randomly change lanes to overtake slower cars.

Note: You could have accomplished the same thing by using the Link Outside Lane 
tool, the difference being that you pick the outside lane first and inside lane 
second both.

5 Select the animation preview box, change the active view to view 1 and 
run the preview.

The vehicles should now enter and exit by changing lanes not appearing 
out of nowhere and you may see some cars changing lanes on the main 
highway.

TIP: Even though the vehicles are randomly placed from the library you 
could occasionally have two or more identical cars in a row. You can use 
MicroStation’s place cell tool to open the cell library then make one of the 
other cars of your choice a red mustang for example the active cell. Now 
just use the cell replace single tool to change the car or truck for the new 
vehicle without loosing your script.
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Adding a Vehicle to a Lane

Let’s say that you want to add a couple more cars or maybe a few tractor trailer 
rigs to your traffic simulation. This can easily be added using the Add Vehicle to 
Lane tool.

 Exercise: Adding a Vehicle to a Lane

1 Click on the Add Vehicle to Lane tool. The Add Vehicle to Lane tool box 
appears.

2 In the Vehicle Set drop down choose Trucks and in the Vehicle drop down 
choose Peterbuilt Red Motion.

You can see that the Prompt for the Tool says Add Vehicle To Lane > 
Identify Lane Center Line.

3 Pick one of you main lanes in View 1 and enter a data point, to identify the 
lane and one more data point to accept the lane, now the truck will 
appear and you can move the truck forward and back on the lane 
centerline by moving your cursor to position the vehicle.

4 Enter a data point to accept the position of the newly added vehicle.
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5 Repeat the steps to add another truck to you simulation.

Create Camera Attached to Vehicle

Now that you have your traffic animating down the highway you may want to see 
the roadway from the vantage point of one of the vehicles. This is very simple to 
do with the Create Camera Attached to Vehicle tool.

 Exercise: Attaching a Camera to Vehicle

1 Continuing in Interchange.dgn,Fit View 1, then window in on the roadway 
at the bottom of the view where the main highway begins.

2 Click on the Create Camera Attached to Vehicle tool.

Set the Following:

Start Time: 0

Camera Height: 6.0
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Standard Lens: Normal

Cell Scale: 1.0

3 Enter a data point on the first car you see in the Northbound outside lane 
to pick this car and another data point to accept.

4 Click on the Animator Preview tool and preview the animation in View 2.

You can see in the preview that you are moving down the highway with 
the car that you chose at a height of 6’ above the highway.

TIP: You really should alway use a Normal lens when creating vehicle 
cameras. The Normal lens viewing angle is near that of human vision and 
you want to see what a person would see, so don’t use Wide Angle or 
Telephoto lens for this camera.

Place Multi Lane Traffic 

In addition to being able to script a single lane of traffic using lane centerlines as 
in the previous exercises you can also script multiple lanes using the Place Multi 
Lane Traffic tool.

The Place Multi Lane Traffic tool settings appears as:

Add Lane Entry - Clicking this icon will open the Add Lane dialog, you will need to 
create a lane entry for each lane, in the interchange example 4 lanes are added 2 
right and 2 left lanes.
Oct-13 115 Traffic Simulation
Copyright © 2013 Bentley Systems, Incorporated



Traffic Simulation
You can use the Add Lane dialog to set the lane parameters for Lane Offset, 
Average Speed, Vehicle Separation and Lane Type.

Copy Lane - You can use the copy lane icon to copy a lane and its parameters. 

The operation of the Place Multi Lane Traffic tool is similar to the Place Single 
Lane Traffic tool they differ in that this tool use a single path and relies on offsets 
to create multi-lane traffic. The set of vehicles used can be selected from the 
Vehicle Set which allows you to choose from a list of named libraries that have 
been defined. The tool uses data point entry to select the lane and define the 
direction of travel of the vehicles and preview the vehicles on the road so the 
vehicle type and spacing can be seen and adjusted before accepting the settings.

Place Multi Lane Traffic List box and icons 

The list box and icons allow you to create and manage a set of lanes associated 
with the lane path element. The add icon allows you to insert entries into the list 
with the data regarding lane offset, speed, vehicle separation as in the single lane 
tool described above. It also allows you to specify if the lane is a left or right hand 
lane. This is so the direction of the vehicles can be set correctly. 

Here are the tool settings completed for the above design file with the lane 
offsets, based on the red center line in the file.

Note: When defining the offsets for the lane +values are used for the lanes which are 
to the left of the path element. To change the gap of placed vehicles just move 
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the vehicles with the move tool (with the animator running) they will snap to 
the correct position on the path and delete the excess vehicles. 

Edit Lanes - The edit lanes tool allows you to edit a selected lane and opens a 
dialog enabling the editing of the lane data. Here is the resulting dialog for the 
lanes placed above. You can only edit the offset and speed.

Once the edit is accepted then the lane data is updated.

Delete Lane - This tool will delete a lane and all the vehicles associated with that 
lane. Simply select and accept the lane to delete but be aware that deleting a lane 
also deletes the lane links associated with it.

Vehicle Library 

A library system has been implemented for maintaining sets of vehicles to use in 
the traffic simulator allowing the creation, editing, and deletion of vehicle lists. 
These lists can also be maintained and moved from project to project via the 
dgnlib system.
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New Vehicle List

This icon will create a new entry in the vehicle list column allowing the user to set 
the name of the entry.

Save Vehicle List 

When the contents of a vehicle list have been changed the changes are saved to 
file when this icon is used.

Copy Vehicle List

This icon will copy the currently selected list of vehicles to a new list with a 
different name 

Delete Vehicle List

This icon will delete the currently selected list of vehicles.

Reset Vehicle List

This icon will reset the currently unsaved changes to the list.

Update From Library

If the origin of this list of vehicles is from another file such as a dgnlib and it is 
different in the active file from the originating file this icon will reset the list to the 
state that the list is in the library.

Add Vehicles
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This icon will open the following dialog.

This dialog allows the user to open .dgn,.cel,.dgnlib etc. files and select a series of 
models within that file for use as vehicles. The user has the option of selecting 
one or more of the entries in the list and these will then be added with the 
associated options into the vehicle list of the main vehicle library dialog.

Add RPC

This icon opens the ADD RPC Files dialog. This dialog allows the addition of Rich 
Photorealistic Content (RPC) vehicles into the system. The settings at the bottom 
of the dialog are the same as the Add File dialog. This is simply for RPC cells.

Browse Icon - To select a directory where the RPC are located select this icon. 
Once the directory has been selected the category option button will be 
populated with the categories of RPC which are available to use.

Refresh Icon - Using this icon will search the current directory list and update 
the lists of RPC available.
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Copy Entry

This icon will copy an entry in the list of vehicles. 

Delete Entry

This icon will delete an entry in the list of vehicles.
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Module Overview

In this module you will learn how to animate materials and lights, including solar 
time. You will learn how to use the Animator’s tree view and timeline editor to 
edit animation scripts.

Module Prerequisites
• Knowledge about 3D view controls

• Knowledge about saved views

• Basic understanding of scripting

• Some knowledge about MicroStation lights

Module Objectives

After completing this module, you will be able to:

• Animating materials

• Animating source lights

• Animating sequential images

• Animating using Saved Views

• Animating of Solar time
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Animating Materials and Lights

In this module you will learn:

• How to animate materials over time to create effects like running 
water. 

• How to animate source lights by changing the color and intensity of 
lights over time.

• Learn how to use the Animator’s Tree View and Timeline editor to 
graphically see the animation scripts and more easily edit them. 

• Learn how to use saved views to create camera animations. 

• Learn how to use the Animator to animate Solar time and also learn 
how to use a special utility called Solar Study to animate the Solar time 
over extended periods of time.

Animating Camera using Saved Views

You can animate between any two saved views, whether orthogonal (non-
camera) or with perspective. The path is linear between two views, but can be 
interpolated as a B-spline when three or more views are used and B-spline 
interpolation is selected. You can even animate from a non-camera orthogonal 
view to a perspective camera view.

You must figure out the actual path the camera would take, since you cannot 
graphically see the path. However, once you see how it works, you will find this 
method useful for animating in small areas like interior spaces.

 Exercise: Animation using saved views

1 Open 08_lobby fountain.dgn.
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This DGN file contains saved views. The two you will work with here are 
shown here rendered with Luxology with Visible Edges Overlay.

2 Select the Animation Producer tool in the Animation tasks.

3 In the Animation Producer dialog select Tools > Saved Views.

4 In the Script Saved View dialog, set the following, and then click OK:

Start Time: 0

Interpolation: Linear

Velocity: Constant

Saved Views: v1 left

5 In the Animation Producer dialog select Tools > Saved Views.

6 In the Script Saved View dialog, set the following, and then click OK:

Start Time: 200

Interpolation: Linear

Velocity: Constant

Saved Views: v3 right

Click OK to add to the Storyboard Panel

7 Click play in the Animation Preview dialog to view the animation in View 2.

The animation transitions using tweening from saved view v1 to saved 
view v3.
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Animating Running Water

Next you will learn how to animate the properties of a material over time to 
achieve the effect of water running down the wall of the fountain.

 Exercise: Animate running water

1 Continuing in 08_lobby fountain.dgn, in the Animation Producer dialog, 
expand Materials in the Animation pane, expand fountain palette, falling 
water, then expand Map.

2 Right click Offset Y and select Script.

3 In the Animate Settings dialog set the following, and then click OK:

Pattern Y Offset: 0

Start Time: 0

Interpolation: Linear

Velocity: Constant

4 Right click Offset Y and select Script.

5 In the Animate Settings dialog set the following, and then click OK:

Pattern Y Offset: 4

Start Time: 200

Interpolation: Linear

Velocity: Constant

6 In the Animation pane, repeat the previous steps and except this time 
expand fountain water, then expand Map.

7 Right click Offset Y and select Script.
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8 In the Animate Settings dialog set the following, and then click OK:

Pattern Y Offset: 0

Start Time: 0

Interpolation: Linear

Velocity: Constant

9 Right click Offset Y again and select Script.

10 In the Animate Settings dialog set the following, and then click OK:

Pattern Y Offset: -0.5

Start Time: 200

Interpolation: Linear

Velocity: Constant

11 Click play in the Animation Preview dialog to view the animation in View 2.

Note: You will need smooth shading applied to view in order to see the that 
the textures maps are animated.

12 To view the animation in a different lighting mode, select the Light 
Manager tool in the Animation tasks Render toolbox and set the following:
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Light Setups: animate water-low lighting

13 Click play in the Animation Preview dialog to view the animation.

You can change the value in the Storyboard Panel of the Animation 
Producer to modify speed of moving water.

Animating Source Lights

To add a little mood effect to the lobby fountain you will add a few more items to 
your script to change the color of the spot lights over time. This will be much 
more interesting and dramatic than just animating the falling water as you will 
soon see.

 Exercise: Animating source lights

1 Continuing in 08_lobby fountain.dgn, in the Animation Producer dialog, 
expand the Lighting, and then Source in the Animation pane.
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Note: You can click and drag the blue timeline marker to the time or frame number 
then when you choose script the time will already be set to match that timeline 
marker position.

2 Expand Fountain Light Left, right click Color, select Script, set the 
following, and then click OK:

Color: 255,255,255 (White)

Start Time: 0

3 Expand Fountain Light Middle, right click Color, select Script, set the 
following, and then click OK:

Color: 255,255,255 (White)

Start Time: 0

4 Expand Fountain Light Right, right click Color, select Script, set the 
following, and then click OK:

Color: 255,255,255 (White)

Start Time: 0

Now that you have the initial light color entries, you can animate the spot 
lights to change color over time, and then back to white at the end of the 
movie.

5 Collapse the Fountain Lights in the list and then click on Source.
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6 Hold Ctrl key and click on the green symbol for Fountain Light Left in the 
timeline, and then drag it to Frame 50. 

7 Repeat this process for Frames 100, 150, and 200 by holding Ctrl key, 
clicking and dragging to make copies.

8 Now do the same for Fountain Light Middle and Fountain Light Right. You 
may need to expand the light to in the list to Ctrl click on the color key in 
the timeline.

9 In the Storyboard Panel modify the color of each Fountain Light for 
frames, 50, 100, 150 and 200 by clicking on the color icon under the value 
column and selecting colors red, yellow, green and white.

You can make the lights any color like and in any order in the below 
example the lights animate from white to red, then green and then blue 
and finally back to white.
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10

Click on the 08_lobby fountain item at the top of the list view to see the 
entire animation script in the storyboard panel.

11 Click play in the Animation Preview dialog to view the animation smooth 
shaded in View 2.

12 Try editing colors and modify your Story Panel to see different effects.

Have Fun!
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Animating Textures

The Animation Producer lets you to animate any defined materials properties 
over time. The various animation properties and Storyboard modifications are as 
follows.

Next you will modify various textures assigned to the water in a scene. Due to the 
time involved in calculating these animation sequences, an animation video is 
supplied so you can see the results after you have completed the scripting. The 
file is named 09_textureanimation.wmv, and is included in the data set provided 
for this course.

 Exercise: Modify bump height

1 Open 09_textureanimation.dgn.

2 Open the Animation Producer dialog.

3 Expand the Materials in the animation pane, then flowing-water, stream 
material and Map properties.
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4 Right click on the Bump Height property and select Script.

5 In the Animate Settings dialog, set the following, and then click OK:

Bump Height: 10

Start Time: 0

6 Repeat, with following settings:

Bump Height: 25

Start Time: 30

7 Repeat, with following settings:

Bump Height: 10

Start Time: 60

 NOTE: These frames must be rendered with Luxology in order to see the 
effects of the bump map being animated. Smooth shading can produce 
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shadows but not bump mapping, displacements, reflections etc. you will 
need to render the frames to animate these effects.

8 Open bumpheight.wmv in from the data set Movies folder with Windows 
Media Player to play the rendered animation.

The same process can be used for other properties on any material in the design 
file. Displacement, bump maps, etc., require the animation to be rendered using 
Luxology from the Record Script dialog since Smooth shading will not display 
these properties. 

Animating Solar Time

You can use the Animator tools to animate the sun’s movement across the sky 
during a single day. If you want to perform a solar study over a period of days or 
months, you can use the Solar Study utility. This utility lets you animate the solar 
time over extended periods. For instance, you could render a building every day 
at 2:00 PM for a year.

You can display the current Solar Time and Date information while rendering a 
view. When used in conjunction with the Solar Study utility, or in an animation, 
you can display the Solar Time and Date information for each frame of the 
sequence. 

View Time Display
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New in MicroStation V8i (SELECTseries 3) is the View Time Display option. This 
option allows you to turn on the display of the date and time in the view during 
the preview of an animation or a schedule simulation, or while recording a movie. 

View Time Display

The View Time Display is set in the Animation Settings dialog. In this dialog, you 
can select the format and location of the time display. Once the style is set, you 
can add the time and date to the preview, change the format of the display and 
use the Display Active Task during Preview tool to see the list of tasks and the 
percentage of completeness.

The View Time Display replaces the Solar Time Stamp feature, which will be 
removed in a future release.

Solar Time Stamp

To display solar time and the date in the rendered view, you first place the cell 
SLRTIM in a convenient place in the view that is being rendered. This cell is 
located in the cell library animator.cel in the \Workspace\system\cell folder. After 
placing the cell, you can edit the Enter-Data field of the cell to display the string 
you want. The format of the string is that used by the C function “strftime”. By 
default, the cell contains the string “%c”, which displays the Date and Time.

Addition Date and Time formats are as follows:

Format Description

%c Date and time appropriate for current locale

%x Date for current locale

%y Year without century (00 — 99)

%Y Year with century (such as, 2010)

%b Abbreviated month name

%B Full month name

%m  Month as number (01 — 12)

%d Day of month as number (01 — 31)

%a Abbreviated day name
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Typical examples are:

Next you will use the Animator to create a script and render frames animating 
solar time over 10 hours, rendering frames every 10 minutes. 

The design file you will be using has the Solar Time Stamp cell placed in the file so 
you can see how it works. If you prefer not to see it you can just turn off the level 
where the SLRTIM cell is located in the design.

Note: the Compass tool in the Light Manager was used on this data set to reset 
the North direction for the model so that the physical sun would appear to rise 
from behind the building.

 Exercise: Animating solar time

1 Open 10_Solartime.dgn.

%A Full day name

%H  Hour in 24–hour format (00 — 23)

%I  Hour in 12–hour format (01 — 12)

%M Minute as number (00 — 59)

%S Second as number (00 — 59)

%p  Current locale's AM/PM indicator for 12–hour clock

%z, %Z  Time-zone name or abbreviation; no characters if time  zone is 
unknown

Displays String

%c 08/14/06, 2006, 10:20:35 AM

Date is %c Date is 08/14/06, 2006, 10:20:35 AM

Time is %I:%M:%p Time is 10:20 AM

Format Description
Animating Materials and Lights 134 Oct-13
Copyright © 2013 Bentley Systems, Incorporated



Animating Solar Time
The design file opens with four open views. You will be using View 2 to 
animate the solar time. 

2 Open the Animation Producer and select Settings > General.

3 In the Animation Settings dialog, set the following:

Time Display: Change %ff to MM-dd_yyy (click the arrow)

After the MM-dd-yyyy format, type a space, then type the following for 
hours and minutes to display: HH:mm

Set 10 minutes = 1 Frame (click the arrow to select minutes)

Range: Start time: Click the calendar, select a Start date, type 7:00:00AM

Range: End: Click the calendar, select an End date, type 5:00:00PM

When a date format is changed in the Animation Settings dialog the 
headings also change in the Animation producer.

Unlike the other procedures using the Animation Producer, you do not 
need to add any items to the script to animate the global solar time. Once 
you set the Animation Producers Time Display to be over a long period of 
hours or days we assume the purpose is a solar study.
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By setting the Start Time to 7:00AM and the End Time to 5:00PM the 
animation will be over a period of 10 hours. Since you also specified that 
10 minutes is equal to 1 frame the animation will require 6 frames/hour 
for a total of 60 frames to be rendered.

4 In the Animation Settings enable the Display Time in View option with the 
options for format as show below.

5 Click Preview Play and move the scrub bar in View 2 to see the Display 
Time in View.

6 In the Animation Producer, select File Record > Script.

7 Set the following in the Record Script dialog, and then click OK to begin 
recording:

Output File: should be 10_Solartime.000.bmp by default

Aspect: NTSC (720X485)

Gamma: 1.70 (Use this value for Luxology renderings)

Format: Windows BMP

Render Mode: Luxology

Render Setup: Exterior Good

Light Setup: Solar Study
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Environment Setup: Physical Sky

8 Use the Movie player (Utilities > Image > Movies) to playback the rendered 
frames after the rendering of 60 frames.

9 Using Window Media Player open the SolarStudy.wmv file and play the 
previously rendered example movie.

Note: This example movie’s script animates the sun rising in the Physical Sky 
where 30 seconds equals 1 Frame. This animation covers 3 hours of 
time from 7:00am to 10:00am, which is 180 minutes of time. The 
frames are rendered at 30 second intervals (time lapse) so that the total 
number of rendered frames is 2X180 or 360 frames.

You could add items to change the Solar Color beginning yellowish at sunrise, 
changing to white at noon, and then reddish as the sun sets. This is one of the 
many advantages of using the Animator’s tools to animate solar time, as this 
could not be done using the Solar Study Utility. You could also animate the 
camera view during this same period of time.

Solar Study Utility

The following steps show how you would use the Solar Study utility to animate 
solar time over a period of days rather than hours.

 How to create a multi-week solar study demonstration:

1. Continuing in 10_Solartime.dgn, in the Animation Producer choose Settings 
> General.

2. To reduce the number of frames for a longer period solar study, set the Time 
Display to 1 Day=1 Frame.

3. Click on the calender icon for Start and set the following in the following:

Solar Time: 08:00 AM
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Start Time: Enter start date and time

4. Click on the calender icon for End and click on the right arrow by the month 
until you are on the one day earlier 1 year later.

Note: Because we are only going to render one frame for each day at 8:00am, 
the end time does not matter as long as it is later than 8:00am.

10 Set the following in the Record Script dialog, and then click OK to begin 
recording 365 frames:

Output File: should be 10_Solartime.000.bmp by default, but you can 
change the name to prevent overwriting the previously rendered frames 
with the same name to 1year000.bmp.

Aspect: NTSC (720X485)

Gamma: 1.70 (Use this value for Luxology renderings)

Format: Windows BMP

Render Mode: Luxology

Render Setup: Exterior Good

Light Setup: Solar Study

Environment Setup: Physical Sky

11 Use the Movie player Utilities > Image > Movies to playback the rendered 
frames after the rendering is completed.
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12 Using Window Media Player open the SolarStudy_1Year.wmv in your data 
set Movies folder and play the previously rendered example movie.
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Animation Outputs
Module Overview

This module shows how to include previously created animation scripts in a final 
animation. It provides a description of the Record Script dialog as used with the 
Luxology Rendering tool, network rendering, and how to generate PDF output. 

Module Prerequisites
• Knowledge Luxology and visualization techniques

• Basic MicroStation V8i

• Completion of prior modules of the Animation course

Module Objectives

After completing this module, you will be able to:

• Create an Animation movie of a script using Luxology

• Set up process for Rendering an animation across a network

• Create an animation inside a PDF document
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Recording Scripts 

After you have created, reviewed and are satisfied with a completed script, you 
use the Record Script dialog to create the final renderings of each frame of your 
animation sequence. By recording individual frames you will have the flexibility to 
re-record individual or a sequence of frames, to improve your final production.

The Record Script tool is located in the Animation Settings tools of the Animation 
Tasks.

The basic steps and settings used to create a recording, are as follows.

• Output File- Click on the magnifying glass to select the path and directory you 
want to use for storing the rendered frames. The default location is 
C:\ProgramData\Bentley\MicroStation V8i 
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(SELECTseries1)\WorkSpace\Projects \Untitled\out. The output directory can 
be set in MS_IMAGEOUT.

• Aspect - Select the Aspect Ratio from a list of standards or select set your own 
value from one of the active views for creating the renderings.

• View - Select the view displaying the animation from the option list.

• Gamma - Set the Gamma value to match the one in the Light Setup which can 
be found on the Brightness Tab of the Light Manager typically 1.7 for Luxology 
renderings.

Warning: The default setting is 1.0, but you should match the settings from 
your Light Setup If you do not modify this setting for a Luxology 
rendering, the lighting may be too dark. If this happens you can use 
the Tone Map Animation Frames utility to fix this and other 
brightness issues. 

• Format - There are numerous options for Format. TIFF (Tag Image File Format) 
is one of the most popular.

Hint: It is recommend that you a lossless format such as TIFF or BMP for 
rendering your animation frames rather than a lossy format such as 
JPEG. The process of creating a media file AVI, WMV, MP4 etc. will 
introduce some noise artifacts and using JPEG will make your movies 
have even noisier.

• Compression - When you select a format the system selects the optimum 
compression application for the selected format. You can override these 
settings.

• Mode - Typically 24 Bit Color is used, but others are available including gray 
scale and monochrome.

• Render Mode - Standard display mode (wireframe through Smooth 
rendering) is available and is very fast. Photorealistic rendering through 
Luxology rendering takes the longest time but this depends on the capabilities 
of your hardware. Selecting Luxology also provides the ability to select 
Render, Light and Environment setups.

Note: If not already familiar with the Luxology rendering tools you should take 
the Visualization course.

• Clear Pattern/Bump Maps Between Frames - Only enable this function if you 
have a number of different pattern images used between frames. If using a 
number of very large animated patterns.
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RPC files are a special third party image format from ArchVision® and 
supported by MicroStation. RPC Libraries can be purchased directly from 
ArchVision at www.archvision.com.

• Record Range

Begin Time - set the frame number of the start of your animation sequence.

End Time - set the frame number of the end of your animation sequence.

Note: Record Range is dependent on what settings you have in the Animation 
Settings dialog.(minutes, days, weeks, etc.).

• Record Selection - Selecting this option lets you record from a specific time.

• Field Rendering - Typically this option is off. This option is used to render 
interlaced video frames for NTSC video (30 frames/second) or PAL (25 frames/
second) to be played back on and old analog television.

• Motion Blur - Luxology Only typically, this option is turned on.When enabled, 
Luxology will take time samples forward and backward from the rendered 
frame blending them together to create the blur effect. Depending on the 
strength of the effect or the speed of motion in your frame, you may find it 
necessary to increase the number of antialiasing samples. Adjustments to Blur 
Length (like adjusting the exposure time for more or less blur) and Blur Offset 
can be found on the Advanced tab of the Render Settings dialog.

• Use Distributed Rendering - If enable and Distributed Rendering Process 
Controller is running a Distributed Rendering process with be used to package 
up the required files and start the job. Be sure to have the Process Controller 
running on at least two machines to take advantage of multiple computers on 
your network (see Network Rendering later in this chapter for details).

• At this point you are ready to click OK and save the animation frames to disk. 
However, due to time constraints, you will not have time to render these files 
during the instructor led course.

 Exercise: Recording an existing script 

1 Open 11_dlamp_luxology_record.dgn.
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2 Apply the Saved View Camera View to View 2 using Window Size option.

3 In the Animation Producer dialog, select File > Record Script, set the 
following, and then click OK:

Output File: Use Default location

Note: If you change the name of the output file, be sure to add the correct 
number of zeros. If the animation is less than 1000, add 3 zeros. If more 
than 1000, add 4. If more than 10,000, add 5 etc.

Aspect: 640X360

View: 2

Gamma: 1.7

Format: Tag Image File Format

Render Mode: Luxology

Render Setup: Interior Good

Light Setup: Lamp Scene

Environment Setup: DLAMP

Begin Time: 0

End Time: 480

By default, the name will be the same as that of the design file and begin 
with the frame number set by the Begin Time and End Time option. In this 
case, the name is 11_dlamp_luxology_record000.tif. If this were final 
output for an actual project, it is recommended you use either TIFF or 
Targa as the file format. These formats take up considerably more disk 
space but they are uncompressed and will look better when compiled into 
a movie using formats such as MPEG1, MPEG2, AVI or MOV.

Note: The Use Distributed Rendering option located in the bottom portion of the 
Record Script can be automatically started and participate in rendering the 
animation frames to disk. 
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Playing Back the Results 

Once you have the frames rendered to disk you can use MicroStation’s Movie 
player to load and playback the sequentially named frames.

You can also use the Movie player to save the Movie as a Microsoft AVI movie. For 
best results, use a non-linear editing package for adding effects such as transitions 
or sound and for saving with a variety of video CODECs (compression de-
compression) options for playback on modern systems.

In the next exercise you will play the movie based on the script you just 
completed. The movie was rendered to frames then compiled into a WMV movie 
format ready to be played back using Microsoft’s Media Player.

 Exercise: Playing back a pre-recorded animation

1 Using Microsoft Media Player, open the file 
11_dlamp_record_script_video.wmv from the class data set and play the 
movie. 

This movie made use of some of Luxology rendering materials containing 
displacement, bump maps, opacity and a background image in the 
Environment setting. 

Distributed Rendering 

You can use several machines to do one rendering or animation by using 
Distributed Rendering. Its basic requirement is that all processors taking part in 
the rendering have access to all the DGN, texture, RPC, and raster files to be used 
in the rendering. It is also necessary that all processors taking part in the 
rendering have access to the output path for saving the frames.
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Simplified setup for Distributed Rendering 

Setting up this new version of Distributed Rendering is simple. To use Distributed 
Rendering, you must first launch the Distributed Processing Controller from the 
MicroStation start menu. 

The first time that you start the controller, you are prompted to define your 
Shared (probably server) Directory. This determines where Distributed Rendering 
stores the information it needs to configure your controller and pass data back 
and forth between multiple machines. All machines that will participate in the 
rendering.

Warning: The Process Controller needs to be running on all the machines that will participate 
in the network rendering and they should all be using the same version of 
MicroStation.
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Distributed Rendering Work Flow

 How to set up Distributed Rendering:

1. From the Start menu, select Bentley > MicroStation V8i(SELECTseries 3) > 
Process Controller for Distributed Rendering. The Configuration Settings dialog 
opens. 

2. To select a Shared directory, click the button to the right of the field.

3. Select a shared folder and click OK.
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5. When Distributed Rendering is available, the Bentley Distributed Processing 
Scheduler icon appears in the System tray.

Distributed Rendering Related dialogs 

The Scheduler is accessed by right clicking the Process Controller tray icon and 
choosing Open Scheduler. The Job Monitor is accessed by right-clicking the 
Process Controller tray icon and choosing Open Job Monitor.

Scheduler 

The Scheduler dialog is used to schedule times that your system is available for 
contributing to processing images. 

Job Monitor 

The Job Monitor dialog displays the progress of your distributed rendering tasks.

Luxology Network Rendering

Selecting the Begin Network Rendering tool in the Luxology Rendering dialog, 
creates a distributed rendering job that renders a new solution of a selected view 
or, if a fence is present in the view, the fence contents.

Note: When using distributed rendering from the Luxology dialog to render a high 
resolution still image, it is not necessary to have design and workspace 
resources shared on the network. These assets are converted to a render-
optimized format and copied to the distributed rendering shared directory for 
use by other distributed render machines. The machine that submits the job 
has to complete the preprocessing phase and package the design resources by 
itself. After that, one machine handles the illumination computation phase by 
itself (if Irradiance Caching is turned on in the active render setup). Once there 
is no more illumination passes to compute, all the other machines join in the 
rendering job to contribute by rendering portions of the scene called buckets.

Note: When sing Distributed Rendering is used to compute animation frames an 
entire frame is rendered by each contributing computer or node. In this case 
each of the contributing nodes will compute the irradiance passes and render 
the frame before moving on to the next one on the sequence.
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After submitting a distributed rendering job from the Luxology dialog, clicking 
Cancel in the Luxology dialog cancels the distributed rendering job for all 
machines. Closing the Luxology dialog while the distributed rendering is active 
only causes the active session to stop previewing and participating in the 
distributed rendering job. If there are still other machines working on the 
distributed rendering job, the final result is placed in the Network Image History 
folder.

Luxology Network Rendering Options

Clicking the arrow next to the Begin Network Rendering tool will display the 
network rendering options.

• Network Image History specifies the folder in which the files created by 
Luxology distributed rendering are placed. 

• This is different from the Luxology history folder because that directory may 
not be accessible to other machines that participate in distributed rendering 
jobs. If this directory is not accessible by other machines, Luxology distributed 
rendering jobs may not succeed.

• Maximum Tile Size specifies the largest size for each distributed rendering tile. 
In general, larger tile sizes offer better performance making them too small 
will result in slow down as you are waiting on the network. Use a smaller tile 
size only if there are many machines participating in the distributed rendering 
job to ensure that each gets its own tile on which to work.

• Group specifies the distributed rendering that will be allowed to participate in 
this job.

• Include Current Session specifies whether or not the current session will also 
work on the distributed rendering job. If this option is checked, the current 
session handles the illumination computation phase of the rendering. This is 
an easy way to ensure that the most powerful machine in a distributed 
rendering farm handles this phase, which is important since this is the longest 
portion of rendering an image that cannot be distributed across multiple 
machines.
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Saving 3D Content in PDF Files

With the release of Adobe® Reader® 9.0, Adobe´s PDF format supports the 
embedding of 3D content within documents. In MicroStation, the creation of PDF 
documents with 3D content is similar to printing a standard 2D document.

Where 3D content is included, it will contain any visualization data and settings 
that already exist within the design file, such as lights, materials, texture maps, 
and animation or camera movement (flythroughs). Additionally, Saved Views are 
included in the 3D content.

Any 3D content within a PDF document is stored in “Universal 3D” (U3D) format. 
This format was introduced by the 3D Industry Forum (http://www.3dif.org/) as a 
means for transferring three dimensional data from CAD systems to mainstream 
applications such as marketing, training, sales, technical support, and customer 
service. MicroStation lets you export geometry directly to U3D, or to seamlessly 
create PDF documents with embedded U3D objects.

Adding 3D content from design models

From a 3D design model, you can add 3D content to a PDF file simply by selecting 
Bentley Driver and enabling the Print to 3D setting in the Print dialog.

3D Plotting Options

Settings that control the 3D content are found in the 3D Plotting Options dialog 
(Settings > 3D Plotting, in the Print dialog). These settings, which are saved in the 
user preference file, are retained between sessions.

Animation in 3D content

Animation scripts created with MicroStation’s Animation Producer (Utilities > 
Render > Animation) can be used to specify geometry or camera motion that can 
be exported to U3D and viewed dynamically within the PDF document. When a 
model is saved to U3D the script currently loaded in the animator, is used to 
specify the U3D animation. In Adobe Reader, the animation can be started or 
paused by selecting the 3D object and then selecting the Start Animation or Pause 
Animation buttons from the tool bar.
Oct-13 151 Animation Outputs
Copyright © 2013 Bentley Systems, Incorporated



Saving 3D Content in PDF Files
Creating 3D content in PDF

To demonstrate this feature, in the next exercise you will create a PDF file that 
contains 3D content. The data set that you will use also includes an animation 
script for a simple fly around of a building. The animation script is provided for 
you to see this functionality when creating the PDF file. Details on the creation of 
the animation, however, is beyond the scope of this course.

 Exercise: 3D in PDF from a design model

1 Set the following in the File Open dialog:

User: examples

Project: General

2 Open Animation.dgn, and then open the model Actor Targets.

3 From the main menu bar, select File > Print to open the Print dialog.

4 Set the Printer to Bentley Driver and select pdf.pltcfg as the printer driver.

5 In the Print dialog, enable Print To 3D.

6 In the Print dialog, select Settings > 3D Plotting.

7 In the 3D Plotting Options dialog, set the following:

Convert Animation: Enabled
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Automatically Activate Animation: Enabled

8 Click OK in the 3D Plotting Options dialog.

9 In the Print dialog, click the Print icon or select File > Print.

10 Set the Directory in Save Print As dialog to C:\.

11 Click OK to save the Animation-Actor Targets-000.pdf file to the hard drive.

A progress bar appears at the bottom of MicroStation application window, 
indicating the percentage of completion. Once the PDF is finished you will 
see message Finished Creating Print at the bottom of screen.

The 3D content in the Adobe PDF file will be displayed using smooth shading. For 
best results you may need to adjust your materials to look their best using smooth 
shading. For instance a glass material that looks great ray traced may appear too 
transparent when smooth rendered.

Note: The design file used for this exercise has an associated Animator script, and the 
animation will playback on startup from Adobe Acrobat Reader 9.

Interacting with 3D content in Adobe Reader

In order to open the PDF file generated in MicroStation, it will be necessary to 
download and install Adobe Acrobat® 9.0 or later version, if available. Currently, 
you can download the software from http://www.adobe.com/products/acrobat/
readstep2.html.

Once a PDF document containing 3D content is created from MicroStation, it can 
be opened with Adobe® Reader® 9.0 in the same manner as a standard PDF file. 
Inside the PDF file, clicking on a 3D object will activate a toolbox with a set of 
tools for navigating within the scene. The standard Adobe Reader tools (Rotate, 
Navigate, Zoom, and Pan) are documented in the Adobe Reader Help. Saved 
Views are available from the Views menu entries. The following are two images 
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from the Adobe animation. Remember to click on the play button to start 
animation.
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MicroStation V8i for Animation 
Assessment
Assessment is often equated with evaluation, but the two concepts are different. 
Assessment is used to determine what an individual knows or can do. 

Complete the assessment to see what you have gained from reviewing this 
module or course (access to surveygizmo.com is necessary).

Note that assessments are for classroom or virtual classroom learning, and not for 
OnDemand learning.

Take Assessment
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