
 

DO NOT DISTRIBUTE – Printing for student use is permitted 

Designing Inlets to Collect Runoff 
 
This course is for the 2021 Release 1 version of: 

OpenSite Designer CONNECT Edition 
OpenRoads Designer CONNECT Edition 
OpenRail Designer CONNECT Edition 
 

About this Practice Workbook... 

• This workbook is designed for use in Live instructor-led training and for OnDemand self-study.  OnDemand videos for 
this course are available on the LEARNserver and through CONNECT Advisor. 

• This PDF file includes bookmarks providing an overview of the document. Click on the bookmark to quickly jump to 
any section in the file. 

• Both Imperial and Metric files are included in the dataset. Throughout this practice workbook Imperial values are 
specified first and the metric values second with the metric values enclosed in square brackets.  
For example: 12.0’ [3.4m]. 

• This course workbook uses the Training and Examples WorkSpace and the Training-Imperial or  
Training-Metric WorkSet delivered with the software. 

• The terms “Left-click”, “Click”, “Select” and “Data” are used interchangeably to represent pressing the left mouse 
button. The terms “Right-click” and “Reset” are also used interchangeably to represent pressing the right mouse 
button. If your mouse buttons are assigned differently, such as for left-handed use, you will need to adjust accordingly. 

 
Have a Question? Need Help? 

• If you have questions while taking this course, search in CONNECT Advisor for related courses and topics. You can also 
submit questions to the Civil Design Forum on Bentley Communities where peers and Bentley subject matter experts are 
available to help 

Course Level: Fundamental Edition: 03-01 

http://learn.bentley.com/app/Public/BrowseLearningPaths?CustomLP=False
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Designing Inlets to Collect Runoff 

This class will show you how to place inlets with catchment delineation, to collect the runoff from a road surface. You will learn how to check 
whether the inlet efficiencies, and the spread widths of the flows along the road edge, are acceptable, and adjust the design so that they are. 

Note: catch basins can also be called Pits, Gullies, or Inlets. In this class the term catch basin will be used to describe a drainage node that 
accepts surface runoff. 
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Getting Started 

1. Start the software. 

2. Set the WorkSpace and WorkSet. 

The WorkSpace and WorkSet define standards that are used by the software. The Training and Examples WorkSpace that 
is used by this class is included in the software install. If you don’t use this WorkSpace, you may not have the feature 
definitions that are used in this class. 

3. Click the left-hand down arrow and select Training and Examples from the 
WorkSpace menu.  

4. Click the left-hand down arrow and select Training-Imperial [Training-
Metric] from the WorkSet menu.  

 

5. Open a design file.  

a. Click Browse.  

The dialog automatically opens in the path defined in the location for Design files that you specified when you selected the 
WorkSet Path a moment ago. Navigate to the C:\Bentley Training\Designing Inlets to Collect Runoff folder. 

b. Select the file name Intersection-Drainage-Imperial.dgn [Intersection-Drainage.dgn]. 

c. Click Open. 

NOTE: If you get a message stating “Incompatible Civil Data”, this is because the training files are “aligned” to 
OpenSite Designer. Clicking Yes will align the file to the software you are using (OpenRoads or OpenRail Designer). 
This will have zero impact for training.  Note that in production, upgrading the file will make the file read-only in 
OpenSite Designer. Full information is available at Bentley Communities - Product Realignment. 

6. Change the workflow to Drainage and Utilities. 
  

https://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/40396/video-product-alignment-incompatible-civil-data
https://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/40396/video-product-alignment-incompatible-civil-data
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Exercise 1: Place Catch Basins with Catchment Delineation 

Description 

In this exercise, you will place catch basins with catchment delineation using two methods of placement.  

Skills Taught 

• Use the Place Node tool to place several Catch Basins 

• Use Snaps and Civil Accudraw 

• Generate catchments 

• Review the 2D and 3D graphics, placement position, and orientation 

• Review the catch basins and catchment properties 
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Checking Project Reference Files 

The first thing you need to do is check the references in the active file. 

1. On the Home ribbon, click Primary > Attach Tools > References. 

Note: References have already been attached and some have the Display icon clicked to turn off the display of the model.  

2. Put focus on to View 1, by clicking on its title bar. 

The Default model References are shown below. 

 

 

 

 

 

 

 

 

 

 

 

3. Check the Default-3D model References as well. 

The Default-3D model References are shown below. 

A reference that contains a terrain model for the surface of the intersection – Intersection-Terrain - is displayed in the 
Default-3D model. This will be used when placing the inlets and catchments. 
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4. Close the References dialog. 

5. Make sure focus is on to View 1, by clicking on its title bar. 

6. On the Home ribbon, click Primary > Level Display. 

7. Select the Intersection-Corridor.dgn 

Note that some of the Corridor Levels have already been turned off. This will help when placing the 
catch basins. 

8. Close the Level Display dialog. 
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Feature Definition Toolbar and Persist Snaps 

The Feature Definition Toolbar needs to be active. This will give access to the Persist Snaps Toggle. 

1. Set the Active Workflow to OpenRoads Modeling / OpenSite Modeling / OpenRail 
Modeling – as appropriate for the product you are using. 

 

 

2. On the Geometry ribbon, click General Tools > Feature Definition Toolbar.  

 

 

 

 

 

3. Check that Persist Snaps is toggled on. 

When you place catch basins with AccuSnap and Civil AccuDraw you are 
creating rules and relationships. If the parent feature moves - the catch basins 
will also move. 

 

As an example of this, the catch basin on the left has been placed with 
AccuSnap with Persist Snaps On. The catch basin on the right has been 
placed with AccuSnap with Persist Snaps Off. 

 

If the parent feature (the red line in the pictures) is moved horizontally, 
vertically or both, only the catch basin placed with AccuSnap and Persist 
Snaps On moves, because it was ruled to the parent feature. 
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The catch basin on the right does not move, because it was not ruled to 
the parent feature. 

4. Close the Feature Definition toolbar. 
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Set the Active Terrain Model  

1. Click on title bar of View 2, Default-3D to make it active.  

 

 

2. Window to the area as you can see in the image.  

 

3. Left click on the contour as you can see in the image. 
 

4. Hover the cursor at the contour for a few seconds and context sensitive toolbar 
appears displaying tools commonly used with terrain models.  

 

 
 

The tooltip will show Terrain Model: Design-Boundary. 

 

5. Click the Set as Active Terrain Model tool. 

Setting the terrain model active instructs the software to use the active terrain model as the default terrain model when using other 
design tools. You can always change or clear the active terrain model at any time. 

6. Click on title bar of View 1, Default to make it active 
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Placing Catch Basins and Catchments using AccuSnap 

1. Set the Active Workflow back to Drainage and Utilities. 

2. On the Layout ribbon, click Place Node. 

3. On the Place Node dialog set the following: 

a. Set the Feature Definition to Node > StormWaterNode > Inlets > Training 
Combination Inlet  

b. Check Vertical Offset, set value to 0. 

c. Select Rotation Mode to Relative to alignment. 

 

 

 

 

 

 

4. Following the Heads-up prompts, set the following: - 

a. At the Select Reference Element for Node Elevation. Reset to Type Elevation 
prompt, select the Design-Boundary Terrain feature from View 2. Select the 
contour as you can see in the image. 

b. The dialog now changes, and Catchment Delineation is now available. 
Check this on. 
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c. Set the Catchment Feature Definition to Drainage Area > Catchment > Pavement. 

 

 

 

 

 

 

 

 

 

 

 

The Hydraulic Properties of the Catchment will be populated from the 
Hydraulic Prototype. One of these properties is the Runoff Coefficient 
for the catchment. When you pick a Feature Definition, you pick a 
Hydraulic Prototype. When placing the catchment, the settings defined in 
the Prototype are copied into the catchment’s data record. 

Prototypes can be viewed and edited using the Components > Catalog > 
Prototypes tool or viewed and selected through Home > Explorer > 
OpenRoads Standards > Active File > Feature Definitions > Drainage Area 
> Catchment > Pavement > Hydraulic > Prototype. 
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5. Select Snap Mode AccuSnap > Near Snap Point. 

 

 

 

6. At the Define Catchbasin prompt, data point on the D-CWAY-Gutter 
Flow Line feature opposite the catch basin on the intersection 
approach in View 1. 

 

 

 

 

 

 

7. Follow the Heads-up prompt: 

a. Data point to accept the Rotation Mode > Relative to alignment 
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b. At the Locate Reference Element for Rotation prompt, data point on the 
D-CWAY-Gutter Flow Line. 

At this point the catch basin is placed.  

 

 

 

 

 

 

 

c. Type 90 for the Rotation and Enter, then data point to accept the 
rotation.  
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The placed catch basin can now be seen in both the Default and Default-3D views 

The catchment area has automatically been created and can be seen only in the Default view. 

 

 

 

 

 

 

 

 

 

 

8. Select the catch basin and view the Quick 
Properties. Note the design intent – it is ruled to the 
gutter flow line feature both for position and rotation. 
The catch basin will be updated if the element is 
subsequently modified. The Elevation Reference is 
the terrain. 
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Moving in a southerly (downstream) direction place another catch basin, snapping to the gutter feature. 

9. On the Place Node dialog set the following: 

a. Check the Vertical Offset value is 0. 

b. Check the Rotation Mode is Relative to alignment. 

c. Check the Feature Definition is Node > StormWaterNode > Inlets > Training Combination Inlet. 

10. From the Heads-up prompts set the following: - 

a. Select Reference Element for Node Elevation. Reset to Type Elevation prompt, select the Design-Boundary Terrain 
feature from View 2. 

b. The dialog now changes, and Catchment Delineation is now available, check this on. 

The Catchment Feature Definition is now available in the dialog. 

c. Check the Catchment Feature Definition is Drainage Area > Catchment > Pavement. 

d. Check the Snap Mode is Near Snap Point.  

Note that double-clicking the icon will set it to the default snap mode, which 
can be easier than remembering to check it. 

 

e. At the Define Catchbasin prompt, data point on the D-CWAY-Gutter Flow Line feature opposite the catch basin on the 
intersection approach in View 1. 

f. Data point to accept the Rotation Mode > Relative to alignment 

g. At the Locate Reference Element for Rotation prompt, data point on the D-CWAY-
Gutter Flow Line.  

At this point the catch basin is placed.  

h. Type 90 for the Rotation and Enter, then data point to accept the rotation. 

 

 

New Catch Basin 
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Note: how the area for the new catchment has stopped at the edge of the previous area. 

 

 

 

  

 

 

 

 

 

 

 

 

11. On the Layout ribbon, click the Element Selection icon. 

12. Select one of the catchments and view the Utility Properties. 

A line is also displayed from the centroid of the catchment to the Outflow Element. 
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13. The Utility Properties show information such as the Outflow Element the 
catchment flows to, and Runoff properties such as Runoff Method and Runoff 
Coefficient. 

There are numerous properties with values of N/A. This is because you have not yet 
computed the system yet. 
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Placing Catch Basins and Catchments using Civil AccuDraw 

 Civil AccuDraw is used for precision input and will be used here to place catch basins that are ruled to civil geometry by station and offset. 

 

1. Select Layout > Toggles > Civil AccuDraw to display the Civil AccuDraw toggle bar. 

 

2. Dock the toggle bar next to the AccuSnap tools at bottom of the screen. 
            

 

3. Click the Toggle Civil AccuDraw icon on the toggle bar. 

4. Click the Station-Offset icon on the toggle bar. 

 

The next catch basin you will place is near the pond. The levels that the pond features are displayed 
on are turned off in the Default view. 

5. Make sure focus is on to View 1, by clicking on its title bar. 

6. On the Home ribbon, click Primary > Level Display. 

Note that some of the Corridor Levels have already been turned off. This will help when placing the 
Catch Basins. 

7. Click on Intersection-Corridor.dgn, Default to select it. 

8. Click on D-EWKS-Ground Interface and D-EWKS-Back of Verge, to turn the display of these levels 
on. 

9. Close the Level Display dialog. 
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Window to the area where the pond is located in order to place the next node. 

 

 

 

 

 

 

 

 

10. On the Layout ribbon, click Place Node. 

11. In the Place Node dialog set the following: - 

a. Check the Vertical Offset is 0. 

b. Check the Rotation Mode is Relative to alignment. 

c. Check the Feature Definition is Node > StormWaterNode > Inlets > Training Combination Inlet. 

12. From the Heads-up prompts set the following: - 

a. Select Reference Element for Node Elevation. Reset to Type Elevation prompt, select the Design-
Boundary Terrain feature from View 2. 

b. The dialog now changes, and Catchment Delineation is now available, check this on. 

The Catchment Feature Definition is now available in the dialog. 

c. Check the Catchment Feature Definition is Drainage Area > Catchment > Pavement. 
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13. At the Define Catchbasin prompt Civil AccuDraw input fields Station and Offset are now added to 
the prompt. 

14. Tab to highlight the Offset input and type the letter ‘o’.  

 

Note: that ‘o’ is the shortcut key for setting the reference element and stands for ‘Offset’. 

 

15. At the Select a reference element or Reset to return to command prompt, click the D-CWAY-
Gutter Flow Line feature. 

 

 

 

 

 

 

 

 

16. Civil AccuDraw is now locked on the feature and by using the Tab key to highlight Station, set value to 
49.2’ [15m], press Enter on keyboard to accept and lock the value. 

17. Offset will now be active, set value to 0, press Enter on keyboard keyboard to accept and lock the 
value.  

a. Data Point to accept the location. 

b. Data point to accept the Rotation Mode > Relative to alignment 

c. At the Locate Reference Element for Rotation prompt, data point on the D-CWAY-Gutter Flow Line.  

At this point the catch basin is placed.  

d. Type 90 for the Rotation and Enter, then data point to accept the rotation. 

You need to place two more catch basins.  
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18. Window to the area where there is text saying, ‘Low Point’. 

 

19. At the Define Catchbasin prompt Civil AccuDraw input fields Station and Offset are now visible. 

20. Tab to highlight the Offset input and type the letter ‘o’.  

21. At the Select a reference element or Reset to return to command prompt, click the D-CWAY-Gutter Flow Line feature. 

22. Civil AccuDraw is now locked on the feature and by using the 
Tab key to highlight Station set value to 227.2’ [84.5], press 
Enter on the keyboard to accept and lock the value. 

23. Offset will now be active, set value to 0, press Enter on the 
keyboard keyboard to accept and lock the value.  

a. Data Point to accept the location. 

b. Data point to accept the Rotation Mode > Relative to 
alignment 

c. At the Locate Reference Element for Rotation prompt, data 
point on the D-CWAY-Gutter Flow Line.  

At this point the catch basin is placed. 

d. Type 90 for the Rotation and Enter, then data point to accept the rotation. 
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24. Repeat steps 20 to 23 above to place the last catch basin at the 
location below. 

25. For the Station, set the value to 316.6’ [96.5]. For the Offset, set 
value to 0. 

26. Click the Element Selection icon, or press Esc on the keyboard, to 
exit the command. 

27. Click the Toggle Civil AccuDraw icon on the toggle bar, to 
deactivate it. 

 

 

 

 

28. Check the Properties of the last catch basin you placed. 

 

 

 

29. Note the Station and Offset values that you just entered are 
shown. These values can be changed if required, to move the 
catch basin. 
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30. From the Properties, click Open Utility Properties. 

31. Click the Browse icon. 

 

 

 

The Utility Properties show information such as the Inlet Type and Longitudinal Slope.  

Inlet Location properties show as On Grade, but this catch basin is at the low point of the gutter flow line. 

32.  Select the Inlet Location property and change it to In Sag. 

Note: A grate inlet in a sag operates as a weir up to a depth of about 150mm and 
as an orifice for depths greater than 450mm. Between these depths, a transition 
from weir to orifice flow occurs. 

33. Close the dialog box 
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Exercise 2: Checking Spread Widths 

Description 

In this exercise, you will set up the data needed for a gradually varied flow scenario using a backwater analysis, compute it to calculate the 
hydrology and hydraulics, and review the messages for potential issues.  

The exercise will start with an overview of scenarios, to give you an appreciation of what they are. In this class, you will be placing catch 
basins and checking whether they are in the correct position to drain the road surface effectively. You will be analysing the hydrology of the 
catchment areas, and the hydraulics of the catch basins, to see how well they perform. You can do this using a single scenario, but it is still 
important that you know what a scenario is, and what it does. 

Skills Taught 

• Understanding Scenarios 

• Review the Base Rainfall Runoff rainfall event for the Analysis Scenario  

• Review the Calculation options  

• Compute an Analysis Scenario to see how well the catch basins cope with a rainfall event 

• Review the spread widths at the catch basins 
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Understanding Scenarios 

Given that … 

• there are hundreds of properties involved in hydraulic design and calculations 

• regulatory agencies often require analysis on multiple variations of constraints (such as multiple storm events) 

• the engineering design process itself often requires evaluation of alternative solutions 

having a logical and manageable system to manage and compare the variations in the hundreds of properties is essential to ensure 
optimum design. This is what the effective use of Scenarios offers you. 

Drainage and Utilities groups similar properties into function-based groups called Alternatives.  Calculations are then performed on a bundle 
of Alternatives, which are grouped together in Scenarios. A Scenario also controls how the calculations are performed, in the Calculation 
Options. 

• Property – a property is any stored characteristic of a model element. Examples include: 

o a single numeric quantity such as a pipe’s Diameter, Length, or Roughness.  

o a Yes/No toggle such as Design Conduit? 

o A value from a list such as Design or Analysis for Calculation Type 

• Alternative – an Alternative is a logically organized set of properties. Examples include: 

o Physical Alternative – groups physical data for the network's elements, such as elevations, sizes, and roughness coefficients.  

o Design Alternative – groups engineering criteria that will be applied during calculations such as velocity limits and other 
settings that may or may not be applied during calculations such as adjusting pipe diameters and inverts. 

o Rainfall Runoff Alternative – allows different storm events to be used in calculations. 

• Calculation Options – a Calculation Option contains properties that control how to ‘solve’ the hydraulics and hydrology of the 
drainage system. Examples include: 

o Calculation Type – whether the system is to be analysed (doesn’t change elevations or sizes) or designed (hydraulic 
optimisation of elevations or sizes)   

o Active Numerical Solver – the methods used for the calculations, such as ‘Rational Method’ and the settings that the method 
needs.  
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• Scenario – a Scenario contains a set of Alternatives, and the settings that control how the hydraulics and hydrology are calculated.  
This “bundling” of Alternatives lets you easily generate system conditions that mix and match groups of data that have been 
previously defined. Note that Scenarios do not actually hold any attribute data – the referenced alternatives hold the data. 

There is always a current scenario. It specifies the current alternatives. The current alternatives are where your data is stored. 

You can use multiple Scenarios to calculate multiple "What If?" situations, in a single project file. You can try several designs and compare 
the results, or analyze an existing system using several different input alternatives, and compare the results. 

Scenarios and Alternatives can “inherit” properties from other Scenarios and Alternatives.  These Parent-Child relationships are a critical tool 
in easily managing variations from otherwise global properties. 

When creating a new project, Scenarios and Alternatives are copied from the Hydraulic Seed File. This is a DGN Library, which is specified 
in the WorkSpace or WorkSet configuration. 

Scenario Manager 

The Scenario Manager is the primary interface for creating, editing and managing an unlimited 
number of Scenarios.  

There must be at least one Scenario.  Additional Alternatives and Scenarios are easily created to 
handle any design requirements. 

Examples include: 

• Competing physical layouts may be managed by different Physical Alternatives.   

• Different Storm Frequencies may be managed by different Rainfall Runoff Alternatives. 

 

There are two types of Scenarios: Base Scenarios and Child Scenarios. 

• Base Scenarios contain all of your working data. When you start a new project, you begin with a default Base Scenario. As you enter 
data and calculate your model, you are working with this default Base Scenario and the alternatives it references. 

• When a Child Scenario is created, it inherits its data from its Parent. More precisely, its Alternatives and Calculation Options are links 
to the Alternatives and Calculations Options of its parent.   
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Scenario Properties 

As stated above, Scenarios are simply a list of Alternatives and a Calculation Options definition. 
Viewing, changing, and managing the different alternatives associated with a scenario is done 
through the Properties dialog. To view the scenario properties, double-click on the scenario, or 
right-click on the scenario and choose Properties. 

A list of the alternatives associated with the scenario will be displayed in the Properties dialog.  

If you have created a new Base Scenario, all the Alternatives will be the same as in the “copied” 
Scenario.  They will be copied, but they will not maintain any further relationship to the original 
Scenario’s Alternatives.   Changes to the original Scenario do NOT propagate to the new Base 
Scenario.  

If you created a Child Scenario, the scenario will initially inherit all of the alternatives from the 
parent scenario. In this case, you will see the "I" next to the name of the alternative. Changes to 
any of the settings in the original scenario – a change in the Rainfall Runoff Alternative, for 
example, automatically gets propagated to the new Childe Scenario.  They’re linked. 

If you manually pick an alternative without the "I," then the Child Scenario will no longer inherit 
any changes in alternatives made in the parent scenario. 

 

 

 

 

To change any alternative for a scenario, click the pulldown beside the scenario name and select 
the alternative.  

 

 

 

If you have not yet created an alternative for the scenario, you can create a new alternative here as well, by selecting the “<New…>” item. 
You will be prompted to enter the name for the new alternative – after which the new alternative will be selected for the scenario and listed in 
the Alternatives Manager. 
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Alternatives Manager 

The Alternative Manager lets you create, view, and edit the alternatives that make up the project scenarios. 
The dialog box consists of a pane that displays folders for each of the alternative types which can be 
expanded to display all of the alternatives for that type and a toolbar.   

As with Scenarios, there are two kinds of Alternatives: Base Alternatives and Child Alternatives. Base 
Alternatives contain local data for all elements in your system. Child Alternatives inherit data from Base 
Alternatives or even other Child Alternatives. The data within a Child Alternative consists of data inherited 
from its parent and the data altered specifically by you (local data). 

Remember that all data inherited from the Base Alternative is changed when the Base Alternative changes. 
Only local data specific to a Child Alternative remains unchanged. 

 

 

Editing Alternatives 

To edit an alternative, expand the tree so that 
all of the alternatives for a given type are listed.  

There are a number of ways to open an 
alternative: 

• You can double-click on the alternative.  

• You can also highlight the alternative 
and select the Open icon.  

• Finally, you can right-click the 
alternative and select Open. This will 
open a new dialog. 

 

Each alternative will have different properties. Any column that is shown as white is a field that can be edited. Columns in yellow cannot be 
edited from the alternative, but in some cases, may be editable from other places in the model, such as the FlexTables or Properties. 

The first column in any alternative editor contains a check box indicating the records that have been changed in this alternative. If the box is 
checked, the record on that line has been modified and the data is local, or specific, to this alternative. If the box is not checked, it means 
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that the record on that line is inherited from its higher-level parent alternative. Inherited records are dynamic. If the record is changed in the 
parent, the change is reflected in the child. The records on these rows reflect the corresponding values in the alternative's parent. 

Changes made in the graphics, Properties, and FlexTables will automatically make changes to the values in the appropriate active 
Alternatives.   

Calculation Options 

The Calculation Options Manager lets you create, view, and edit the calculation options available for 
your scenarios. The dialog box consists of a pane that displays the calculation options created.  

To edit the calculation options, double-click on the one you want to edit. This will display the 
properties of the calculation options in the Properties dialog. 

The parent/child function is not available for calculation options. New calculation options can be 
created by clicking the New icon. 

Computing Scenarios 

There are several places where you can compute a scenario: 

• The Compute icon in Analysis > Calculation - this computes the current scenario. Use this if you’re confident that you know 
which scenario this is 

 

• The Compute Centre – this lets you choose the scenario to compute and shows you the most important settings 
that it contains. Use this when you are getting familiar with scenarios, as an easy way to check their settings 

 

• The Scenarios Manager – this lets you choose the scenario to compute, and 
compute multiple scenarios, in a hierarchy or by selecting a batch. You will use 
this more when you are more proficient with the software and are using more 
scenarios. 
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Checking the Storm Data 

1. On the Components ribbon, click the arrow below Common > Storm Data > Global Storm Events. 

2. Click Global Storm Events.  

Here you are choosing the storm event that you want to use. It is stored in a Rainfall Runoff alternative, and this one is called "Base Rainfall 
Runoff". This storm event is therefore specific to this rainfall runoff alternative. The "Base Rainfall Runoff" alternative has been selected in 
the scenario which you will compute in a moment. 

3.  Check that Coffs Harbour: Latitude30.237 (S) Longitude 153.1375 (E) (9.49 ARI (10% AEP)) is selected.  

4. Close the Global Storm Events dialog.  
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Checking the Calculation Options 

By default, the Gradually Varied Flow (GVF) calculations will be used to ‘solve’ the hydraulics of a storm drainage network.  

1. On the Analysis ribbon, select Calculation > Options.  

Note: The calculation options that you see here have been copied in from the DGN library.  

Note: The red tick in the icon for the Base Analysis solver icon tells you that this is the active 
calculation option.   

Perhaps the most important property of a Scenario is the Calculation Option: 
 

• An Analysis performs calculations but does NOT change pipe sizes and levels 

• A Design performs calculations and MAY change pipe sizes and elevations 

2. Double-click Base Analysis in the Calculation Options dialog.  

Note that because you are editing the active Calculation Options they will automatically be used 
by the active Scenario.  

3. The settings for Base Analysis are displayed in the Properties dialog.  

Your Calculation Options should be the same as the picture on the right.  

Notes:  

• The Active Numerical Solver is set to GVF-Rational (StormCAD), for Gradually Varied 
Flow using the Rational method.  

• The Calculation Type is set to Analysis. This will not change the pipe sizes, levels etc. – 
i.e. none of the physical data.  

• The Flow Profile Model is set to Backwater Analysis. This is the preferred option for 
computing a system because the gradually varied flow algorithms it uses are more 
rigorous and generate solutions that more closely reflect reality. 

• The Minimum Time of Concentration is set to 5 minutes. Any catchment with no Time of 
Concentration set, or one that is less than this, will be adjusted by the calculations to use 
this value.  

• Use Minimum Tc as Minimum System Time applies when a pipe at the top of a branch 
has no flow. 
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4. Scroll further down the Calculation Options. 

5. Locate the Use Rational Method Frequency Factors property in the 
Rational Method category. 

6. Set Use Rational Method Frequency Factors to True.  
 

7. Locate the Frequency Factors property in the Rational Method 
category. 

8. Click the Browse button and Key-in the ARIs and Multiplier shown in 
the screen shot below, or  

go to the dataset folder and open Frequency Factor.xlsx file, copy the data columns, and paste it in the Frequency Factors dialog box.  

9. To change the number of decimal places, Right Click on the title heading ‘Average Recurrence Interval’ and select Units and 
Formatting. 

Note if your design standards require the use of Frequency Factors, then these values should be set up your WorkSpace dgn library. 

10. Click OK to close the Frequency Factors dialog. 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

Copyright © 2021 Bentley Systems, Incorporated DO NOT DISTRIBUTE – Printing for student use is permitted 33 

11. Locate the Allow Runoff Coefficient to Exceed 1.0 property in the Rational Method category. 

12. Check that this is set to False. 

This setting does not allow the product of the Runoff Coefficient and the Frequency Factor to exceed 1.0. 

13. Repeat the process in Steps 4 - 12 above for Base Design in the Calculation Options dialog. 

14. Close the Calculation Options dialog. 
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Checking the Active Scenario 

1. From the Analysis ribbon, select Calculations > Scenario Manager.  

2. Rename the Base Analysis Scenario to 9.49 ARI GVF Analysis. 

3. Double click the Scenario and check that the Calculation Options are 
set to Base Analysis. 

4. Close the Properties panel. 
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Computing the Scenario  

1. From the Analysis ribbon, select Analysis Tools > Compute Center.  

The toolstrip at the top of the Compute Center lets you access a number of Managers and tools, to help you 
use scenarios. It always displays the current scenario when you open the dialog, but you can change the 
scenario to compute if you need to. 

2. Confirm that the Scenario is set to 9.49 ARI GVF Analysis.  

Review the other settings in the Compute Center dialog.  

Note: Settings for the Calculation Type, is set to Analysis. Remember - this means that the physical 
properties of the drainage network will not be changed. A Calculation Type that is set to Design may well 
cause the physical properties, such as invert levels and pipe diameters, to change.  

4. Click Compute. This computes the current scenario.  

 

After a few moments, the GVF-Rational Calculation Summary dialog is 
displayed.  

Due to the system only consisting of catch basins and catchments, and 
no conduits or outfall, no details are displayed in the Calculation 
Executive Summary area of the dialog.  
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5. On the GVF-Rational Calculation Summary panel, Click Details. 

This dialog is a good way to get an overview of a conveyance system, without selecting individual objects. Because we 
don’t have any gutters or pipes yet, some of the tabs don’t show any useful information, but the Inlet Summary tab does. 

6. Click the Inlet Summary tab and review the 
data. 

You can see the Capture Efficiency of each 
catch basin, and the Spread / Top Width, so 
you can easily find any big issues. 

The Catchment Summary tab is also a useful 
one to check at this stage, as it could reveal 
an issue with the storm data. 

7. Close the Details dialog. 

 

 

 

 

 

8. On the GVF-Rational Calculation Summary panel, click 
Messages.  

Review the messages.  

Note: The messages about time of concentration, no 
gutters, no outfall, and no valid network can be ignored as 
this is to be expected. 

 

9. Close the User Notifications dialog.  
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If this is the first time that you’ve used the User Notifications dialog, then the Civil Message Center dialog will now be displayed. The content 
of this will be very similar to what you’ve just seen in the User Notifications, but this dialog also displays MicroStation and other OpenRoads 
Designer messages.  

The buttons across the top of the dialog act as toggles, so you can click them to toggle the display of the errors, warnings, and information 
messages on and off. This also toggles on and off the glyphs in the graphics.  

10. Close the Civil Message Center dialog – if it is open.  

11. Close the GVF-Rational Calculation Summary and the Compute Center dialogs. 

12. User Notifications are now also shown as 
warning glyphs in the Default view. 
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Checking Hydraulic Properties 

1. Select the catch basin south of the intersection fillet (this was the first catch basin we placed) and view the Utility Properties. 

2. There are quite a lot of result fields so if you want to look at the spread width in the gutter just type in the word ‘spread’ in the Property 
Search. 

 

 

 

 

 

 

 

 

 

 

 

3. You can see that the inlet is operating at 66% of its efficiency. 

4. You can also see the width of flow in the gutter is approximately 4.778’ [1.4m]. 

Note that your values may differ slightly, as they depend on exactly where you placed the catch basin.  

5. Select one of the catchments 

6. Remove the ‘spread’ text from the Property Search if you typed it in. 

You can see the results for the catchment, including how much flow is coming off it. 

7. Keep the Properties - Storm Water Node – SA-13 open and click on the Catchment boundary. (Image shown on the next page) 



 

Copyright © 2021 Bentley Systems, Incorporated DO NOT DISTRIBUTE – Printing for student use is permitted 39 
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Exercise 3: Moving Catch Basins 

Description 

This exercise will look at moving catch basins to optimize their locations. This will also show the power of using catchment delineation, 
because the catchments are linked to the catch basins and will update automatically. 

 

Skills Taught 

• Moving a catch basin using Accusnap 

• Automatically calculate the Road Cross Slope 

• Measuring the Road Cross Slope 

• Finding the route of a bypass flow path 

• Moving a catch basin to collect bypass flow 
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Moving a Catch Basin using AccuSnap  

You are going to move a catch basin in a moment. First though, check its 
hydraulic properties. 

1. Select the catch basin SA1-13, south of the intersection fillet (which was 
the first catch basin that you placed) 

2. View the Utility Properties. 

 

 

 

 

 

3. Find the Road Cross Slope property. 

4. There are quite a lot of result fields so if you want to look at the spread width in the 
gutter just type in the word ‘slope’ in the Property Search. 

5. Note the value – 0.03 m/m. 

This value came from the prototype that is assigned to the Training Combination 
Inlet feature definition. The prototype defines the default value – so any catch basin 
placed will have this value by default. This value can be edited – you can type a new 
value in the Utility Properties for example, but you would need to measure the road 
cross slope first, then type it in. 

While you are reviewing the Utility Properties, note the value for the Longitudinal 
Slope (Inlet), which also happens to be 0.03ft/ft [0.03 m/m]. This value is set 
automatically when the catch basin is placed or moved. 

6. Close the properties dialog. 
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The next step is to relocate this catch basin to the corner fillet of the 
intersection. 

7. Select the catch basin, then select the Move Node manipulator. 

 

 

 

 

 

 

 

 

8. Select Snap Mode AccuSnap > Near Snap Point. 

 

 

9. Locate the catch basin and data point on 
the D-CWAY-Gutter Flow Line feature as 
shown below. Use the arrow for the 
“Exercise 3 – Position 1” text to guide you, 
but make sure that you snap to the D-
CWAY-Gutter Flow Line feature – not the 
arrow. 
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Note that the catchment area was updated when you moved the catch basin. It significantly 
reduced in size, because it is now not picking up some of the road surface runoff. The 
catchment area downstream has increased in size to fill in the gap. 

 

 

 

 

10. Check the Properties of the repositioned catch basin. 

a. First, note that the Rotation Reference has been 
retained, and the Rotation Offset, so the catch basin 
stays at 90 degrees to the gutter flow line. 

b. Next, click Open Utility Properties, then click the 
Browse icon. 
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c. Check that the text slope is still in the Property Search (if not, type it in again) 

d. Note that the Longitudinal Slope (Inlet) has changed and is now 0.04ft/ft 
[0.04m/m]. 

 

 

 

 

 

 

 

 

11. Right-click on the Road Cross Slope property, then select Units and 
Formatting. 

 

12. Change the Unit to %, then click OK. 
 

The Road Cross Slope value is now in percent, which is a more accurate result to two 
decimal places. 

Note: changing the units for the Road Cross Slope affects the Longitudinal Slope 
(Inlet) property as well, because they both use the same Slope formatter. The 
formatter is shown in the title of the Units and Formatting dialog. 

 

 

 



 

Copyright © 2021 Bentley Systems, Incorporated DO NOT DISTRIBUTE – Printing for student use is permitted 45 

Finding the Route of a Bypass Flow Path 

1. For checking the modified position of the catch basin use Home > Model Analysis > Civil 
Analysis > Analyze Trace Slope.  

This tool traces along a surface either following a user-specified slope value or the 
steepest slope. You can trace upstream or downstream. 

2. Set the settings as shown on the right. 

 

 

 

 

3. Select Snap Mode AccuSnap > Near Snap Point. 

4. Select the Terrain in the Default-3D View. 

Data point on the corner of the deflection island in the 2D Default 
View.  

The trace slope is displayed in the Default-3D View. 
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If there is any bypass flow from the catch basin on the corner of the deflection island you can see in the picture below that 
it will not be captured by the catch basin that you have just moved. 
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Moving a Catch Basin to Collect Bypass Flow 

1. Select the catch basin that you previously repositioned. 

 

 

 

2. Select Snap Mode AccuSnap > Near Snap Point. 

 

 

3. You may find it helpful to temporarily turn off the display of the Util_Storm_Areas, to 
make the location pick easier. 

If Util_Storm_Areas is the default level, you will need to make another level the default 
first, because you cannot switch off the default level. 

4. Click the Move Node manipulator. 
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5. Move the catch basin so that any bypass flow will be captured. Use the 
arrow for the “Exercise 3 – Position 2” text to guide you, but make sure that 
you snap to the D-CWAY-Gutter Flow Line feature – not the arrow. 
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Exercise 4: Checking Catch Basin hydraulics 

Description 

This exercise will look at checking the catch basins to ensure that they are hydraulically efficient.  

 

Skills Taught 

• Checking the Default Design Constraints 

• Computing the active scenario 

• Checking the hydraulic properties 
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Checking the Default Design Constraints 

When you have computed the system previously, you have used the default settings for the spread width and depth. At an intersection, 
where there may be pedestrians, you may want to reduce these values.  

1. On the Analysis ribbon, click Analysis Tools > Default Design Constraints. 

2. Click Inlet and for the Maximum Spread, set the value to 3.0’ [1.000m]. 

3. Close the dialog. 
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Compute the Active Scenario 

1. From the Analysis ribbon, select Calculation > Compute > Compute Scenario 

2. Click Messages on the GVF-Rational Calculation Summary dialog.  

3. Review the messages. Because you have changed the default design constraint for the spread width, a new warning is now being 
shown - The maximum spread constraint has been exceeded for this ‘On Grade’ inlet. 

4. Right click, Zoom To and check the positions and properties for the catch basin that have this warning. 
 
 
 
 
 
 

 

 

Note: the messages about time of concentration, no gutters, no outfall and no valid network can be ignored as this is to be expected. 

You can also click Details and review the Inlet Summary tab.  

5. Close the User Notifications dialog. 

6. Close the GVF-Rational Calculation Summary dialog.  

7. User Notifications are again highlighted by glyphs in the Default view. 
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Checking the Hydraulic Properties  

1. Select catch basin SA1-13, south of the intersection fillet, and view the 
Utility Properties. 

 

 

 

2. There are quite a lot of result fields so if you want to look at the 
spread width in the gutter just type in the word ‘spread’ in the 
Property Search. 

Note that your values may be slightly different to those shown in 
the picture on the right, because they depend on the exact 
position of the catch basin. 

 

 

 

 

 

 

You can see that the inlet is now operating at over 90% of its efficiency. 

You can also see the width of flow at the upstream face of the catch basin is over 3.0’ [1.0m]. 

This catch basin can’t be moved, because it was placed to accept bypass flow from the catch basin on the corner of the 
deflection island. A new catch basin is required. 
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3. On the Layout ribbon, click Place Node. 

4. In the Place Node dialog, set the following: 

a. Check the Feature Definition is Node > StormWaterNode > Inlets > Training 
Combination Inlet. 

b. Check the Vertical Offset is 0. 

c. Check the Rotation Mode is Relative to alignment. 

5. Following the Heads-up prompts set the following: 

a. At the Select Reference Element for Node Elevation. Reset to Type Elevation prompt, 
select the Design-Boundary terrain feature from View 2. 

b. The dialog now changes, and Catchment Delineation is now available, check this on. 

c. The Catchment Feature Definition is now available in the dialog. 

Set the Catchment Feature Definition to Drainage Area > Catchment > Pavement. 

6. Select Snap Mode AccuSnap > Near Snap Point. 

a. At the Define Catchbasin prompt, data point on the D-CWAY-Gutter Flow Line feature 
opposite the deflection island. Use the arrow for the 
“Exercise 4 – new catch basin” text to guide you, but 
make sure that you snap to the D-CWAY-Gutter Flow 
Line feature – not the arrow. 

b. Data point to accept the Rotation Mode > Relative to 
alignment 

c. At the Locate Reference Element for Rotation prompt, data point on the D-CWAY-Gutter Flow Line. 

d. Type 90 for the Rotation and Enter, then data point to accept the rotation. 

 

Because you have placed a new catch basin upstream of an existing catch basin, you need to update the catchment area for the existing 
catch basin. 
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7. Select the catch basin SA1-13, shown on the right. 

8. Click Update Catchment for Inlets. 

 

 

 

The area of the catchment is updated, and this can be confirmed using a tooltip.  

Note that you may need to right-click to cycle through the catchment areas, to select 
the one that you want. 

 

 

 

 

 

 

 

9. From the Analysis ribbon, select Calculation > Compute > Compute Scenario 

10. Select each of the two catch basins SA1-13 and SA1-18 and check the results.  
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Both catch basins are now operating at a high efficiency, and the spread width is not being exceeded. 
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11. Catch basin SA1-16 has a spread width above 3.0’ [1.0m]. 

12. Move catch basin SA1-15 downstream, towards SA1-16, until the spread width of SA1-16 is reduced to 3.0’ [1.0m] or less. 

Notes: 

• Remember to compute after you have moved catch basin SA1-15, to recalculate the spread width 

• Use the Near Point snap to position the catch basin, and double-click the icon to set it as the default 

• The correct position for catch basin SA1-15 is a little way south of catch basin SA1-6, which is on the opposite side of the road 

 

 

 

13. Turn back on the display of the Util_Storm_Areas level – if you previously turned this level off. 

The remaining maximum spread constraint has been exceeded for this ‘On Grade’ inlet warning is for catch basin SA1-8. 
This catch basin is at the low point of the road surface. 
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14. Select catch basin SA1-8 
and view the Utility 
Properties. 

15. Clear the ‘spread’ text from 
the Property Search field 

16. Change the Inlet Location 
to In Sag. 

 

17. From the Analysis ribbon, select Calculation > Compute > Compute Scenario 

18. You might notice that there is a glyph at each catch basin. Glyphs show messages that were calculated when you computed the 
scenario.  

 

 

 

 

 

 

 

 

19. In this particular case this glyph is telling you that, as you would expect, there is no subsurface network. This is because there are no 
pipes, and no outfall, so the water that arrives at the inlet is lost from the system. In effect it flows through the inlet and falls out of the 
bottom. 
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20. Select catch basin SA1-17 and view the Utility Properties. 

21. Scroll down to Results  

You can see a field called Calculation Messages, which tells you that there is 1 
message for this object. 

22. Select the browse button and view the message.  

You can see that it shows the same text as the tooltip for the glyph. 
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Exercise 5: Setting the Time of Concentration 

Description 

Warnings about the Time of Concentration are being shown in the Notifications. This warning occurs because the catchment areas do not 
have a Time of Concentration set, so the default time is used. This issue will be addressed in this exercise. 

Skills Taught 

• Setting the Minimum Time of Concentration 

• Setting the Time of Concentration for the Catchment Areas 

• Reviewing the Time of Concentration in a FlexTable 

• Computing the Design Scenario 
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Setting the Minimum Time of Concentration 

1. Click Analysis > Calculations > Options. 

2. Double click the Base Design and check the Properties. 

This is where the default value is set for the Minimum Time of Concentration for your 
catchments. This value is used if it has not been set on the individual catchment areas. 

 

 

3. Change Minimum Time of Concentration from 5.000 to 4.9999 as this value is 
just less than 5.000. 

Why are you using four decimal places – not two or three? Because the precision 
of this property is set to three decimal places, so by using four, the result will be 
displayed to three, and so appear as 5.000. 

 

 

 

 

 

You can check the precision by right clicking on the property, then 
clicking Units and Formatting. 

4. Close the Properties dialog. 

5. Close the Calculation Options. 
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Setting the Time of Concentration for the Catchment Areas 

1. On the Analysis > Calculations ribbon, click Alternatives. 

In the Alternatives dialog, locate the Hydrology > Base Hydrology Alternative. 

 

 

 

 

 

 

 

2. Double Click on Base Hydrology to view the Hydrology. 

3. Select the Catchment tab. 

4. The Time of Concentration values can be set here for 
individual or all catchments. 
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5. Right click on the Time of Concentration (min) column heading and select Global Edit. 

 

 

 

 

 

 

6. Set the value to 5 and click OK. 
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The values are now updated. 
Remember that individual 
modifications can be made if 
required. 

 

 

 

 

 

 

 

 

 

 

 

7. Close the dialog. 
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Reviewing the Time of Concentration in a FlexTable 

1. Select Analysis > Analysis Views > FlexTables. 

2. From the Drainage tab double click Tables Predefined > Catchment Table. 

 

 

 

 

 

 

 

The modified Base Hydrology for the Catchments can be 
confirmed here. 

Note that the modification could also have been made in 
this dialog. Why have two dialogs – Alternatives and 
FlexTables – that both allow modifications? FlexTables 
always show values from the current scenario, so it’s 
important that you check this before you start making 
changes. By using the Alternatives dialog, you are 
specifically choosing the Alternative to edit. Both 
workflows will achieve the same result. 

3. Close the FlexTables dialog.  

4. Close the Notifications dialog. 

5. Save Settings and Exit the software. 
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