
DO NOT DISTRIBUTE - Printing for student use is permitted

Edition 06-01

Using and Editing Terrain Models
This course is for the 2021 Release 1 version of:

OpenSite Designer CONNECT Edition
OpenRoads Designer CONNECT Edition
OpenRail Designer CONNECT Edition

About this Practice Workbook...
 This workbook is designed for use in Live instructor-led training and for OnDemand self study. OnDemand videos for 

this course are available on the LEARNserver and through CONNECT Advisor.

 This PDF file includes bookmarks providing an overview of the document. Click on a bookmark to quickly jump to any 
section in the file.

 Both Imperial and Metric files are included in the dataset. Throughout this practice workbook Imperial values are 
specified first and the metric values second with the metric values enclosed in square brackets. 
For example: 12.0’ [3.4m].

 This course workbook uses the Training and Examples WorkSpace and the Training-Imperial or
Training-Metric WorkSet delivered with the software.

 The terms “Left-click”, “Click”, “Select” and “Data” are used interchangeably to represent pressing the left mouse 
button. The terms “Right-click” and “Reset” are also used interchangeably to represent pressing the right mouse 
button. If your mouse buttons are assigned differently, such as for left-handed use, you will need to adjust accordingly.

Have a Question? Need Help?
If you have questions while taking this course, search in CONNECT Advisor for related courses and topics. You can 
also submit questions to the Civil Design Forum on Bentley Communities where peers and Bentley subject matter 
experts are available to help.

Course Level: Fundamental

http://learn.bentley.com
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Course Overview

In this course you will ... 

 Review terrain features and display, and learn to create 
thematic height displays

 Create a terrain from graphical elements

 Create a terrain from graphical elements using filters

 Learn about terrain model rules and how they affect 
editing

 Learn how to add and modify features in a terrain 
model

 Learn how to report on and resolve crossing break lines 
and conflicting points

 Learn how to remove edge triangles using the edge 
method property and the edit terrain tools

 Learn how to complex two terrain models into one 
terrain model

 Learn how to create a ‘final’ terrain model by adding 
and modifying a boundary feature
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Exercise 1: Terrain Model Review and Display

Description
In this exercise we will review what is a terrain model and then learn how to use the override symbology option to control the display of a 
referenced terrain model to view different source and computed features including the boundary, triangles, contours, and thematic height 
illustrations. 

Skills Taught
 Terrain Model Review

 Define Override Symbology and select Element Templates

 Display Terrain Model Boundary, Contours and Triangles

 Display Terrain Model Thematic Height
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Terrain Model Review

What is a Terrain Model?
A terrain model is a set of triangles mathematically computed from point data collected from the surface being modeled. They are typically 
used to model highly irregular surfaces, like the surface of the earth. A terrain model is created from 3D features such as points, break lines, 
and contours. Terrain models are also referred to as digital terrain models (DTMs), triangulated irregular networks (TINs), or triangulated 
surfaces. 

A terrain model is stored as a 3D mesh element in an OpenRoads/OpenRail Designer 3D design (.dgn) file, similar to what used to be stored 
in a GEOPAK TIN, InRoads DTM, or MX FIL file. When you select a terrain model in the design file, the Element Selection tool recognizes it 
as a Terrain Model, and the Properties and Explorer Windows will show it as a Terrain Model Element. The display of a terrain model in the 
product is controlled by using a Feature Definition and Element Template.

Being an element stored in a 3D design file, terrain models are easily shared and used by anyone using any DGN based application like 
AECOsim Building Designer, OpenPlant Modeler, or MicroStation CONNECT Edition.

Terrain Model Features
Terrain Models contain two types of features.

 Source Features are created from the source data imported to create the terrain model and include Break lines, Boundary, Imported 
Contours, Islands, Holes, Voids, and Feature Spots. 

 Calculated Features are derived or calculated from the source features and include Contours, Triangles, Spots, Flow Arrows, Low 
Points, and High Points.

Terrain Models contain two types of ‘spot’ points, Feature Spots and Spots.

 Feature Spots are a Source Feature and contain the x,y,z information from imported point data.

 Spots are a Calculated Feature and contain the x,y,z information at all of the triangle vertices in the terrain model.

In an existing terrain model, it is possible and often likely that the Feature Spots and Spots will be the same. In a complex terrain model where 
an existing terrain model and a proposed design terrain model have been combined, you will see differences in the points.
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Terrain Display with Feature Definitions, Feature Symbology and Element Templates

An important concept to understand ...

When a Terrain Model is used with the product, it is linked to a Feature Definition which provides additional intelligence such as the terrain 
models role in volume calculations (design, existing, etc.) and links to a Feature Symbology. The Feature Symbology then links to three 
Element Templates that define how the terrain model appears in plan, profile and 3D views. The Element Template defines the default display 
for the terrain model, but can be overridden when needed.

“What something is and what something looks like are separate things.”

 Feature Definition defines “what” an item is.

 Feature Symbology defines “how” the item is displayed.

 Element Templates and Annotation Groups define the detailed display settings.

Element Template Manager
Remember that a Feature Definition defines “what” an item is, and a Feature Symbology, along with its Element Templates and Annotation 
Groups, define “how” an item is displayed.

The Element Template Manager is where you set all the parameters for an Element Template. These parameters include which features are 
displayed and the symbology used to display each feature type. Some features have additional settings such as contours which have settings 
for smoothing, major and minor intervals, and labeling.

Element Templates are stored in DGN Libraries making it easy to setup standard display configurations that can be deployed and managed 
across large groups of users. 

When an Element Template is used, it is copied to the active design file model so that the model appears and behaves correctly even when 
the original DGN Library that contains the standard is not available.

The Element Templates dialog is accessed from the templates selection drop-down menu by clicking “Manage Templates...”.
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Open File and Attach Reference

The terrain model used in this exercise is in a file named Existing Ground Terrain.dgn. The terrain model will be 
attached as a reference to the active design file model.

1. Start the software.

2. Set the WorkSpace and WorkSet.

The WorkSpace and WorkSet define standards that are used by the software. The WorkSpace and WorkSet used for this training are 
installed during the software installation.

Typically, the WorkSpace contains organizational standards and the WorkSet contains project standards.

a. Select Training and Examples from the WorkSpace drop-down menu.

b. Select Training-Imperial [Training-Metric] from the WorkSet drop-down 
menu.

3. Open an existing design file and attach the existing ground terrain model 
as a reference file.

a. Select Browse

b. Browse to C:\Bentley Training\Using and Editing Terrain Models or 
other folder where you unzipped the dataset files 

c. Select the 2D design file Display Terrain Model.dgn [Metric_Display Terrain Model.dgn]. 

This is an empty design file.

Note: If you get a message stating “Incompatible Civil Data”, this is because the training files are “aligned” to OpenSite Designer. 
Clicking Yes will align the file to the software you are using (OpenRoads Designer or OpenRail Designer). This will have zero impact for 
the training courses. However, note that in production, upgrading the file will make the file read-only in OpenSite Designer. Full 
information is available at Bentley Communities - Product Realignment.

https://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/40396/video-product-realignment-incompatible-civil-data
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d. Attach the file Existing Ground Terrain.dgn [Metric_Existing Ground Terrain.dgn] as a reference by selecting Home > Primary > Attach 
Tools > References > Tools > Attach.

 Select the file Existing Ground Terrain.dgn

 Set the Attachment Method to Interactive 

 Select Open

 Set the Orientation to Coincident - World

 Select OK

e. Close the References dialog box.
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4. Fit the view so that the terrain model is visible.

5. Set the attached terrain model as Active by using the Element Selection tool to select the terrain model boundary, hover until the Context 
Sensitive Toolbar displays, then select Set As Active Terrain Model.

Setting the terrain model active automatically creates a 3D model and attaches it to the 2D design file as a reference.

Use the View Control tool to open Plan and 3D views.

6. Right-click and hold in View 1, then select View Control > 2 Views Plan/3D to open the two views. 

7. Then Fit View in both views.
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Display Terrain Model

In this section you will learn how to set the Override Symbology option for the referenced terrain model and use feature 
definitions to change the terrain display.

1. Enable Override Symbology on the Terrain Model

a. Select the Properties tool from the Home > Primary section.

b. Select the Element Selection tool and then in View 1, select the Terrain Model.

The Properties window displays information about the selected terrain model.

Note: You may also use the context sensitive toolbar to access the Properties as shown at 
the right.

2. Observe that the following parameters are grayed out and unavailable:

 Template parameter in the General section

 Edge Method in the Edge Method Section

 All parameters in the Calculated Features Display section

 All parameters in the Source Features Display section

 Feature Definition parameter in the Feature section

These parameters are grayed out because the terrain model is referenced into the current file 
and as is common with references that are read only. However, terrain models have a special 
parameter to override symbology (display) even though the reference is read only. The 
override allows the terrain model to display different in the reference without changing the 
source.
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3. In the Reference section, set Override Symbology to Yes.

4. Observe the changes to the Properties and note that the following parameters are now accessible and can be used to modify the display 
of the terrain:

 All parameters in the Calculated Features Display section

 All parameters in the Source Features Display section

 Override Template in the Reference section

5. Set the Override Template to Terrain\Existing_Boundary and note that the display in View 1 changes to show only the boundary.

Remember that Override Symbology is view dependent. Only the active view changes when you set the Override Symbology to Yes. You 
can repeat these steps for all views where the terrain model is displayed and where you want to change the display parameters.

6. Set the Override Template to Terrain\Existing_Contours and note that the display changes to show only the contours.

7. Use the On/Off toggles in the Calculated Features Display and Source Features Display sections to individually turn feature displays on 
and off.

Remember that you can double click on the feature name or on the On/Off option to toggle the setting.

Prepare the view for the steps in the next section.

8. Click in View 2, Default-3D to set that view active

9. Select the terrain model and use Properties to

 Set Override Symbology to Yes

 Set Overrride Template to Terrain\Existing_Triangles

10. Click in the view to clear the selection of the terrain model.

11. Close the Properties Window.
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Exercise 2: Create Terrain from Graphical Elements

Description
In this exercise you will learn how to import graphic elements into a terrain model using a selection set and the Create Terrain from Elements 
tool.

Skills Taught
 Create a terrain model from graphic elements
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Create Terrain from Elements

1. From the Quick Access tool bar, select Open to open the Create Terrain from Elements.dgn [Metric_Create Terrain from Elements.dgn] 
file.

Note: If you get a message stating “Incompatible Civil Data”, this is because the training files are “aligned” to OpenSite Designer. 
Clicking Yes will align the file to the software you are using (OpenRoads Designer or OpenRail Designer). This will have zero impact for 
the training courses. However, note that in production, upgrading the file will make the file read-only in OpenSite Designer. Full 
information is available at Bentley Communities - Product Realignment.

This file contains graphics representing buildings, roads and terrain features. The graphics are identified by which level in the design file 
they were placed. 

2. Close the Properties Window if it is open.

https://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/40396/video-product-realignment-incompatible-civil-data
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3. In View 1, use the Element Selection tool to select all 1222 elements in the file. 

Hint: Click Select All icon in the tool settings window.

4. Create the Terrain Model.

a. Select Terrain > Create > From Elements.

b. Set the following values in the dialog box.

 Feature Type: Break Line

 Edge Method: Remove Slivers

 Feature Definition: Existing_Triangles

 Name: Existing

c. Follow the heads up prompts and left-click for each of the following:

 DataPoint to Add 1222 selected elements

 Feature Type: Break Line

 Edge Method: Remove Slivers

d. The graphic elements are processed.
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The new terrain model is created and the terrain model triangles are displayed. While this is a valid terrain model, it might not be everything as 
desired.

One issue is that the terrain model is triangulating through the buildings which should more accurately be represented as void areas. In this 
workflow, all of the graphic elements were loaded at once and defined as break lines. An alternative workflow would be to bring in the break 
lines and the building voids in separate steps. That workflow would be something like this.

 Create a selection set with all of the elements except the buildings and create a terrain model from those elements defining them as 
break lines.

 Create a selection set with just the buildings and create a second terrain model from those elements defining them as voids.

 Use the Complex Terrain Model tool (we will learn about that later) to combine the two terrain models.

While this process works, it is a bit tedious. If you do this regularly, or have more than two types of data to load, this method would be very 
inefficient. When there are multiple feature types to load, using the Graphic Filters tools is the Best Practice method.
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Exercise 3: Create Terrain from Graphical Elements using a Filter

Description
In this exercise learn how to create filters and filter groups in the local design file and then create a terrain model with multiple feature types 
using the graphical filter.

Skills Taught
 Creating graphical filters and filter groups

 Creating a terrain model using a graphical filter

 Understanding the linkage between graphical source data and the terrain models

 Terrain model rules

 Editing linked source data
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Terrain Filters

There are two parts to the Terrain Filter Manager, Filters and Filter Groups. 

Filters define the feature type (break line, spot, void, etc.) and the filter selection criteria. Elements that meet all of the filter selection criteria 
pass the filter and are created in the terrain model with the designated feature type. The filter selection criteria includes color, level, element 
type, line style, line weights, cell names, feature definitions, transparency, element templates, and elevations. A minimum of one selection 
criteria must be defined.

Filter Groups are a combination of individual Filters that will be processed in a single operation. For example, a Filter Group might contain 
three filters. One for break lines, one for spot points, and one for void areas. Complex filter groups could contain dozens of filters. 

The Training and Examples workspace delivered with the software includes several filters and filter groups that can be used.
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Create a Graphical Filter and Filter Group

In this exercise learn how to create filters and filter groups in the local design file. It is best practice to create filters and 
filter groups in DGN Libraries that are shared throughout an organization as standards, but they can also be created in 
a local file if the filter is specific to a project and will have little value as a standard.

1. Open the 3D file Create Terrain from Graphical Filter.dgn [Metric_Create Terrain from Graphical Filter.dgn].

This file contains the same graphics that were used in the previous exercise.

2. Select the Terrain > Create > From Graphical Filter > Graphical File Manager tool to display the Terrain Filter Manger dialog box.

3. Use the scroll bar in the middle of the dialog to scroll to the top of the list view.

4. Create a Filter to load the building graphics as drape void features.

a. As necessary, expand Create Terrain from Graphical Filter [Metric_Create Terrain from Graphical Filter] in the tree view so the Filter 
Groups and Filters sections are visible as shown in the above image.
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b. Right-click on Filters and select Create Filter.

 Set Name to Buildings. If the Name field is grayed out, right click on the filter in the tree 
view and select Rename.

 Set Description to Buildings

 Set Feature Type to Drape Void

Note: The Drape Void feature type will create void features (no triangles inside the feature) 
but the elevations for the feature are not read from the graphic elements. Instead each vertex is draped onto the active terrain model 
and the elevation taken from that model.

c. Enable the Link to Terrain Features option.

Terrain elements created with this option enabled are 
automatically updated if the original graphic element is 
modified.

d. Click Edit Filter.

The Edit Filter window appears.

e. Select the Levels category.

f. Select the E_Struc_Building level and click Add->.

Hint: Double-click on the E_Struc_Building level name to 
quickly add it to the Selected Levels list.

g. Click Finish on the Edit Filter dialog.

h. Verify that the Levels option is enabled in the Filter By 
section on the Terrain Filter Manager dialog.
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5. Create a Filter to load all of the other graphics as break line features.

a. Right-click on Filters and select Create Filter.

 Set Name to Break Lines. If the Name field is grayed out, right click 
on the filter in the tree view and select Rename.

 Set Description to Break Lines

 Set Feature Type to Break Lines

 Enable the Link to Terrain Features option.

b. Click Edit Filter.

c. Select the Levels category.

d. Click All->.

All of the levels are moved to the Selected Levels column. However we 
do not want all of these levels selected.

e. Select the E_Site_Building level and click <-Remove.

f. Select the E_Struc_Building level and click <-Remove.

g. Click Finish on the Edit Filter dialog.

h. Verify that the Levels option is enabled in the Filter By section on the Terrain Filter Manager dialog.

6. Create a Filter Group that includes the Building and the Break Line filters.

a. Right-click on Filter Groups and select Create Filter Group.

 Set Name to Training

 Set Description to Break lines and voids

b. Select the Buildings and Break Lines filters from the Select Filters option.

7. Click Finish to close the Terrain Filter Manager dialog.
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Create a Terrain Model using a Graphical Filter

In this exercise learn how to use a graphical filter to create a terrain model.

1. Create a Terrain Model using the graphical filter.

a. Select the Terrain > Create > From Graphical Filter 
tool.

b. In the Create Terrain From Graphical Filter window, 
select the ellipsis  in the Graphical Filter Group 
option.

c. In the Graphical Filters dialog box, scroll up to the 
top of the list.

d. Select the Training Graphical Filter Group from the 
Active DGN.

e. Enable the Ignore Feature Linking option.

When this option is enabled an unruled terrain model 
is created without a link to the source graphic 
elements. Changes to the source graphics do not 
affect the terrain model.

When this option is disabled and if the Link to Terrain Features option is enabled in the filter, a ruled terrain model is created. Changes 
to the source graphics cause the terrain model to immediately update. Using this option on large datasets takes a significantly longer 
time to build the terrain model. 
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f. Set the following parameters in the dialog box:

 Set Edge Method to Remove Slivers.

 Set Feature Definition to Terrain > Existing > Existing Triangles.

 Set Name to Survey.

g. Left-click in the graphic view to confirm the edge method, accept solution and create the terrain 
model.

 Append to Terrain: No

h. Right-click or Esc to exit the Create Terrain Model From Graphical Filter tool.

Notice that the buildings are now voids in the 
terrain model. All of the graphic elements were 
loaded into the terrain model but the buildings were 
loaded as voids and the other elements as break 
lines.
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Terrain Model Rules

Terrain Models created using the OpenRoads Designer tools have an additional level of intelligence called rules that preserve a link between 
the source data and the terrain model so that it can be updated when revisions are made to the source data. This has very powerful 
implications for how terrain models are updated and edited. For example, terrain models created from design elements are automatically 
updated as changes are made when geometry and templates change. Unlike the past when DTMs and TINs were a result of a design 
process, terrain models are a dynamic representation of the current source data.

Sometimes it is desirable to lock or remove the rules to temporarily or permanently deactivate them. For example, there are tools to make 
minor edits to terrain models that may be necessary if the source data no longer exists or is impractical to edit. Also, large terrain models and 
terrain models shared with non-OpenRoads users may benefit from removing the rules. The Activate, Deactivate, and Remove Rules tools 
are used to change how terrain model rules are applied.

Deactivate Rule

 Temporarily deactivate rules.

 When deactivated, terrain models will not automatically update when the source data changes.

 The Edit Terrain Model tools require the terrain model to be deactivated.

Activate Rule

 Activates rules. This is the default state of a terrain model when it is created.

 Edits to source data are updated in the terrain model either automatically or using the Update from Source tool.

 If previous edits were made with the Edit Terrain Model tools they will be lost if the terrain model is set to activate rules and the rules 
are reapplied (model re-triangulated). The edits are saved if the terrain model is just set to activate rules.

Remove Rule

 Permanently removes rules. Once removed, rules cannot be reactivated, the link to the source is broken permanently.

 Improves the performance of a terrain model and is recommended for all large terrain models.

 Recommended when sharing a terrain model with non-OpenRoads/OpenRail Designer users such as MicroStation, plant, or building.

Note: Terrain Models created from Survey field books have a slightly different locking process. Instead of locking the terrain you need to 
deactivate the survey processing rules.  To do this, go to the Survey tab in the Project Explorer.  Right-click on the survey project and select 
Deactivate Survey Processing Rules.
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Editing Linked Source Data

1. Zoom into the center of the terrain model so your view is similar to the following illustration.

2. Use the Move tool (Drawing > Manipulate) to move one of the buildings to a new location.

Notice that the terrain model does not change. 

When the filters were created the Link to Terrain Features option was enabled which established a link between the graphics and the 
terrain model. However, this option works in conjunction with the Ignore Feature Linking option on the Create Terrain From Graphical 
Filter tool. Since Ignore Feature Linking is enabled, the link defined in the filter is active but the terrain model is NOT automatically 
updated.

Hint: Working with the Ignore Feature Linking enabled is recommended when numerous edits to the graphics are being made and when 
working with large terrain models. The Ignore Feature Linking option can be disabled when working with a smaller terrain model to see 
immediate updates to the terrain model.

3. Select Undo again to move the building back to its original location.
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4. Select the terrain and from the context sensitive menu select Delete to delete the terrain model.

Note that the terrain model can also be deleted using the Undo tool, but the better practice is to use the Delete tool.

5. Create the Terrain Model again using the graphical filter but with the Ignore Feature 
Linking option disabled.

a. Select the Create Terrain Model From Graphical Filter tool.

 Graphic Filter Group: Training 

 Ignore Feature Linking: Disabled

 Edge Method: Remove Slivers

 Feature Definition: Existing Triangles

 Name: Survey

b. Click in the graphic view to confirm edge method, accept solution and create the terrain model.

 Append to Terrain: No

c. Right-click to exit the Create Terrain Model From Graphical Filter tool.

6. Use the Move tool to move one of the buildings to a new location.

The terrain model updates automatically because it is linked to the source graphics.

7. Select Undo as necessary to remove the triangulation changes and to move the building back to its original location.
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Exercise 4: Updating, Analyzing and Editing Features

Description
In this exercise you will learn how to identify and fix various types of terrain model problems including adding features to the terrain model, 
changing a feature type, fixing crossing break lines, and resolving conflicting points.

Skills Taught
 Add new features to a terrain model

 Change feature types in terrain models

 Locate and correct crossing break lines in terrain models

 Review and resolve conflicting points
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Adding and Modifying Features

The source data for the terrain model may be incomplete or inaccurate and require features to be added, removed, or redefined in the 
terrain model.

1. Fit the view.

Notice that there are three buildings where the terrain model is still triangulating through the buildings.

2. Zoom into the two buildings that are side by side.

In this situation the building features are not included in the terrain model. How can we tell? Notice that there are no triangle vertices at 
the corners of the buildings.

Why were these buildings not brought into the terrain model with the other graphics? These two buildings are on a level named 
E_Site_Building. This level was not included in either of the two filters created in the previous exercise so the graphics on this level were 
never loaded.
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3. Add the Building graphics into the Terrain model

a. Select the Terrain > Edit > Add Features tool from the Terrain ribbon menu.

b. Follow the heads up prompts...

 Locate Terrain Model To Add Elements: Left-click on the terrain

 Locate Element To Add: Left-click on one of the buildings

 Locate Next Element To Add - Reset When Done: Left-click on the other building

 Locate Next Element To Add - Reset When Done: Right-click (reset)

 Feature Type: Drape Void

The terrain model updates to include the two buildings as void features.

4. Zoom to the other problem building on the southern portion of the terrain model.

Looking closely it appears this building is in the terrain model because the triangle vertices exist at the building corners. The problem is 
that the feature was incorrectly created as a break line when it should have been a void. This was caused by the graphics being on the 
wrong level.

5. Change the Feature Type of the building from Break Line to Void.

a. Select the Terrain > Edit > Change Feature Type tool.

b. Follow the heads up prompts...

 Locate Terrain Linear Feature: Select the building graphic

 Locate Next Feature To Change - Reset When Done: Right-click (reset)

 Feature Type: Drape Void

The terrain model updates with the building as a draped void feature.
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Locate and Correct Crossing Break Lines

The Report Crossing Features tool locates intersecting line features in the terrain model, such as break lines or contours. At the intersection, 
the elevations of the two features are computed and compared. The elevation for both features and the difference in elevation is provided in 
the report. An elevation tolerance value can be set to filter or limit the number of conflicts reported.

1. Select the Terrain > Analysis > Reporting > Report Crossing Features tool. 

This tool reports where two features cross. It will report on two separate features crossing as well as a single feature crossing itself.

a. Follow the heads up prompts, or enter the following values in the dialog box: 

 Select Terrain Model element: Select the terrain model

 Apply Elevation Tolerance: Yes

 Set Elevation Tolerance: 0.10 [0.03]

The report lists all the crossing feature issues, and a warning graphic is displayed in the design file at each identified feature crossing.

b. Click on the first item in the report and then select Zoom To. Your view window will zoom in tightly on the location of the crossing. Zoom 
out some so that you can see more of the two features that are crossing.

c. Close the Terrain Crossing Features Report dialog box and select Fit View.

We will fix these crossing features in the following steps.

Next, report on crossing features without applying the elevation tolerance.



Copyright © 2021 Bentley Systems, Incorporated 29DO NOT DISTRIBUTE - Printing for student use is permitted

2. Select the Terrain > Analysis > Reporting > Report Crossing Features tool.

a. Follow the heads up prompts...

 Select Terrain Model element: Select the terrain model

 Apply Elevation Tolerance: No

The report now shows all the crossing features, regardless of the elevation difference, and the associated warning symbols in the design 
file. (Note: The metric files may show different results.)

Why are there more results this time? Previously the apply tolerance value was set, so only elevation differences larger than the specified 
tolerance were reported. With the apply elevation tolerance toggled off, all feature crossings are reported, regardless of the elevation 
difference.
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Review and correct the crossing features.

3. Left-click on the items listed in the report window to highlight the following crossing features. 

4. Adjust your view using Window Area or Zoom so that you can clearly see the crossing of the features.

In this situation it appears the red feature is a general elevation break line and the blue feature represents the boundary of a traffic island. 
The Terrain Crossing Features Report window shows that there is over a 5’ [1.7 m] elevation difference between the two features. Using 
our best judgment we determine the red feature is incorrect and should be deleted.

Notice in the Terrain Crossing Features Report window that the red feature is ‘Feature Type 1’ and the blue feature is ‘Feature Type 2’.

5. Right-click on the first row Intersection Point in the report window that highlights the traffic island in blue and select DeleteFeature1.
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Note that the first two points in the list are removed because the one feature that was deleted crossed the traffic island feature in two 
locations. Also note that the source graphical element was not deleted, only the feature in the terrain model was deleted.

6. Left-click on the results in the report window to highlight the following crossing features.

7. Adjust your view using Window Area or Zoom so that you can clearly see the crossing of the features.

In this situation two break line features are crossing. The report shows the elevation difference is 0.111’ [0.034 m]. The two survey strings 
are close but are not exactly the same elevation where they cross due to the interpolation along the break lines. An acceptable solution in 
this situation is to keep both break lines and establish a new point where they cross at the average elevation of the two lines.
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8. Right-click on the first row Intersection Point in the report window that highlights the features as shown above, and select Insert a Point 
into both Features at an average Elevation.

Note that after inserting a point at an average elevation, the intersection point remains in the list at that location, but the elevation 
difference is now zero and is acceptable.
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9. Right-click on the second row Intersection Point in the report window and select Zoom To.
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10. Zoom out until you can see the ends of the lines that overlap one another.

The issue here is that the beginning and ending points of a closed shape representing a traffic island do not connect and they overlap. 

The reason for these differences is that this is a single feature that is crossing itself. The algorithm used to present the options to correct 
crossing features does not work on a single feature crossing itself. The solution is to use MicroStation tools to modify the graphics to 
move one end point to be coincident with the other end point.
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11. Select the Drawing > Modify > Modify Element tool.

12. Snap to one end point and move to the other end point. Be sure to snap to the ends of the lines to ensure an accurate move.

The Terrain Model is immediately updated.

Note: If the terrain model does not automatically update, most likely the Ignore Feature Linking option was enabled when the terrain 
model was created and the terrain is not automatically updating to changes in the source graphics.

13. Close the Terrain Crossing Features Report dialog box.

14. Select Fit View.



Copyright © 2021 Bentley Systems, Incorporated 36DO NOT DISTRIBUTE - Printing for student use is permitted

Review and Resolve Conflicting Points

Any location in a terrain model (as defined by an X, Y coordinate) can have one and only one elevation. However, the source data used to 
create the terrain model may have duplicate points (as defined by an X, Y location with the same or differing elevations). During 
triangulation, if two or more points with the same X,Y coordinates are encountered, the first point (with its elevation) is utilized, while the 
second or subsequent points which may have different elevations are ignored. The Report Conflicting Points tool utilizes the underlying 
source data for this report. 

1. Select the Terrain > Analysis > Reporting > Report Conflicting Points tool. 

This tool reports the location of duplicate points at a single X, Y coordinate that have one or more different elevations.

a. Follow the heads up prompts... 

 Select Terrain Model Element: Left-click on the terrain model

 Apply Elevation Tolerance: No

The report shows the conflicting points, the elevation difference, which points were used in the terrain model, and the associated warning 
symbols are displayed in the design file. (Note: The metric files may show different results.)

Note that in this case, the report displays “point pairs”... two points at the same X,Y or N,E with different elevations.
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2. Right-click on the Point Location in the report window that shows an Elevation Difference of 0.127 [0.039] and select Zoom To.

3. Zoom out until the location causing the issue is clearly visible.

The feature in the image on the left below should be highlighted (Point Location with 0.127 [0.039] elevation difference). 

Clicking on the “point pair” (the Point Location with the same XY/NE values) will highlight the feature and point as shown in the right 
image below. 

In this situation two break line features along a traffic island meet at an elevation difference of 0.127’ [0.039 m]. 

An acceptable solution in this situation is to establish a new point at an average elevation of the two points. 

Evaluating the elevations of the two points, the average elevation will be 203.8091’ [62.1210 m].
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Note the coordinate values of the “point pair” that will be modified to resolve the conflict.

4. Left-click on the Point Location in the list so that the feature and point shown in the above left image (0.127 [0.039]) is highlighted.

5. Right-click on the Point Location and select Set Point to Elevation and at the Enter Elevation prompt, key-in 203.8091 [62.1210].

The report window updates as shown below.

6. Left-click on the Point Location in the list of the “point pair” that shows Elevation Difference of 0.000 so that the feature and point shown 
in the above right image is highlighted.

7. Right-click on the Point Location and select Set Point to Elevation and at the Enter Elevation prompt, key-in 203.8091 [62.1210].

Note that after setting the average elevation for both points, the two entries for that point location are removed from the report.

The remaining warnings in the Conflicting Points Report all have an elevation difference of zero and require no modifications.

8. Close the Terrain Conflicting Points Report dialog box.
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Exercise 5: Remove Edge Triangles and Complex Terrain Models

Description
In this exercise you will learn multiple methods for controlling and removing edge triangles, how to complex multiple terrain models together 
and add a boundary feature to control edge triangles.

Skills Taught
 Change the triangulation edge method

 Deactivate and activate terrain rules

 Use the Delete Edge Triangle and Delete Triangle by Line tools

 Create Complex Terrain models

 Add Boundary feature 

 Modify boundary feature
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Remove Edge Triangles using the Edge Method

In this section learn how to remove unwanted terrain triangles along the outer edges of the terrain model using the Edge Method property.

1. Continue in the Create Terrain from Graphical Filter.dgn [Metric_Create Terrain from Graphical Filter.dgn] file.

2. Fit the view.

The terrain model currently uses the Sliver Edge Method to reduce unwanted edge triangles. However, there are still unwanted triangles 
in several areas as shown in the following illustration.
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3. Use the Element Selection tool and select the terrain model.

4. Hover over the terrain model and select the Properties tool from the context sensitive 
toolbar.

5. Set the Edge Method to Max. Edge Length.

6. Set the Length to 100 [30] and click in the view. 

Notice the reduction in the unwanted triangles around the edge of the terrain model.

Also notice that in several areas around the edge of the model that buildings no longer 
have terrain data around them and they are no longer draped to the terrain.

The buildings were added to the terrain as Drape Void features. With the drape void feature type, the void coordinates are not included in 
the triangulation. The void coordinates and lines are inserted and draped on the terrain model surface post triangulation. 
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7. Use the Element Selection tool and select the terrain model.

8. Hover over the terrain model and select the Properties tool from the context sensitive toolbar.

9. For the Edge Method, change the Length to 225 [70] and click in the view. 

Notice the change in the triangles around the edge of the terrain model.

Also notice that several of the buildings are again being draped to the terrain, but some are still not draped onto the terrain.



Copyright © 2021 Bentley Systems, Incorporated 43DO NOT DISTRIBUTE - Printing for student use is permitted

10. Select the terrain model again, click on Properties and change the Edge Method Length to 445 [136] and click in the view. 

11. Review all of the buildings and verify that they are draped onto the terrain model. If you still find triangles going through a building, 
continue to increase the Max. Edge Method Length value until all buildings are draped onto the terrain.

Increasing the max edge length in order for all the buildings to be draped onto the terrain brings back edge triangles that we may not want 
to be included in the final terrain model. The Edge Method, Sliver and Max. Edge Length options, is one of the tools for removing triangles 
around the boundary of a terrain, but as we have seen here, in some areas it may work well and in other areas not as well. There are 
additional tools available that can be used to remove undesired edge triangles.
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Remove Edge Triangles using the Edit Terrain Model Tools

In this section, you will learn how to use the Edit Terrain Model tools to delete triangles along the edge of the terrain 
model. This editing should be done after all other terrain model edits have been completed.

1. Select Terrain > Edit > Edit Model. This will bring up the Edit Terrain Model dialog.

There are several tools on this dialog that you may find helpful in 
modifying your terrain model. In this exercise we will use:

 Delete Edge Triangle - deletes edge triangles one at a 
time as identified and updates the boundary

 Delete Triangle by Line - deletes all edge triangles which 
intersect the line defined by two data points and updates 
the boundary

2. Select Delete Edge Triangle and follow the prompt to select the terrain model. When you try to select the terrain model, you get a 
message that says “Not an editable Terrain”. What does this mean?

When this terrain model was created using the graphical filters, the Link to Terrain Features option was enabled which established a link 
(rules) between the graphics and the terrain model. These rules preserve the connection between the source data and the terrain model 
so that the terrain model can be updated when revisions are made to the source data. 

By default, when the terrain model is created the rules are active (unlocked). 
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Let’s review how terrain models behave when the rules are activated and deactivated.

Activate Rule

 Activates rules. This is the default state of a terrain model when it is created.

 Edits to source data are updated in the terrain model either automatically or 
using the Update from Source tool.

 If previous edits were made with the Edit Terrain Model tools they will be lost if the terrain model is set to activate rules and the 
rules are reapplied (model re-triangulated). The edits are saved if the terrain model is just set to activate rules.

Deactivate Rule

 Temporarily deactivate rules.

 When deactivated, terrain models will not automatically update when the 
source data changes.

 The Edit Terrain Model tools require the terrain model rules to be deactivated.

3. Select the terrain model boundary, hover and from the context sensitive toolbar select Rules > Lock - Deactivate Rule. 

This will deactivate the rules and allow the Edit Terrain Model tools to be used

4. Select Terrain > Edit > Edit Model. This will bring up the Edit Terrain Model dialog. .

5. Select Delete Edge Triangle and follow the prompt to Select Terrain Model by left-clicking 
on the terrain model. 

6. Move the cursor to the edge of the terrain in the upper-left or Northwest corner of the 
model. When the cursor is positioned on an edge triangle, the triangle will ‘highlight’ with 
thick lines. 

7. Left-click to delete the highlighted triangle.

8. Continue to left-click and delete several more edge triangles on the NW corner. 

Note that only edge triangles can be deleted and that the boundary is automatically 
updated as the triangles are deleted. Interior triangles in the model cannot be deleted with 
this tool.
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9. Select Delete Triangle By Line and follow the prompt to Select Terrain Model by left-clicking on the terrain model.

10. Move the cursor to the edge of the terrain in the lower-right or Southeast corner of the model. 

 Prompt Point to Start Line/Reset to Select Terrain: left-click just outside the boundary line

 Prompt Point to Accept Deletion/Reset for New Start: move cursor over triangles and they will ‘highlight’ with a thick border, then 
left-click to delete

 The boundary is automatically updated

 Reset to exit the command
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Complex Terrain Models

When multiple terrain models need to be combined, the recommended best practice is to reference the terrain models into a blank file and 
create the new complex terrain model there. This keeps the complex and the source terrain models organized in separate files making it 
easier to manage your data.

1. Open the file Complex Terrain Model.dgn [Metric_Complex Terrain Model.dgn].

This is a blank 3D design file.

2. Attach the following as reference files using the Coincident World attachment method:

 Create Terrain from Graphical Filter.dgn [Metric_Create Terrain from Graphical Filter.dgn] 

 East Survey Terrain Model.dgn [Metric_East Survey Terrain Model.dgn]

3. Fit the view. 

Survey graphics and triangles are shown on the left for the terrain model we created in the previous exercise. On the right are the survey 
graphics and terrain boundary (green line) for the remainder of the project site. Remember that the terrain model display can be changed 
using override symbology and a different feature definition. These two models are edge to edge and do not overlap.
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4. Create a complex terrain model.

a. Select the Terrain > Create > Additional Methods > Create Complex Terrain Model tool.

b. Select the Survey terrain model.

c. Click Add. 

d. The Survey terrain model is added as the Primary terrain model.

e. Set the Current Action to Append.

f. The Append action defines that if the terrain models 
overlap the data from both terrain models is retained. 
The Merge action will discard data from the primary 
terrain model and only keep the data from the merge 
model.

g. Select the East Survey terrain model.

h. Click Add.

i. Set the Feature Definition to Existing Triangles.

j. Set the Name to Existing Ground Survey.

k. Click Finish. 

A new terrain model named Existing Ground Survey is 
created that is the combination of the original Survey 
and East Survey terrain models.

5. Open the Attach References dialog and turn off the two reference displays. Do not detach the references, just turn their display off.
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The result is the single new complex terrain model. The model is currently displaying the triangles based on the assigned feature 
definition Existing Triangles, but that display can be changed by changing the feature definition.

Note: The Edge Method set in the primary terrain model is applied to the combined terrain model. If your results differ from the image 
above, you can go back to the Create Terrain from Graphical Filter.dgn [Metric_Create Terrain from Graphical Filter.dgn] file and review 
what edge method was last applied to the Survey terrain model.

Also note: The edge triangles in the NW and SE corners of the Survey model that were previously deleted using the Edit Model tools 
have returned. During the processing of the Create Complex Terrain Model tool, the two terrain models are re-processed (triangulated) 
and this causes the terrain rules to be reapplied.
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Merge and Append Options

Terrain models can be combined into Complex Terrain models. The complex terrain model is not only a combination of terrain models but a 
combination that remembers the order in which terrain models are combined and how they are combined. Terrain models can be combined by 
merging or appending them together.

 Merge – The data from the primary terrain model is 
discarded and replaced with the data from the merge 
terrain model in the area where the two overlap. The two 
terrain models must overlap with at least one point.

 Append – The combined data from both terrain models is 
retained in the areas where the terrain models overlap. 
The two terrain models can overlap or be adjacent to one 
another.

When the terrain models are combined, the Edge Method of the 
primary terrain model is applied to the new combined terrain 
model.

Note: The Edit Complex Terrain Model tool is used to make changes to complex terrain models such as changing the order of the terrain 
models or the merge/append action.
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Add Boundary and Modify

In this section, you will learn how to add a boundary to the terrain model and then modify the boundary feature. The Add Boundary tool 
extracts the implied or stored boundary from a terrain and adds it to the terrain as the edge method, overriding all other edge methods. The 
tool options provide the ability to create a 3D graphic of the boundary, add a non-graphical feature to the terrain, or add an editable graphical 
boundary that is ruled to the terrain.

1. Select Terrain > Edit > Boundary Options > Add Boundary and set the following parameters in the dialog box:

 Method: Add Ruled Boundary

 Feature Definition: Linear > Terrain Feature> Terrain_Exterior

 Name: Boundary

2. At the Locate a Terrain Model prompt, click on the terrain model to identify it and then click again to accept the settings and process the 
command.

What happened?

 The boundary was added to the model as an editable boundary that is 
ruled to the terrain

 The edge method was set to From Boundary

 The terrain model was processed (triangulated)

3. Select the edge of the terrain to highlight the new boundary graphic and hover.

 The line string is on level Terrain_Exterior (from the feature definition 
setting)

 The feature context sensitive toolbar is available

 Handles are available on the line string for modifications

Note: After a boundary has been added to a terrain model, the Terrain > Edit Model tools cannot be used to edit the model.
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4. Zoom Out/In to move your view to the Northwest corner of the complexed terrain model. 

The boundary graphic may or may not be selected, it will not matter.

5. Select Drawing > Modify > Insert Vertex and click on the boundary graphic then move the cursor and click to identify the location for the 
new vertex. 

The boundary graphic and triangles are updated to reflect the change in the boundary. 

6. Zoom Out/In to move your view to the Southeast corner of the complexed terrain model.
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7. Select Drawing > Modify > Insert Vertex and click on the boundary graphic then move the cursor and click to identify the location for the 
new vertex. 

8. Zoom Out/In to move your view to the Southeastern corner of the complexed terrain model.

9. Select the edge of the terrain to highlight the boundary graphic so that the handles are visible.

10. Select Drawing > Modify > Modify Element and click on the lower left boundary handle and move the cursor and click to identify the 
location for the new vertex. 
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11. Continue to move around the model boundary and use the Modify tools - Modify Element, Insert Vertex, and Delete Vertex - to modify the 
boundary graphic to remove undesired edge triangles.

The final terrain model may look similar to the following.

Note: A boundary feature added to a terrain model will control the creation of triangles regardless of future feature edits or reprocessing 
of the terrain model.

Add Boundary Methods
 Extract Graphic - creates a graphical 3D line string that can be edited. It is just a simple graphic and is not linked to the terrain in any 

way.

 Add Boundary - extracts the current boundary for the triangulation and creates a non-graphical boundary feature within the terrain 
model and it overrules all other trimming methods (Sliver, Max Edge Length).

 Add Ruled Boundary - extracts the current boundary for the triangulation and creates an editable graphical boundary that is ruled to 
the terrain. It overrules all other trimming methods (Sliver, Max Edge Length).
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Skills Assessment

The questions below will test your retention of the skills covered in this course.

1. From the list of Terrain Model features, which ones are considered Source Features? (select all that apply).

a. Triangles

b. Boundary

c. Break lines

d. Low Points

2. From the list of Terrain Model features, which ones are considered Calculated Features? (select all that apply).

a. Contours

b. Triangles

c. Boundary

d. Break lines

e. Low Points

3. What terrain model feature type is required to be displayed in order to create a Thematic Display?

a. Voids

b. Contours

c. Breaklines

d. Triangles
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4. When a terrain model is referenced into another design file, what must be turned on so that you can change how the terrain is displayed?

a. Override Symbology

b. Feature Definition

c. Element Template

d. Triangles

5. A user should manually create a 3D model in their 2D project file.

a. True

b. False (Use the Set As Active Terrain Model command and let the software automatically create the 3D model).

6. Using a selection set to import graphics requires multiple imports in order to identify various data types such as break lines, voids, and 
contours.

a. True 

b. False

7. A Terrain Filter Group provides the ability to define a feature type (break line, spot, void, etc.) and selection criteria (level, color, element 
type, line style, etc.) for importing graphical elements to create a terrain model.

a. True 

b. False (A Terrain Filter defines the feature type and selection criteria. A Terrain Filter Group defines one or more Terrain Filters to be 
processed in a single operation).

8. The Link to Terrain Features option creates a rule that links the graphic element (source data) to the terrain model so that the terrain 
model will be updated when revisions are made to the source data.

a. True 

b. False

9. Once rules are created in terrain models they cannot be changed.

a. True 

b. False (Terrain rules can be activated, deactivated and removed).
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10. The Add Features and Change Feature Type tools can be used to add a feature to an existing terrain model or change a feature type (i.e. 
from break line to void).

a. True 

b. False

11. Terrain model edge triangles can be removed by several methods. Select all that are valid.

a. Edge Method set to Max Length

b. Add boundary

c. Edge Method set to Slivers

d. Delete Element

e. Delete Edge Triangle

12. The Create Complex Terrain Model tool is used to combine multiple terrain models into a single model with options to merge or append 
the data.

a. True 

b. False
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Skills Assessment - Answers

The answers to the skills assessment questions are highlighted below. 

1. From the list of Terrain Model features, which ones are considered Source Features? (select all that apply).

a. Triangles

b. Boundary

c. Break lines

d. Low Points

2. From the list of Terrain Model features, which ones are considered Calculated Features? (select all that apply).

a. Contours

b. Triangles

c. Boundary

d. Break lines

e. Low Points

3. What terrain model feature type is required to be displayed in order to create a Thematic Display?

a. Voids

b. Contours

c. Breaklines

d. Triangles
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4. When a terrain model is referenced into another design file, what must be turned on so that you can change how the terrain is displayed?

a. Override Symbology

b. Feature Definition

c. Element Template

d. Triangles

5. A user should manually create a 3D model in their 2D project file.

a. True

b. False (Use the Set As Active Terrain Model command and let the software automatically create the 3D model).

6. Using a selection set to import graphics requires multiple imports in order to identify various data types such as break lines, voids, and 
contours.

a. True 

b. False

7. A Terrain Filter Group provides the ability to define a feature type (break line, spot, void, etc.) and selection criteria (level, color, element 
type, line style, etc.) for importing graphical elements to create a terrain model.

a. True 

b. False (A Terrain Filter defines the feature type and selection criteria. A Terrain Filter Group defines one or more Terrain Filters to 
be processed in a single operation).

8. The Link to Terrain Features option creates a rule that links the graphic element (source data) to the terrain model so that the terrain 
model will be updated when revisions are made to the source data.

a. True 

b. False

9. Once rules are created in terrain models they cannot be changed.

a. True 

b. False (Terrain rules can be activated, deactivated and removed).
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10. The Add Features and Change Feature Type tools can be used to add a feature to an existing terrain model or change a feature type (i.e. 
from break line to void).

a. True 

b. False

11. Terrain model edge triangles can be removed by several methods. Select all that are valid.

a. Edge Method set to Max Length

b. Add boundary

c. Edge Method set to Slivers

d. Delete Element

e. Delete Edge Triangle

12. The Create Complex Terrain Model tool is used to combine multiple terrain models into a single model with options to merge or append 
the data.

a. True 

b. False
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Summary

In this course you have learned what a terrain model is and how to display, create, and edit terrain models.

Terrain models are a set of triangles stored in a 3D mesh element in a 3D design file. They contain different feature types and use Feature 
Definitions, Feature Symbology, Element Templates and Annotation Groups to control their display. Most often a terrain model is referenced 
into another design file and the Override Symbology option is enabled to allow control of the terrain model display. The thematic height display 
provides a color shaded display based on elevation, aspect angle (direction), slope and hill shade.

There are many methods available to create terrain models. In this course terrain models were created directly from graphical elements and 
from graphical elements using graphical filters and filter groups. Terrain model rules and the linking of the source data to the terrain model was 
explored and how the rules and linkage affects the terrain model when the source graphics are edited.

After a terrain model is initially created, there is often a need to make additions and revisions to the terrain model. Features were added to the 
terrain model and the feature type was changed on a current feature. Crossing break lines were located and corrected. Conflicting points were 
located, reviewed and resolved. Edge triangles were controlled with the Sliver and Max Edge Length methods and additional edge triangles 
were deleted using the Edit Model tools.

A complex terrain model was created from two terrain models and the append and merge options discussed. A boundary feature was added 
to the terrain model to control the extents of the triangulation.
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