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Detecting and Managing Utility Conflicts
This course is for the 2020 Release 3 (10.09.00.91) version of:

OpenSite Designer CONNECT Edition
OpenRoads Designer CONNECT Edition
OpenRail Designer CONNECT Edition

About this Practice Workbook...
 This workbook is designed for use in Live instructor-led training and for OnDemand self study. OnDemand videos 

for this course are available through CONNECT Advisor and on the LEARNserver.

 This PDF file includes bookmarks providing an overview of the document. Click on the bookmark to quickly jump to 
any section in the file.

 Both Imperial and Metric files are included in the dataset. Throughout this practice workbook Imperial values are 
specified first and the metric values second with the metric values enclosed in square brackets. 
For example: 12.0’ [3.4m].

 This course workbook uses the Training and Examples WorkSpace and the Training-Imperial or
Training-Metric WorkSet delivered with the software.

 The terms Left-click, Click, Select and Data are used interchangeably to represent pressing the left mouse button. 
The terms Right-click and Reset are also used interchangeably. If your mouse buttons are assigned differently, 
such as for left-handed use, you will need to adjust accordingly.

Have a Question? Need Help?
If you have questions while taking this course, search in CONNECT Advisor for related courses and topics. You can also 
submit questions to the Civil Design Forum on Bentley Communities where peers and Bentley subject matter experts are 
available to help.

Course Level: Fundamental

http://learn.bentley.com
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Exercise 1: Exploring the Design File Structure

Description
In this exercise we will start the software and review the structure of the Design File...

Skills Taught
 Setting the WorkSpace and WorkSet.

 Reference files

 Exploring 3D Views

 Exploring 3D Models
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Getting Started

In this section you will create a new design file, and attach a terrain model, existing drainage network and a utility file.

1. Start the software.

2. Set the WorkSpace and WorkSet.

The WorkSpace and WorkSet define standards that are used by the software, and the ones used for this training are installed during the 
software installation. 

Typically, the WorkSpace contains organizational standards and the WorkSet contains project standards.

a. Select Training and Examples from the WorkSpace drop-down menu.

b. Select Training-Imperial [Training-Metric] from the WorkSet drop-down 
menu.

3. Create a new 2D design file.

a. Select New File.

b. Browse to C:\Bentley Training\Detecting and Managing Utility Conflicts or other folder where you unzipped the dataset files.

c. In the File name field, key-in Managing Utility Conflicts.dgn [Metric-Managing Utility Conflicts.dgn].

d. Verify that the Seed is set to Seed2D - Imperial Site Design.dgn [Seed2D - Metric Site Design.dgn]. 

e. Select Save.

4. Select the Drainage and Utilities workflow from the ribbon bar.

5. Attach the terrain model and set it active.
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a. Select Home > Primary > Attach Tools > References and select Attach Reference.

b. Select Terrain Combined.dgn [Metric-Terrain Combined.dgn] and set the Attachment Method to Coincident World.

c. Click Open to attach the file and leave the References 
dialog open.

d. Select Fit View for View 1.

e. Use the Element Selection tool to select and hover over the 
terrain model boundary.

f. From the context menu, select Set As Active Terrain Model.

The software automatically creates the 3D model and attaches it to 
View 1, the 2D view.

g. Put your cursor in an open area of View 1, right-press and select
View Control > 2 Views Plan/3D.
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6. This will open a second view that is a 3D model view.Attach the drainage network.

7. With View 1 active, from the References dialog, select Attach Reference.

a. Select the list of files below and set the Attachment Method to Coincident World.

 Drainage.dgn [Metric-Drainage.dgn]

 Source Graphics_2D Util.dgn [Metric-Source Graphics_2D Util.dgn]

 Source Graphics_3D Util.dgn [Metric-Source Graphics_3D Util.dgn]

 Utilities via Filters.dgn [Metric Utilities via Filters.dgn]

b. Click Open to attach the file.

c. Select Fit View in both views.
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Review your file. It should look similar to the images below with a 2D Model and a 3D Model with the terrain, Utility and drainage 
network files referenced into them.
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Exercise 2: Conflict Detection - Utilities

Description
In this exercise we will determine which of our Utilities conflicts with the other Utilities:

Skills Taught
 Set up the Conflict Detection parameters (conflict targets, soft clearances, resulting Conflict Nodes)

 Review Conflict results using the Flex Tables.
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Detecting Hard Conflicts

We will now check the Gas Utilities against all the other utilities for conflicts.

Note: your results may vary from the book.

1. Remaining in Managing Utility Conflicts.dgn [Metric-Managing Utility Conflicts.dgn].

2. Ensure that the 3D view is the active view.

Note:- Conflict detection must be done in the 3D Model, the Utilities Conflict dialog is disabled if the 2D Model is active.

3. Ensure that the Display of the Utilities via Filters.dgn [Metric Utilities via Filters.dgn] reference model is ON.
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The Utilities Conflict Detection tool works with the active dgn and any reference files with their Display On.

4. Select the Workflow Subsurface Utilities > Tools > General Tools > Utility Conflicts.

If the file does not have a Utility database the first command selected will prompt you for permission to create it.



Copyright © 2021 Bentley Systems, Incorporated 10DO NOT DISTRIBUTE - Printing for student use is permitted

5. From the Subsurface Utility Conflict Detection dialog, define the two Structure Sets to be analyzed by dragging the appropriate Feature 
Definitions into the Subset boxes

Drag to Here

Drag to Here
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The Utility Conflict Detection tool is similar to Bentley Navigator’s Conflict Detection tool. It does incorporate some additional utility-
optimized functionality, including:

 Utility conflict detection creates a node feature at all conflicts. This node can be featurized and visualized the same as any other 
utility 

 Node type

 The found conflict nodes can be reported and edited in FlexTables

 Multiple conflicts between two features are identified, not just the first one

 Feature Definitions can be used to define conflict sets

 OpenRoads trenches can define soft conflict envelopes

Note: The Check These Features and Against These Features sets can be defined by Level contents or by Feature Definitions. 

6. Select Conduit\GasSegment\Gas Line (HDPE) Feature Definition and drag it to the Check This list.
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7. Select the following feature definitions and drag it to the Against That list.

 Conduit\CommunicationsSegment\Fibre Optic Cable

 Conduit\ElectricalSegment\Direct Bury Cable

 Conduit\ElectricalSegment\Electrical Duct

 Conduit\WaterSegment\Water Line (HDPE)

8. Ensure that the Allow Soft Conflict option in the Criteria tab in the upper middle of the Conflict Detection dialog is cleared.

The result of Clash Detection is a node at each conflict. The nodes can be any node defined by a Feature Definition. We need to specify 
how to represent detected conflicts. Our workspace represents a clash with a red sphere.

9. Click on the Global Options tab.
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10. For Feature Definition, select Node > ConflictNode > Conflict-Confirmed..

11. Click Process.

Status dialogs open and close. No “results confirmations or summaries” are provided, but nodes are created at the conflicts and are 
displayed in the design file. The conflict nodes obey the symbology definitions as defined by the Conflict Node Feature Definition. 

Numerous tools can be used to methodologically evaluate the conflicts.

Note: Conflict Nodes and be located vertically at the conflict itself or at a designated terrain.

12. Once Processing has finished Close the Conflict Detection dialog.
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Exercise 3: Reviewing Conflicts and Managing Results

Description
Visually inspecting the design file is a valid procedure, but it is not a “Quality Process” as it is possible to not see all the 
conflicts. A more certain process is to use FlexTables to review the Conflict Nodes.

Skills Taught
 Reporting Conflicts.

 Zoom to Conflict.
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Reviewing Conflicts and Managing Results

1. From the Drainage and Utilities Workflow, select Analysis > Analysis Views > FlexTables.

The FlexTables dialog opens showing the Predefined, Shared and Project FlexTables.

2. Double-click on the Conflict Table FlexTable.
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The Conflicts are listed in the FlexTable. The same full functionality exists for Conflict Nodes as any other structure type.

Note: your results may vary.

3. To locate a conflict from the FlexTable, select a conflict in the list Right Click and select Zoom to.
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Managing the Results

Once the conflicts have been found, engineering decisions can be made. Because existing data is often of questionable quality, 
especially elevations, a common procedure for many conflicts is to request field confirmation of the location of the existing utility. Boring or 
“pot holing” at the potential conflict location may find that 

 A conflict does not actually exist

 The existing utility may need relocation or abandonment

 The proposed design might need editing.

In many cases, a work order to evaluate the existing condition may be required. Changing the Feature Definition of the 
Conflict Node to a Field Request type is commonly the next step in managing conflict resolution.

Running another conflict detection tests does NOT delete any previously-created conflict nodes.

You will want to plan what you want to do with the existing nodes.

Do they have value (like ‘Borehole Needed’) or are you running a series of conflict tests

whose results are not “permanent”? 

The conflict nodes we just created have no long-term use, nor will any of the nodes created

in the remaining exercises. We will delete the results of each test.
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Deleting Conflict Nodes

Conflict Nodes are like any other node and can be deleted like any other node.

A preferred way to delete nodes is via selection sets created by FlexTables and Queries. Once a selection set is active, click Delete.

1. Make sure a 2D View is active, as Select in Drawing only works in 2D.

2. In the FlexTable toolbar, select the Select in Drawing icon

This highlights and creates a selection set in the drawing.

3. Click the Delete key or MicroStation Delete.

Note that double-clicking the Predefined Query Nodes > All Conflicts will also create a selection set of the conflict nodes.



Copyright © 2021 Bentley Systems, Incorporated 19DO NOT DISTRIBUTE - Printing for student use is permitted

Exercise 4: Conflict Detection - Drainage

Description
In this exercise we will check to see if any Utilities clash with our Drainage Network.

Skills Taught
 Detecting Conflicts.

 Reporting Conflicts.

 Deleting Conflicts.
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Detecting Conflicts with Drainage Design Network

1. Select Subsurface Utilities Workflow Tools > Utility Conflicts.

Ensure that you are in the display of the 3D Model view.

2. From the Subsurface Conflict Detection Dialog, Select from the list of Feature Definitions, Conduit\ElectricalSegment\Electrial Duct and 
drag into the Check These Features field.

3. Repeat the above process but drag the following in to the Against These Features.

a. Conduit\StormWater\Pipes\Circular\Storm Water (Concrete).

b. Node\StormWaterNode\Inlets\Inlet Flush Grate.

Ensure you have a Feature Definition set for the Conflict,
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4. Then Process.
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Reporting and Deleting the Conflicts

1. Select Analysis > Analysis Views > FlexTables.

2. Double Click on Conflict Table.

Results may vary!!!!

3. On the Conflict Table menu select Report in XML.
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4. Close the Report.

5. From the Conflict Menu select > Select in Drawing

6. Click the Delete key or MicroStation Delete.

This deletes the conflict nodes.
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Exercise 4: Detecting Soft Conflicts

Description
This exercise shows how to detection “near conflicts”: where utilities encroach within a tolerance distance of a utility.

Skills Taught
 Defining a Soft Clearance Distance around a utility and checking the results.
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Detecting Soft Conflicts

1. Remaining in Managing Utility Conflicts.dgn [Metric-Managing Utility Conflicts.dgn].

2. Ensure that the 3D view is the active view

3. Return to the Subsurface Conflict Detection dialog.

4. Select the Conduit\WaterSegment\Water Line(HDPE) feature definition and drag into Check These Features.

5. Select the following Utilities and drag into the Against These Features.

 Conduit\CommunicationsSegment\Fibre Optic Cable, 

 Conduit\ElectricalSegment\Electric Duct 

 Conduit\ElectricalSegment\Direct Bury Cable

6. Select the Conduit\WaterSegment\Water Line(HDPE).

7. Enable the Allow Soft Conflict check box.

8. Type a Soft Clearance of 10’ [3.0m].
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This will look for any clashes within 10 foot [3.0m] of the Water Lines.

9. Process the Conflict Detection...

Conflict nodes, including hard conflicts, are created again.

How many conflicts are there with a 10’ [3.0m] clearance?

Feel free to delete your results and try other Soft Clearance values.

Full Storm Network Clash Detection

To check the full storm network against the other utilities, simply drag all the Storm Sewer Feature Definitions and Drainage Node Feature 
Definitions into the Check This list and Process.

10. Check the Flex Tables and Review the results.
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Notice in the conflict type in the last column.

11. Delete the results from the Flex Table.
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Exercise 5: Detecting Clashes with Trenches

Description
In this exercise we will show how to identify utilities that clash with a Utility construction Trench.

Utility Feature Definitions have a setting for Trench Template, which can point to any OpenRoads “roadway” template. Templates designed for 
trenches can include bedding layers in addition to trench walls. Once a Utility exists, its Trench setting can be toggled ON or OFF. When on, it 
behaves like a linear template, being extruded along the 3D utility.

The Conflict Detection dialog has a setting where the Trench’s resulting component “Meshes” can be used as Conflict Targets.

Skills Taught
 Changing Utility Feature Definition.

 Setting the Trench Mesh as a utility conflict target.
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Amending the Feature Definition to a trench template

1. Select File > Open and browse to the data set folder and select the file Utilities via Filters.dgn [Metric-Utilities via Filters.dgn]

2. Select the 2D view

3. Zoom to the area shown below. 

The first action we are going to undertake is to change the assigned Feature Definition to one that will apply a trench template.

4. Using the Element Selection tool, select the red Electrical Direct Bury Cable that runs north to south.

5. From the Properties dialog locate the Feature tab.

select this feature
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a. Select the option for Trench and change No to Yes.

The trench should look like below. (This is a 3D view).

The trench itself is a linear template if the trench type needs to be changed then you can just change the applied template. If there is a 
need to create or amend an existing template you will need to access the Template Library and either create a new trench template or 
update an existing template.
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6. To change the template type, select the outer boundary of the trench which is the Template Drop.

7. From the Context sensitive toolbar select Edit Template drop.

a. From the editing template drop window select a different template. In this case just Cancel as we are keeping the applied template.



Copyright © 2021 Bentley Systems, Incorporated 32DO NOT DISTRIBUTE - Printing for student use is permitted

Detecting Utility Clashes with the Trench Template

1. Select File > Open and browse to the data set folder and select the file Managing Utility Conflicts.dgn [Metric-Managing Utility 
Conflicts.dgn]

2. Select the 3D view.

3. Click the Utility Conflict Detection tool.

The Feature Definitions are grouped by active and reference files; there are a number of them.

4. Drag the Conduit\ElectricalSegment\Electrical Duct Feature Definition to the Check These Features list. This utility has its trench 
displayed.
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5. Drag the Conduit\Water Segment\Water Line HDPE and Conduit\GasSegment\Gas Line (HDPE) Feature Definitions to the Against 
These Features list.

6. Click on the Conduit\ElectricalSegment\Electrical Duct in the Check This list.

7. Set the Allow Soft Conflict check box.

8. Select Use Trench Mesh in the list to the right of the Allow Soft Conflict field.

9. Under Global Options, ensure that Feature Definition is set to Node > ConflictNode > Conflict FieldCheck Needed.

10. Click Process.
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11. Review Results.

12. Flex table results.
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Summary

In this course we have learned how to detect conflicts between Utilities, a drainage network and trench meshing. Also we have learn how to 
report those clashes.
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